the Sim Settlements forums!

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Primary Bug Report Have you experienced the Scrap Crash?

Have you experienced the Scrap Crash?

  • Yes, on multiple characters

  • Yes, but only once

  • Yes, and I have an unmodded save this occurs (please send this to kinggath!)

  • No, I've never had this happen


Results are only viewable after voting.

sitheguy32

New Member
Messages
0
Hey there I’ve also experienced the scrap crash. I’m running SS and RotC on a Xbox One S. This has happened when building a generator, and scraping certain things in my settlement (Sanctuary). I’d be happy to test more things for you if needed, cheers.
 

Sajuuk333

Member
Messages
45
I, too, crash when trying to scrap in certain settlements. Had no issues until I noticed Starlight Drive-In crashed upon placing a light. Then it started crashing on connecting any power-related object. Reset the settlement (self-destructed), rebuilt, things were fine but now I could not scrap or store objects. Now I noticed placing interior plots leads to a CTD. Latest version of FO4, SS with almost all addons available, including IDEK's.
 

derogue

Member
Messages
18
I crash when scrapping objects that are built by my settlers. I'm using RotC, and before using that, I would crash when scrapping my own things. It's even more common when those objects are part of the power grid. Placing generators doesn't crash me apparently, but there was one time where I placed the vanilla industrial wall light and that crashed me. Haven't crashed from placing any items since.
 

Afetogbo

New Member
Messages
2
I ran into this issue while trying to trouble shoot CTD after fast travel. I am still working on it I am posting my journey here https://simsettlements.com/site/index.php?threads/fast-travel-issues.4560/#post-35724.
After I uninstalled all my mods and then had sim settlements installed and detonated all the local plots i kept getting ctd with the destroy everything command. After some testing i found a wire and a vanilla light post i had in town that if i scraped them I would crash. Also the elevator crashed me when i tried it.
When all the mods were reinstalled I was able to scrap it no crash. (I don't think this is the same CTD that many people get but in my research on the topic i read the most common answer was removing a mod caused the problem. although there are instances of this on vanilla i think. it is something with the power systems in towns) but forcing a crash with uninstalling mods might give some indication of where to look.
 

John Knapp

Member
Messages
31
I seem to only have this happen to me in Sanctuary (Level 2, 48%). I've only been able to scrap one item (a tire in the middle of the road) but trying to scrap anything else causes CTD. Trying to create certain items like generators or the first part of the Molecular Teleporter also caused CTD. But I can create other items. When trying to refresh the settlement, it goes through about half the refresh process then CTD, I turned off Cinematics but had the same result. I also tried just selecting a wire off a generator to see if isolating the generator would help, but got an instant CTD. I could live with this bug but I'm trying to do the "Good Ending" and that means building the Molecular Teleporter in Sanctuary.
 

John Knapp

Member
Messages
31
I seem to only have this happen to me in Sanctuary (Level 2, 48%). I've only been able to scrap one item (a tire in the middle of the road) but trying to scrap anything else causes CTD. Trying to create certain items like generators or the first part of the Molecular Teleporter also caused CTD. But I can create other items. When trying to refresh the settlement, it goes through about half the refresh process then CTD, I turned off Cinematics but had the same result. I also tried just selecting a wire off a generator to see if isolating the generator would help, but got an instant CTD. I could live with this bug but I'm trying to do the "Good Ending" and that means building the Molecular Teleporter in Sanctuary.
I cleaned a savefile with Fallrim Tools and managed to scrap Sanctuary with the Gavel, so it's now rebuilding from scratch. But still have the same CTD when scraping or building powered items. Wonder if I can build the Molecular Teleporter in Red Rocket?
 

derogue

Member
Messages
18
If anyone has All Settlements Extended installed, or any other mod that edits a settlement cell, try uninstalling it. It temporarily fixed the scrap crash for me. If you use Scrap Everything, don’t, it doesn’t play nice with Sim Settlements and it’s a very risky tool. That doesn’t mean it’s a bad mod, but it’s not optimal to use alongside Sims. Scrapped items do not come back, I learned that the hard way. I cannot stress this enough: if you use Place Everywhere, DO NOT scrap the red workbench, do not move it, don’t touch it at all. It will cause all sorts of problems in your game, and if you love building settlements, you’ll have to restart on a new character to compensate for the amount of headache-inducing bugs that are inevitably going to come your way. Another first hand experience modding safety tip I’d like to add is, be very careful if you ever decide to install a Transfer Settlements blueprint. Especially ones that contain thousands of objects and markers. They will overwhelm your workshop and you will not be able to do anything about it. The only thing you can do is save beforehand, and TEST to see if your game is still stable. Never leave and continue the game and assume everything checks out. So there you have it; everything I WISH someone would have told me before I started modding the HELL out of this game.
 
Last edited:

John Knapp

Member
Messages
31
I cleaned a savefile with Fallrim Tools and managed to scrap Sanctuary with the Gavel, so it's now rebuilding from scratch. But still have the same CTD when scraping or building powered items. Wonder if I can build the Molecular Teleporter in Red Rocket?
Tried disabling SS and cleaning savefile. Didn't help. Guess the Molecular Teleporter can be built in other settlements. Sturges goes wherever you build it. So I'll let Sanctuary do it's thing while I continue my questing.
 

Cranky Cat

Active Member
Patreon Supporter
Community Rockstar
Messages
291
It only happens to me if I build and scrap really quickly like when I've created the wrong item. I try to be careful not to scrap too quickly and that seems to work but sometimes I forget and it gets me still. Usually the chances are directly related to how long I've been building without stopping to save. :-p
 

OwenHo

BugGuy
Verified Builder
Support Team
Messages
140
aljoo
19 March 2018, 9:05PM
This Mod is so COOL! But...
I've found my game would crash during the first upgrade opportunity cinematic at Sanctuary. I then set the upgrade to auto such that it would happen without me viewing. Once I received the notification that Sanctuary had upgraded, both Fast Traveling to and manually walking to Sanctuary causes the game to crash. When manually walking the game would crash as I got to Red Rocket Truck Stop. Fast travelling to Red Rocket Truck Stop will also cause my game to crash, but I'm pretty sure Sanctuary is the issue.
Prior to upgrading Sanctuary to L1 my game would also crash if I attempted to manually build a power generator (specifically the small generator). I don't know if any other build items would cause this as I attempted the auto city upgrade shortly after noting this. City had (21) settlers at time of upgrade.
I've turned off all the performance options to see if this helps and it does not.
My game has (3) active city plans in progress.
- Hangman Alley (upgraded to L1, no issues)
- Red Rocket Truck Stop (L0)
- Sanctuary (upgraded to L1, Crashes on manual approach and fast travel)
I've probably given you a lot of useless info, but I'm afraid I'm not terribly savvy on these things...
 

FopfuMaster

Member
Messages
82
aljoo
19 March 2018, 9:05PM
This Mod is so COOL! But...
I've found my game would crash during the first upgrade opportunity cinematic at Sanctuary. I then set the upgrade to auto such that it would happen without me viewing. Once I received the notification that Sanctuary had upgraded, both Fast Traveling to and manually walking to Sanctuary causes the game to crash. When manually walking the game would crash as I got to Red Rocket Truck Stop. Fast travelling to Red Rocket Truck Stop will also cause my game to crash, but I'm pretty sure Sanctuary is the issue.
Prior to upgrading Sanctuary to L1 my game would also crash if I attempted to manually build a power generator (specifically the small generator). I don't know if any other build items would cause this as I attempted the auto city upgrade shortly after noting this. City had (21) settlers at time of upgrade.
I've turned off all the performance options to see if this helps and it does not.
My game has (3) active city plans in progress.
- Hangman Alley (upgraded to L1, no issues)
- Red Rocket Truck Stop (L0)
- Sanctuary (upgraded to L1, Crashes on manual approach and fast travel)
I've probably given you a lot of useless info, but I'm afraid I'm not terribly savvy on these things...
i kind of work around this is to when near settlement walk to settlement do not look at settlement look at ground or away from settlement. walk slowly save every minute or so. once you get into the settlement range wait for settlement to load. also when you do get in range use pipboy and refresh all plots. once done save then look at settlement if you crash reload once reloaded refresh the city this will not refresh plot nor will it destroy anything you have placed. it will only remove and replace the stuff ss built. if doing this at red rocket avoid looking at sanctuary and DO NOT use a scope to look at settlement until you can move around in settlement without crashing. This has worked for me on several occasions since i started doing this in mid feb.
Also if you have nividia card check your driver they came out with a new drive a couple weeks ago
Also if this seams to help but you have to keep doing it then you could replace the default texture graphics I used texture optimization pack which help me a ton It is a manual download and it is a huge file
I now have very few crashes mainly crash after extended play time or when I rush too fast into a settlement that is being attacked. I know this crash is not ss since I know i will crash cause textures are still loading and I run in anyways. but if saved I can just reload and everything is fine.
 

kinggath

Well-Known Member
Staff member
Administrator
Moderator
Verified Builder
Messages
4,447
Running in to a settlement while textures are still loading is absolutely a big problem with the game engine. This is primary reason for the build limit in settlements. The more textured items in place, the more likely the game is to crash. For whatever reason, the game engine doesn't handle this gracefully (by dropping FPS), but instead just hits the desktop.
 

40ksmything

Member
Messages
36
I found something common with the ctd after scrapping. I went back to play an old character that I originally played before SIm. I had all the settlements under my control with a large populous. The few settlements I allowed SS to run, I would scrap everything with the town gavel then pick my settlement map at the city desk I put down and assign my leader. When I did this at Zimonja I didn’t stick around to watch the settlers build their plots. When I came back I noticed a short guard tower and a bed mattress was left behind after running the scrap everything. The tower was tucked in at the front of the settlement under a new walkway that was created next to the ladder you can never remove. As soon as I tried to scrap it CTD. I restarted and tested again, same same. Next I removed everything from the workbench and tried to scrap the defense I left behind and same ctd. At that point I didn’t bother with it anymore and reloaded my save before I started scrapping the defense. I assumed that what was left behind after running “scrap everything” was now locked in somehow to the new settlement and as soon as I tried to get rid of the item it caused a huge problem. Before this scenario I haven’t had a ctd from scrapping since the latest patch with 2 of my other characters.
 
Last edited:

Heaser

New Member
Messages
0
I am able to consistently reproduce this bug by going to one of the settlements where I crash. (Red rocket in this case).
And looking at the power switch inside it, That instantly CTD's, Every time.
 

40ksmything

Member
Messages
36
This is a summary of what I have experienced thus far. When I scrap a settlement using the gavel it’s the only time I have ctd afterwards from scrapping. I have found on more than one occasion that after I gavel scrap a settlement and before I build a new settlement using SS I have come across what appears to be something still in the settlement just unable to see it, i.e yesterday I highlighted a corn crop from the vanilla that I had planted but could not actually see the plant (I could see the name of the plant like it was still there). As soon as I try to scrap it game crashes. If I scrap everything manually then build manually using SS plots I never get a scrap crash. At this time I can’t be shure If I can say the same if I allow SS to auto build after I manually scrap.
 
Last edited:

FopfuMaster

Member
Messages
82
This is a summary of what I have experienced thus far. When I scrap a settlement using the gavel it’s the only time I have ctd afterwards from scrapping. I have found on more than one occasion that after I gavel scrap a settlement and before I build a new settlement using SS I have come across what appears to be something still in the settlement just unable to see it, i.e yesterday I highlighted a corn crop from the vanilla that I had planted but could not actually see the plant (I could see the name of the plant like it was still there). As soon as I try to scrap it game crashes. If I scrap everything manually then build manually using SS plots I never get a scrap crash. At this time I can’t be shure If I can say the same if I allow SS to auto build after I manually scrap.
The corn you tried to scrape can you select it and move it? If so maybe if you move it or store it it will appear.
 

MrCJohn

Well-Known Member
Community Rockstar
Messages
1,509
I had a crash when I scrapped one of the city planner desks by Coots. I don't use scrap everything, but use Build High 5.0 with the scrapper's patch. bUse is set at 1. Build High 5.0 one does bUse = 0 within the settlements, without affecting performance for rest of game outside of the settlements.

John
 

tankthing

NOT the Settler AI designer
Administrator
Moderator
Verified Builder
Wiki Contributor
Messages
1,678
AFAIK, bUsePrecombinedObjects=0 is game wide. It's like being just a little bit pregnant, it's a game wide boolean.

Unless Build High 5.0 swaps the settlement cells with precombined off cells.

I'd be careful with anything that messes with precombined objects in any way, a lot of the settlement plans will have problems with that and they're straight up settlement builds.
 

tankthing

NOT the Settler AI designer
Administrator
Moderator
Verified Builder
Wiki Contributor
Messages
1,678
Sounds like you got hit with the power grid workshop corruption bug. If it's not widespread yet, you can sometimes get away with a full gavel settlement nuke and then restart the settlement.
 
Top