the Sim Settlements forums!

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Primary Bug Report Have you experienced the Scrap Crash?

Have you experienced the Scrap Crash?

  • Yes, on multiple characters

  • Yes, but only once

  • Yes, and I have an unmodded save this occurs (please send this to kinggath!)

  • No, I've never had this happen


Results are only viewable after voting.

Reakktor09

New Member
Messages
1
Reproducible CTD when I scrap something 'vanilla' (not SS stuff) that was added by City Builder itself, but only right after it has done that. Saving/Reloading and then scrapping the same thing works.

Example - Sanctuary:
* clean (!) Sanctuary, untouched by SS -> do 'scrapall'
* build settlement workbench, start city builder, assign leader, choose 'yes, tear down'
* lower end house ruins (near lower turn and bridge) will be rebuilt
* wait for completion of cutscene and relocation
* scrap one of those houses -> CTD

If I save right after completion and reload, scrapping that houses works.
 

Ludacrits

New Member
Messages
1
Im getting crashes during upgrade of sanctuary. I believe its related to scraping. I thought it might be related to some base defense turrets I built, so I went to remove them. Upon removing them the game CTD every time. It also CTD at roughly the same spot in the air fly though.

On another note, I tried to enable to debug mode through the link you provided in another post, but it doesnt seem to be working.


[Papyrus]
bEnableLogging=1
bEnableTrace=1
bLoadDebugInformation=1
bEnableProfiling=1
sDefaultLogOverlay=Papyrus

I entered that, but nothing is happening.
 

tankthing

NOT the Settler AI designer
Moderator
Messages
1,678
Try starting the upgrade and cancelling the flyaround via opening then closing the pip-boy as soon as it starts. Then just look down at the ground until the settlement says it has completed upgrading or has crashed.

Can you confirm that you are on the latest and greated Rotc expansion file as well as the Sim Settlements core and IR if you have it?
 

Ludacrits

New Member
Messages
1
The crash was significantly faster when I did the open close pipboy to stare at the ground. I am 3.1.2 on all three sim settlements. I did install IDEK's logistics station, it has been disabled and I never built anything from it.
 

tinfever

New Member
Messages
0
I think I must have a completely corrupted settlement at Oberland Station. It started with not being able to place a generator without crashing but now I can't even fast travel there without an instant crash. Crash happens with or without any mods activated. Running the latest 3.1.2 version. Crashes occur with and without the (unnecessary with the latest version) crash fix ESP and the PEX script Kinggath uploaded for someone else (I know that one was for Sanctuary but I thought I give it a try). I've also tried every sort of cleaning of the save file with Fallrim Tools I can. Clean save also didn't help. It sounds like this is a Bethesda bug but I just thought I'd put this out here. I'm happy to upload a copy of my save if it would help.
 

FopfuMaster

Member
Messages
82
I have been fighting ctd. Trying to figure out what is causing it so far to no avail. I am currently trying to use the FO4EDIT and still waiting for it to load the list. it seams to be stuck on IDEK's logistic ESL file. Just sits there on start processing. I exited out the editor and restarted it without idek selected and it populated the list without issue. Wonder if there is a error in the IDEK'S logistics ESL file. I do not want to have to start all over again seems like I get about to the same time point and it all starts all over. At first I thought it was graphic/sound issue since sometimes I get into a fight and all of sudden i get cdt and if i can avoid mass explosions i can get through. But I also get from time to time the sounds just stops for about 30-45 sec and then all sounds within that time happen all at once. This did not matter if I was in combat or not. But I am not a moder or file editor and know just enough about how to open files and maybe change things usually leading to having to completely uninstall and reinstall loosing everything. All my mods are up to date and I did run loot on them


I can really use some help here.
 

Tinuvia

Wasteland Venturers
Staff member
Moderator
Verified Builder
Support Team
Messages
953
It should according to the patch notes:
Version 3.2.1 contains the following changes:

  • Fixed circular leveled lists check
  • [FO4] Added STCP to WEAP and XPTL to REFR
  • [SSE/FO4] Basic ESL Load Order Support
  • [SSE/FO4] CC club support (ESL plugins)
  • [FO4] FO4LODGen mode
  • filtering: if 8-digits hexadecimal FormID number is provided in "Base Record EditorID contains" field, then FormID will be checked instead
  • multi selection in plugins window and similar ones, right click menu options apply to selection only
  • improved record definitions
  • new scripts
 

FopfuMaster

Member
Messages
82
ok got it to work see a bunch of red and some yellow stuff. Guess it is time to really mess the files up before i wipe and reinstall
 

FopfuMaster

Member
Messages
82
It should according to the patch notes:
Version 3.2.1 contains the following changes:

  • Fixed circular leveled lists check
  • [FO4] Added STCP to WEAP and XPTL to REFR
  • [SSE/FO4] Basic ESL Load Order Support
  • [SSE/FO4] CC club support (ESL plugins)
  • [FO4] FO4LODGen mode
  • filtering: if 8-digits hexadecimal FormID number is provided in "Base Record EditorID contains" field, then FormID will be checked instead
  • multi selection in plugins window and similar ones, right click menu options apply to selection only
  • improved record definitions
  • new scripts
well that did not go well all that time and it did not work and I broke nmm in the process might have to reinstall that
 

Nukanuka

New Member
Messages
8
I've experienced this at Castle. At this point, when trying to upgrade the settlement it crashes. I can scrap the entire settlement, but the "size" bar still shows almost full. At any point before or after scrapping the entire settlement, placing a generator will CTD. Any fix as of yet?
 

Matri

Member
Messages
22
Now experiencing this in Sanctuary.

1) Noticed a door was out of alignment. Tried to Refresh City. Silent CTD midway through.
2) Noticed a concrete base 2x2 occupying the same space as a Commercial Plot with Concrete base. Tried to scrap the extra concrete base. Instant CTD.
3) Tried to reset the city by Taking Back The City, then re-assigning the leader. Only Ada was available. Tried to scrap the Table. Instant CTD.
4) Tried to Refresh Local Plots. Silent CTD midway through.
 

Matri

Member
Messages
22
2) Noticed a concrete base 2x2 occupying the same space as a Commercial Plot with Concrete base. Tried to scrap the extra concrete base. Instant CTD.

Okay, wow. This just happened.

Used the ASAM Sensor on that particular plot, selected Refresh.

Midway through, the computer rebooted.

Didn't see a bluescreen show up. Logs don't seem to indicate any bluescreening occurred, but I'm not going to try that again.
 

tankthing

NOT the Settler AI designer
Moderator
Messages
1,678
Erm... That's not a Sim Settlements problem, guessing either your video driver crashed outright or video card or processor is overheating.
 

FopfuMaster

Member
Messages
82
Okay, wow. This just happened.

Used the ASAM Sensor on that particular plot, selected Refresh.

Midway through, the computer rebooted.

Didn't see a blue-screen show up. Logs don't seem to indicate any blue-screening occurred, but I'm not going to try that again.
hmm... had something similar before in previous play where 2 bases occupied same space. what I did was just move them both then deleted the one I did not want. then I place the one that i did want (was suppose to be there) back where it was suppose to be. when i did this I did not ctd. Never had my system reboot from doing a action before. A reboot could be a system performance/memory issue. Always a good thing to check. Also I always turn off the demolition explosions. if the settlement is level zero or 1 you could try the remote thing and see if that works. But 2 foundation occuping same space on a planned city could be a plan issue where there was a plan change and something was not removed or accidentally added.
 

Matri

Member
Messages
22
Have nearly 200 mods on my list, save is not going to be mobile.

The log I can do, if I knew how.
 

KolashackIcons

New Member
Messages
3
I've just started tinkering with RotC but i've noticed a couple of ctd's that might be related. I've noticed in Croup Manor that it happens when trying to place an interior plot (tested multiple times and multiple types of interiors) and when trying to scrap trees near the cliffline. I have not tested for these crashes in other settlements yet.
 
Top