the Sim Settlements forums!

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Primary Bug Report Have you experienced the Scrap Crash?

Have you experienced the Scrap Crash?

  • Yes, on multiple characters

  • Yes, but only once

  • Yes, and I have an unmodded save this occurs (please send this to kinggath!)

  • No, I've never had this happen


Results are only viewable after voting.

Camando

New Member
Messages
0
Hi All. I seem to have a CTD in sanctuary. It's happened before when upgrading to level 2. last time i rolled back a save and restarted the town. this time its happened without me noticing. there was a issue of my automaton bench crashing the game when i tried to store it. So i assume this to be the scrap issue. Can someone have a peak at the log for me and help me out?

I use SS 3 in 1
 

Attachments

  • Papyrus.0.txt
    53.4 KB · Views: 85
  • loadorder.txt
    1,010 bytes · Views: 40

Porthos

New Member
Messages
0
I am using horizon with the Sim settlement, but I ruled out the possibility of horizon since in other settlements are fine scrapping, but still, the problem for me is at Starlight Drive Through (from lv0- lv1). Previously after the city upgraded it cause CTD when I am approaching the settlement, but now I cancelled the upgrade, it's fine entering the settlement, but when I am trying to scrap weapons workbench it crashes the game, haven't tried scrapping other stuff yet. (NOW I am using V3.3.0 of the sim settlement. 3-in-1)
PS: I guess the scrap crash has something to do not with mods but the 'scrapall' command, so far it only occurs for the settlement I used this command and the settlement I didn't use the command remains fine.
Also, If your settlement crashes the game after city upgrade, that settlement is more likely to have scrap crash occur even the city upgrade is disabled, this occurs to me after the plots upgrades themselves and the city is not upgraded.

UPDATE: it's weird after a few days in the game, I can now upgrade my city and scrap without crashing, that problem seems temporary.
 
Last edited:

Revilo

New Member
Messages
0
Hi so following advice on this thread, I can confirm removing WOtC works and stopped my CTD. Easy decision Sim Settlements > WOtC.
 

MDA10

New Member
Messages
3
i had the scrap and generator crash before in Sanctuary.
So in my New save i did not build anything from Sim settlement assets, in Sanctuary. I built auto city building in other settlements and they seemed to be working fine without any CTD until today the Generator/scrap crash starting occur at Oberland station. The crash persists even after cleaning the settlement after detonating using the self destruction tool.

I am not using WotC either.

The other guy who posted before me said the problem is temporary so I may wait for few more days and see what happens.

-------------------------------------------------------------------

So I waited few days until the oberland station upgrades to next level.

After the upgrade the game CTDs whenever I manual/fast travel to the settlement.
The upgrade process which scraps existing structure seems to be the cause.

I am going to road the save before the upgrade to self destruct the settlement and rebuild it only by using the city building terminal.
 
Last edited:

Rocola

Active Member
Messages
320
Use the "scrap everything" option of the town meeting gavel instead of the self destruction tool from the holotape. It scraps absolutely everything scrappable. The later only destroys asam sensors and plots (cities I don´t know)
 

hmmm_gravy

New Member
Messages
0
Created an account just to contribute what I'm dealing with right now. Because I have this issue in Sanctuary. Can't scrap anything or it CTDs, can only place windmill generators, other types of gennies are a no go, as well as lights.

I'm fairly early on in the game too. So I hope this gets fixed soon. In any case I like this mod even though it's bugging out on me. Good luck!
 

falsfire1976

New Member
Messages
12
Hi all.

I *believe* the save I have recently reverted to playing is a victim of this as well. You may or may not have seen my earlier posts about missing all the RoTC city plans, that is now resolved by the way. One by one, I have been visiting my settlements to make sure they're in a good state, growing, happy etc.

I've spent the better part of a day now trying to get into the Castle. I cannot fast travel, I cannot fast travel near and walk in.

I have used the "halves" method to disable all mods except SS and its addons, and I still cannot approach very near.

With *everything* except SS disabled, I can get fairly close, but still cannot get all the way in. However, in this state I am able to get close enough for the citizen needs HUD to render. Not sure if this is close enough to trigger a self-destruct, I'm about to try that.

However, I am concerned with doing any kind of "fixing" to the save with so many mods disabled at this point, how many other corrupted things will be left in the world due to the mods being disabled?

As I am able to go anywhere else (so far) in the Commonwealth without issue, I can keep playing the save. It is finished the main story so there will be no story reason to have to visit the castle, if I need to interact with any NPCs there I can use the console to teleport them to me elsewhere.

But I want to help solve this! If indeed I am suffering this at the Castle, please tell me what I can do and/or provide to help. Please note this is a heavily modded save, 207 active plugins at full load. The uncompressed savefile is 49mb, but is clean (no unattached instances, no excessive active scripts, etc).

One question I have, is there any way to feasibly trigger a full settlement self-destruct from outside the build area? Or even a full cell reset? That way I could "fix" it without having to have most of my mods disabled, which would no doubt cause further save corruption. I really don't want to do the full Self-Destruct-All, plus, the few times I have tried that on previous saves, it just blows up anyways from the insane amount of work it has to do (most of my saves end up with ALL settlements unlocked and running, I'm a bit of an "Oxhorn" that way! )
 

Chiruadr

Active Member
Messages
89
Hi all.

I *believe* the save I have recently reverted to playing is a victim of this as well. You may or may not have seen my earlier posts about missing all the RoTC city plans, that is now resolved by the way. One by one, I have been visiting my settlements to make sure they're in a good state, growing, happy etc.

I've spent the better part of a day now trying to get into the Castle. I cannot fast travel, I cannot fast travel near and walk in.

I have used the "halves" method to disable all mods except SS and its addons, and I still cannot approach very near.

With *everything* except SS disabled, I can get fairly close, but still cannot get all the way in. However, in this state I am able to get close enough for the citizen needs HUD to render. Not sure if this is close enough to trigger a self-destruct, I'm about to try that.

However, I am concerned with doing any kind of "fixing" to the save with so many mods disabled at this point, how many other corrupted things will be left in the world due to the mods being disabled?

As I am able to go anywhere else (so far) in the Commonwealth without issue, I can keep playing the save. It is finished the main story so there will be no story reason to have to visit the castle, if I need to interact with any NPCs there I can use the console to teleport them to me elsewhere.

But I want to help solve this! If indeed I am suffering this at the Castle, please tell me what I can do and/or provide to help. Please note this is a heavily modded save, 207 active plugins at full load. The uncompressed savefile is 49mb, but is clean (no unattached instances, no excessive active scripts, etc).

One question I have, is there any way to feasibly trigger a full settlement self-destruct from outside the build area? Or even a full cell reset? That way I could "fix" it without having to have most of my mods disabled, which would no doubt cause further save corruption. I really don't want to do the full Self-Destruct-All, plus, the few times I have tried that on previous saves, it just blows up anyways from the insane amount of work it has to do (most of my saves end up with ALL settlements unlocked and running, I'm a bit of an "Oxhorn" that way! )
Interesting. I experienced the same issue 2 days ago. Could not approach, could not tp. It would crash just as soon as the cell was loaded and I was too far for remote settlement detonation . What worked was approaching from the east, spectacle island side, avoiding castle cell to load. Then as I got close half of castle loaded. There's probably 2 cells there. A quick inspection with free camera showed the sea wall loaded and the workshop (along with some buildings) and I could hit remote detonation
 

falsfire1976

New Member
Messages
12
Interesting. I experienced the same issue 2 days ago. Could not approach, could not tp. It would crash just as soon as the cell was loaded and I was too far for remote settlement detonation . What worked was approaching from the east, spectacle island side, avoiding castle cell to load. Then as I got close half of castle loaded. There's probably 2 cells there. A quick inspection with free camera showed the sea wall loaded and the workshop (along with some buildings) and I could hit remote detonation

Nice, I'm going to try that, approach from the sea. I don't have Spectacle Island yet on this character, nor do I have aqua girl. Time for some Rad-X! :)
 

NOFOSRFCSTR

New Member
Messages
0
on Xbox One X my game crashes every time I try to scarp a wall In Sanctuary.
UPDATE: I Took back the city at Sanctuary and walked over o a couple other settlements I had running and took those back as well. The crashing stopped and I was even able to place a couple turrets and fast travel to other settlements without a crash. I'll keep everyone updated on any changes.
 

persim

New Member
Messages
1
Having CTD issues with one of my settlements as soon as I scrap anything. Can place anything, but scrapping CTDs. Same with "scrapall" command. Moved settlers away from settlement. Was able to use the holotape to remove all objects/plots from the settlement. However CTD still happens if I place and scrap anything.

Is there a way to get a list of objects in a particular cell, especially the ones that start with "FFXXXXXX"? Perhaps they are causing the issue I can start by disabling these items/objects and report back.

Other settlements I can scrap and place just fine, just this particular one (Dalton Farms).
 

Labigcheeze

Member
Messages
20
Scrap crash, Sanctuary-Red Rocket, attempted to clean file with fallrim tools though cleaned file currently untested.

Both settlements were cleaned via use of forced scrapping command from a remote cell.
Would attach a file but for some dumb reason they aren't showing up.

EDIT: Save file is now completely buggered again with no way of completing the mainquest, cheers.
 
Last edited:

persim

New Member
Messages
1
Looks like I fixed my issue with the scrap crash. After doing what I did before at "Dalton Farms" I went to Fallrim Tools, opened the save, and cleared all the Script instances I had open with the *CELL* associated with "Dalton Farms". There are 4 cells, and only one of them did not had a script instance associated with it. Removed the 3, opened my game, and I could build and scrap as often as I wanted.

Fair Warning, I am not an expert on this, but it worked for me. Not responsible for screwing your save, attempt only if your save is completely messed up.
 

Cranky Cat

Active Member
Patreon Supporter
Community Rockstar
Messages
291
I recently had the power scrap issue and I suspect it had to do with deleting objects used in currently running scripts. If I waited until after everything finished I didn't have the crashes. I think some recalculations take place after deleting generators and power lines so if you have lots of connections it might be possible to delete a second object before the scripts which include that object finish executing. Anyway, that's just my guess. In my case it was on the original city plan for Somerville Place which has lots of power connectors scattered throughout the settlement on posts, trees, roofs...
 

Opiate

New Member
Messages
2
I'm getting a CTD in Sanctuary whenever I try to scrap something in the northern end of town. I was able to go to the southern end, near the bridge, and scrap some things, but the game crashes to desktop as soon as I click scrap on anything in the northern area. Same thing with trying to store items in the workshop. I did try to carry an item from the northern end to the southern end, place it down, and scrap it, but the game crashes then as well.
 

SuzanoSho

New Member
Messages
1
So is this even being worked on, or is there a workaround/reset for this bug? Would disabling city management for the affected settlement work?...
 

Rocola

Active Member
Messages
320
As far as i know it is a vanilla bug and kinggath can´t fix it. Best thing to do is not run wires in a city plan
 

Opiate

New Member
Messages
2
As far as i know it is a vanilla bug and kinggath can´t fix it. Best thing to do is not run wires in a city plan
Yes, there does seem to be a vanilla bug that is similar to this, but I don't know if it is the exact same. At the very least, it feels as if this mod may make the bug happen more often. I mean, look at the number of posts here, and that's just the number of people who have found this post and bothered to create an account.
Either way, I am hopeful that they are able to find a fix for it. These mod creators are some of the most talented I've ever seen.
 

LeopoldKain

New Member
Messages
13
I made a account just so I could follow this forum post. I removed Spring Cleaning Mod from my game. I played today and I did not CTD. I deleted a few thing and no crash.

I wanted to ask. Could the crashes be caused by mods like Place Anywhere? When my settlement upgraded today I notices power-lines and some power polls and sources where now built into walls.

I am just trying to help trouble shoot.
 
Top