the Sim Settlements forums!

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Question Workshop Framework Error in SS2 HQ


New Member
Hello, i have problem in Sim Settlements 2 with Workshop Framework. Im trying to assign Jake and Aiden to security and engineering, but i have strange error. It says "Workshop Framework Error. Unable to start barter menu system". I was looking for answer couple of hours, nothing founded. Also, i have download again and reinstalled Workshop Framework and still this message is displayed. I was trying to load older save games but it also didnt help. One thing i didnt tried yet is reinstalling SS2, but i dont think this will help. I have newest version of both SS2 and Workshop


  • Nowy-Obraz-—-mapa-bitowa.png
    3 MB · Views: 16


On a new playthrough i Have the same error in framework as author is describing. Have only essential mods loaded, but did install uf04. Had to load an older save playthrough which worked with or without uf04. Can anyone help.


Well-Known Member
if i had to guess, based on the very limited "no information" provided here, i'd suspect you have some other mod overwriting the WSFW script injections. and don't have the Workshop Framework Script Override Optional file at the bottom of your load order to fix those scripts.

by UFO4, i assume you mean UFO4P, the Unoffical Fallout 4 Patch, which does in fact overwrite the vanilla scripts and can cause this problem if it's below WSFW in your load order.

the point of the optional file is to fix up these scripts at the very bottom, after everything else that might have overwritten them is done overwriting them.


Well-Known Member
Staff member
Community Rockstar
HQ Support
For non MO2 users:
Check for loose scripts in <Steam Install Path>/Fallout 4/Data/Scripts/
If there are any Workshop<anything>.pex files, you will want to figure out what mod they are from and remove them.
(or just delete them and wait for issues to popup in the mod that requires them)
Loose files have the highest priority and will render the mentioned override patch useless.

For MO2, I don't know how it handles this. I would imagine it has some way to show loose files.


New Member
Ok, i looked in Fallout 4/Data/Scripts. There's nothing with Workshop in it's name. Also i disabled all mods not related to SS and still nothing. Now only thing im thinking of is reinstalling SS and WF. Or maybe loading older save but there is small problem. I only use Exit Save and Quick Save. Last save before them is in Vault 111. So in both cases i must start all game from the beginning.


New Member
Damn, i went here to find a solution to this exact problem.
I checked that WSFW was under UFOP, i put the override file a the very bottom of my load order (even under my Bashed patch) and still no way to make this.
I've checked all the advices on this thread and didn't find any Workshop{anything}.pex files ...
And of course all the 3 mods are up to date.