the Sim Settlements forums!

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Solved SS AIO 4.2.9a City Plan menu not working

RogueKnight24

New Member
Messages
6
Hello everyone. I recently got back into FO4 because of all the new updates, and after a couple tries managed to get a stable-ish modlist in MO2 and save. With a little patience for the scripts to kick in, I've had no real issues with SS.

However, I really wanted to try out a couple of City Plans and decided to start at Abernathy farm. Only problem is, after building the planning desk and toggling the "City Plans" blueprint static item... nothing happens. I went through Kinggath's tutorial on SS common problems, but haven't found anything quite like this.

Doing some google-fu, I noticed some people didn't have the correct version of SS, didn't have city plans add-ons or hadn't downloaded the AIO, but this was not my case since I've updated everything within the last 72 hours. I also tried running SS AIO with IR and RotC installed separately, and still no fix.

Current plugin list:
*Unofficial Fallout 4 Patch.esp
*ArmorKeywords.esm
*SettlementKeywords.esm
*HUDFramework.esm
*WorkshopFramework.esm
*Homemaker.esm
*SimSettlements.esm
*CROSS_CosmeticFramework.esm
*FAR.esl
*SimSettlements_AddOnPack_IntimateSpaces_SirLach.esl
*SimSettlements_IDEKsLogisticsStation.esl
*Alternate_Power_Sources.esl
*Alternate_Water_Sources.esl
*More NPCs Sandbox Expansion.esl
*CROSS_Wasteland_Ronin.esl
*AORobcoReconScope.esl
*ArchUniqueSettlers.esl
*SSCityPlanContest_BostonAirport_Hornet.esl
*SSCityPlanContest_BostonAirport_MadGax.esl
*SSCityPlanContest_EchoLakeLumber_aSemioticGhost.esl
*SSCityPlanContest_EchoLakeLumber_KynthiaBarnes.esl
*SSCityPlanContest_EchoLakeLumber_NDCowdy.esl
*SSCityPlanContest_MechanistsLair_Karvoc.esl
*SSCityPlanContest_OutpostZimonja_Karvoc.esl
*ThrowMoneyAtSimSett.esl
*Flicker Fixer.esp
*[Bug fix] enable placing objects on floor - All in one (English).esp
*LooksMenu.esp
*BodyTriangleEnhancer.esp
*clothingoverhaul.esp
*ClothingOverhaulSP_XB1_PC.esp
*AdvBubbleTurretSet-Real.esp
*Better Vendor Stalls.esp
*Northland Diggers.esp
*Northland.esp
*OCDecorator.esp
*3DNPC_FO4.esp
*City of Quincy.esp
*AllSetsExtended.esp
*ChildrenofBunkerHill.esp
*ChildrenofGoodneighbor.esp
*DiamondCityPlus.esp
*Diamond City Enhanced.esp
*DiamondCityMoreSecurity.esp
*DiamondCitySWAT - Vanilla Helmets Version.esp
*DiamondNewVendors.esp
*Cleaner Diamond City Indoor and Outdoor.esp
*Goodfellow's Diamond City Defences.esp
*DiamondCityAutoClose.esp
*TrainBar.esp
*VendorVariety.esp
*NeighborWatch.esp
*Child Posters.esp
*Orphans.esp
*TheInstitute.esp
*FO4 NPCs Travel.esp
*AtomicRadio.esp
*AA LMSE_FarHarbor.esp
*3DNPC_FO4Settler.esp
*BetterSettlers.esp
*BetterSettlersCleanFacePack.esp
*BetterSettlersNoLollygagging.esp
*SimSettlements_MegaPack_YearTwo.esp
*MPY2 Windmill Shack Patch.esp
*SS-PrasRandomAddon.esp
*SimSettlements_MegaPack_YearThree.esp
*home_improvement_all.esp
*IndustrialCity_Sim_Settlements_Addon.esp
*ohSIM_Sim_Settlements_Scrappers_Addon.esp
*SimHomestead.esp
*SimpleLiving.esp
*SimSettlements Previews Newest.esp
*SimSettlements_Addon_VaultLand.esp
*SimSettlements_AddOnPack_UltimateDefenses_SirLach.esp
*SimSettlements_AddOnPack_Utilities_JtBryant.esp
*SimSettlements_MegaPack_YearOne.esp
*SimSettlementsDiverseVisitors.esp
*SS MegaPackOneYear-Previews.esp
*SS_AddOn_CbC_AIO.esp
*SSAOP_SamutzVault88.esp
*TrailerParkDreams.esp
*VFXAddon.esp
*ProjectBlueprint.esp
*ProjectBlueprintCOBJs_Sim.esp
*ProjectBlueprintCOBJs_Sim_Automatron.esp
*ProjectBlueprintCOBJs_Sim_FarHarbor.esp
*ProjectBlueprintCOBJs_Sim_Nukaworld.esp
*SimSettlementChildrenSupport.esp
*SettlementMenuManager.esp
*Altairp's Animal Farm.esp
*AnotherBrickInTheWall.esp
*B84sThemedResidentials.esp
*ClassicShacks.esp
*JibsResidentialAddOnPack.esp
*SimSettlements_AddOnPack_AwsomeTown.esp
*SimSettlements_AddOnPack_Defences_Brae.esp
*SimSettlements_AddOnPack_Flags_JtBryant.esp
*SimSettlements_AddOnPack_SimTowers_JtBryant.esp
*SimSettlementsAddOnPack - RaiderRefugees.esp
*BetterJunkFences.esp
*BrighterSettlementLights.esp
*EvilViking13_WastelandWalls.esp
*GruffyddsSignsAndPosters.esp
*SignsOfTheTimesCategorized.esp
*HomePlateWorkshopSettlement.esp
*IncreasedSettlerPopulation100.esp
*MoreVaultRooms.esp
*RegsPrefabs.esp
*SanctuaryParts.esp
*g2m_Workshop_Nexus.esp
*AES_Bookcases.esp
*AkaInvisibleFurniture.esp
*Art Gallery.esp
*dinoshelf.esp
*dinoshelf_extra_ammo.esp
*ImmersiveVendors.esp
*LivingInterior.esp
*MOAR Turrets.esp
*MOAR Turrets - Hard Mode.esp
*Northland Diggers New.esp
*OCDecorator - No Experience.esp
*OCDecoratorDLC.esp
*OCDispenser.esp
*Thematic and Practical.esp
*Thematic and Practical - DLC.esp
*WeaponDisplays.esp
*Workshop_Planters.esp
*ZerasPaintings.esp
*cVc Dead Wasteland 6.esp
*cVc Dead Wasteland 6 DLC.esp
*cVc Dead Wasteland 6 DLC2.esp
*Alternate_Guard_Sources.esp
*Armorsmith Extended.esp
*Armorsmith All DLCs Patch.esp
*combat_PA.esp
*tumbajamba Advanced Engineering.esp
*combat_PA - tAE - AWKCR.esp
*Scavvers of the Commonwealth.esp
*standaloneconstruct.esp
*WastelandFashionAccessories.esp
*WastelandFashion.esp
*WVSimSAddon.esp
*SimSettlements_CityPlanPack_ContestEntries.esp
*AnS Wearable Backpacks and Pouches.esp
*AnS Wearable Backpacks and Pouches - Power Armor Carry Capacity.esp
*CorpusPraesidium.esp
*CROSS_CourserStrigidae.esp
*CROSS_Gear.esp
*CROSS_InstituteExpeditionarySuit.esp
*Eli_Armour_Compendium.esp
*EAMR.esp
*MASH.esp
*Goggles on Forehead.esp
*WIPAG_Combat_Addon.esp
*WIPAG_Contraptions_DLC_Addon.esp
*WIPAG_FarHarbor_DLC_Addon.esp
*WIPAG_NukaWorld_DLC_Addon.esp
*WIPAG_Power Armor Overhaul.esp
*WIPAG_X03_Hellfire_Addon.esp
*WIPAG_Construction_Addon.esp
*AKWCR - HellfireArmor Patch.esp
*IP4APA.esp
*Eli Armor Compendium AE Patch.esp
*Hellfirenew.esp
*Rangergearnew.esp
*Ranger-Arm.esp
*AnS Wearable Backpacks and Pouches - AWKCR.esp
*HandmadeRevolver.esp
*HandmadeRevolver - AWKCR.esp
*autoweapons.esp
*YogCrowbar.esp
*PipeShotgun.esp
*PipeShotgun-AWKCR.esp
*PlungerGun.esp
*Extended weapon mods.esp
*Swinging Meat Bags.esp
*P.L.U.N.D.E.R.esp
*Better Courser.esp
*Weapons of Fate.esp
*DV-Armored Pilots.esp
*DV-No Levelled Vertibirds.esp
*DV-Very Durable Vertibirds.esp
*PlayerComments.esp
*Settler Sandbox Overhaul.esp
*SniperDamage v2.0x.esp
*3DNPC_FO4_DLC.esp
*DLCRobot - AdditionalVoices.esp
*Dogmeat A True Companion Insanity.esp
*CompanionsGoHome.esp
*BOS_X01_Paintjobs.esp
*The Eyes Of Beauty.esp
*TheEyesOfBeauty.esp
*AzarPonytailHairstyles.esp
*BetterSettlersCCAPack2.0.esp
*RobotFactionPaint.esp
*LooksMenu Customization Compendium.esp
*BostonFPSFixAIO.esp
*Lots More Male Hairstyles.esp
*Lots More Facial Hair.esp
*SleekStylesPack.esp
*LooksMirror.esp
*Guards.esp
*FactionFlagsRedux.esp
*More Where That Came From Diamond City.esp
*Elvani's Track Pack - FIX.esp
*Extra_Tracks_Freedom.esp
*Publick Occurences.esp
*Better_Notes.esp
*Publick Occurrences Expanded.esp
*W.A.T.Minutemen.esp
*VIS-G We Are The Minutemen.esp
*BetterOpenSeason.esp
*IcebreakerCDO-Piper.esp
*Deeper Thoughts - Expressive Curie.esp
*PiperCaitCurieDialogueOverhaul.esp
*IcebreakerCDO-Settlements.esp
*Realistic_conversations - More_NPCs.esp
*Pet - Call -Feed Dogmeat.esp
*Diverse Cats.esp
*Farming Resources.esp
*SkjAlert_All_DLC.esp
*TransferSettlements.esp
*Journal.esp
*Dank_CrossArmorIntegration.esp
*Scrap Everything - Ultimate Edition.esp
*Genetical Father 1.0.1.esp
*PlayerComments_3DNPC_FO4_Patch.esp
*PlayerComments_IceBreakerCDO-Piper_Patch.esp
*PlayerComments_PiperCaitCurieDialogueOverhaul_Patch.esp
*PlayerComments_UFO4P_Patch.esp
*AmazingFollowerTweaks.esp
*Bashed Patch, 0.esp
Minor patches that don't show up as plugins:
Unofficial Fallout 4 Patch 2.1.1a
Buffout 4
Address Library for F4SE plugins
Baka ScrapHeap
MCM
HUDFramework
DEF_UI (Default)
Workshop Framework
Better COnsole
Any help would be appreciated! I'll do my best to provide more information if necessary.
 

RogueKnight24

New Member
Messages
6
Well, in case anyone else finds this looking for the same/similar issue, atm it seems to be fixed by chance. It turns out Workshop Framework wasn't updated and I installed Snappy Housekits to try it out. I switched profiles in MO2 to check if I had all my old mods up to date, moved the load order on my current profile and savegame a bit, and on a hunch decided to test the desk again and the message for City Plans popped up.
 

Philip

New Member
Messages
1
Thanks for posting your solution, it gives me hope that the menu derived from the planning desk's "City Plan" option will eventually appear for me too. Everything else about SS seems to work fine, but I'm unable to assign a leader etc. without that menu.

I reinstalled the AIO manually as the FAQ here suggested: no change. I didn't download city plan add-ons yet, but RotC already has base city plans to choose from, right? Vortex is telling me everything is up to date, and I tried an early savegame (from before using SS holotape). Sounds like playing around with load order might help since I do have a few other mods enabled. I'd really like to see what City Plans have to offer.
 

RogueKnight24

New Member
Messages
6
Best of luck, Phillip! I don't know why, but maybe it's switching profiles that does the trick because it forces MO2 to reload everything. If you want another weird fix that worked (and borked) on my Skyrim SE, disabling a plugin (something really small) sometimes also causes other mods to kick in.

This happened when I tried out the "Book of UNNP" armor mod (awful example) and realized even with the non-skimpy patches it was too much for my taste. Upon loading a save somewhere isolated, cleaning it, reloading it and waiting ingame for 3 days, the Palace Overhaul mod suddenly started working... bugging almost every single Jarl hall.
 
Top