the Sim Settlements forums!

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Can't assign mayor - "You don't control [settlement]."


New Member
Pretty much as the title says. When assigning a city mayor, I get this popup.
This came after updating Workshop Framework (the desk stopped working altogether, updating fixed it. Didn't receive the error message). This applies to all settlements, including new ones, not just the ones I already had. I've tried going to older saves, reverting the mod to old version (broke the desks again), giving up control of the settlement then re-claiming it, and so far nothing's worked. Any help would be appreciated.
Might actually be a good idea to restart regardless. If you hit that bug, chances are it's just going to keep getting worse, and you'll end up spending more time debugging than you will playing.