the Sim Settlements forums!

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Fixed Hotfix 2.0.5a: Settlers Locking Up

kinggath

Well-Known Member
Staff member
Administrator
Moderator
Verified Builder
Messages
3,678
A bug was just reported last night and I've just found the cause and a solution for PC players, unfortunately for Xbox players who have this bug, it involves resetting Sim Settlements progress.

Patch 2.0.5a was just uploaded as a hotfix to prevent this.


Do I have this bug?

If you uninstalled Industrial Revolution, or an add-on pack that made use of the Sim Settlements resource generation code, your settler scripts can become locked up. You'll know you have it if you uninstalled an add-on that you had a building for and your settlers have since stopped responding to assignment.


What can I do?

If you already have this problem, your save can be fixed on PC (explanation below), if you're having this issue on Xbox, you'll have to disable Sim Settlements, load and save your game to clear it from your save, and then re-enabled it.


I apologize deeply for this, it was never caught in testing as we're always looking for compatibility issues with installed mods, never with uninstalled. Going forward, new features will be tested with add-on pack un-installation to ensure something like this doesn't happen again.


PC Fix

Open your save with Fallrim Tools, expand Active Scripts, find any entries that start with “autobuilder:autobuildparent”, right-click on them and choose Terminate. Now save your file.
 

bludthurst

Official Wiki Manager
Staff member
Administrator
Support Team
Vault Librarian
Wiki Contributor
Messages
135
uninstalled
What if an Xbox user just deactivated Industrial revolution and/or add-on packs for testing (rather than deleting entirely)? Would/could this still happen?

having this issue on Xbox, you'll have to disable Sim Settlements, load and save your game to clear it from your save, and then re-enabled it.
On Xbox, if you have a save from before any add-on pack or Industrial Revolution was uninstalled, could you:
  1. reinstall the add-ons/Industrial Revolution that had been removed
  2. then upgrade Sim Settlements with this hotfix
  3. load up that older save
  4. make a new save and close down the game
  5. then go back in and delete the add-ons/Industrial Revolution again.
If that worked then at least someone on Xbox would not lose all of their Sim Settlements progress.

- Bludthurst
 

kinggath

Well-Known Member
Staff member
Administrator
Moderator
Verified Builder
Messages
3,678
Unfortunately, no. The bug involved in an infinite loop in the code that handles the uninstallation of the resource list from an uninstalled add-on/expansion.

The only way to end that loop on Xbox is to uninstall Sim Settlements.
 

Lunchbox88

New Member
Messages
18
So, I installed the Industrial Revo pack (and a few Sim family packs) 2-3 days ago on Xbox. As of earlier today, settlers began locking up and could not be sent on supply routes or moved to other settlements. Is this due to this bug? It sounds similar
 

kinggath

Well-Known Member
Staff member
Administrator
Moderator
Verified Builder
Messages
3,678
You could have a bug causing that, but not from Sim Settlements. You would have had to be playing with the older patch for quite a while to ever experience it.

Can you still assign your settlers to things inside of that settlement?
 

Lunchbox88

New Member
Messages
18
You could have a bug causing that, but not from Sim Settlements. You would have had to be playing with the older patch for quite a while to ever experience it.

Can you still assign your settlers to things inside of that settlement?

I can, I believe. I'll test when I get home.

I downloaded the packs, and started adding Rec plots and Advanced Industrial plots to settlements, then refreshed a few across the board for new housing. I took Nordhagen Beach, set up my power grid and plots (roughly 8 resident, 2 factory, 3 agri, advanced factory, recreational, and two martial), added a few boxcars for sardine-style bed cramming, and used the Portable Cheat Console to spawn a settler to be a provisioner. I have done this at all my other settlements with no issue. This guy, however, couldn't be assigned to a supply line or moved out of the settlement. I tried a second one, same results. I went to Finch Farm, couldn't move anyone there. Same for County Crossing. I decided I would handle things later, and started noticing nobody was moving at any settlement. I asked Reddit, they said the first spawned guy at Nordhagen might be an issue, so I Sandman'd him, and everyone else there to be safe (minus the kid). Still cant move anyone, and nobody is doing anything but standing still in the rod, on their farm plot, or on top of buildings.

EDIT:

I can reassign people. Made Codsworth a bartender at Sanctuary, and reassigned a few people at Sunshine, County Crossing, and Finch Farm.

Just checked the Sim Settlement mod, and it looks like there was an update between now and when I downloaded those packs. Running it to see if it improves anything.
 
Last edited:

kinggath

Well-Known Member
Staff member
Administrator
Moderator
Verified Builder
Messages
3,678
The next thing I would test, is to load your game with only Sim Settlements and the add-on packs to see if it's a mod conflict causing the issue. If the moving works with just those installed, it's as simple as tracking down which mod by disabling and enabling half at a time.


EDIT: Removed suggestion of Fallrim Tools - just realized you're on Xbox.
 

Lunchbox88

New Member
Messages
18
So, I've loaded up SS on its own, and still couldnt assign anyone. I just updated to 2.006000 (I believe is what it told me). At this point, should I uninstall, load/save without it, then reinstall? I lose all my settlements, essentially, but could re-do them.
 

L2K_Perma

Active Member
Staff member
Moderator
Support Team
Wiki Contributor
Messages
286
Although kinggath is best suited for this, I would suggest before uninstalling to just disable all SS mods you have installed and load in to see if the bug persists, if it does then there is another conflict, if not, then whatever kinggath says will probably be the best action.
 

Lunchbox88

New Member
Messages
18
Although kinggath is best suited for this, I would suggest before uninstalling to just disable all SS mods you have installed and load in to see if the bug persists, if it does then there is another conflict, if not, then whatever kinggath says will probably be the best action.

Good call, issue persists. Off to disable everything and load one by one.
 

L2K_Perma

Active Member
Staff member
Moderator
Support Team
Wiki Contributor
Messages
286
Alright hope you're able to find the one that is causing it.
 

L2K_Perma

Active Member
Staff member
Moderator
Support Team
Wiki Contributor
Messages
286
Dang that really sucks, sadly some bugs get hard coded into the saves and can't be fixed by disabling mods.
 

kinggath

Well-Known Member
Staff member
Administrator
Moderator
Verified Builder
Messages
3,678
That's means one of your mods is probably causing an infinite loop within the workshop - which unfortunately gets stuck at the save level.

Check out the problem mods page to see if any of those are in your load order: https://simsettlements.com/web/wiki/index.php?title=Problematic_Mods

If you want to post your mod list I can let you know of any trouble ones I've seen that aren't on that list.
 

Lunchbox88

New Member
Messages
18
That's means one of your mods is probably causing an infinite loop within the workshop - which unfortunately gets stuck at the save level.

Check out the problem mods page to see if any of those are in your load order: https://simsettlements.com/web/wiki/index.php?title=Problematic_Mods

If you want to post your mod list I can let you know of any trouble ones I've seen that aren't on that list.

Made sure I didnt have any of those before I posted :)

Mod List (in order):
- Unofficial Fallout 4 Patch
- Sim Settlements
- Sim Settlements: Industrial Revo
- Sim Settlements: Braes Defenses
- Sim Settlements: Sim Homestead
- Sim Settlements: Junk Town
- Sim Settlements: Altairp's Animal Farm
- Sim Settlements: SimTowers
- Sim Settlements: Classic Shacks
- Snappy Housekit Xbox
- HUDFramework (Added post-issue, xbox will not allow this to be ordered over Sim Settlements)
- Settlement Menu Manager (Added post-issue)
- Gorgeous Vault Girl
- Cheat Terminal
- Blacksmith's Crafting Expansion (v. 27)
- Institute Portal Gun
- Commonwealth Cuts
- Everyone's Best Friend
- WRVR- New Companion and Radio Station
- CROSS_Cybernetics
- Ponytail Hairstyles by Azar
- All Settlements Extended
- Eli's Armor Compendium
- Better Settlers XBOX
 

kinggath

Well-Known Member
Staff member
Administrator
Moderator
Verified Builder
Messages
3,678
Do you have all of the DLC?

Also, do you have any older saves of that character so you can test if the issue keeps happening if you go back in time to before you installed Sim Settlements.
 

Lunchbox88

New Member
Messages
18
Do you have all of the DLC?

Also, do you have any older saves of that character so you can test if the issue keeps happening if you go back in time to before you installed Sim Settlements.

All DLC is installed. And the purpose of this character was to use sim settlements lol. So, all saves have it.
 

kinggath

Well-Known Member
Staff member
Administrator
Moderator
Verified Builder
Messages
3,678
Most of your mods are pretty popular, so I'd look to the less popular ones as the potential problem.

Blacksmith and Portal Gun are the two I'd check on. Check there mod pages to see if people are complaining of issues.

The other thing you might try, is loading up again without mods and just wait about 15 minutes not in any menus, just leave your character in the world. After that, see if the issue clears up- it could be as simple as script lag that's making the issue stick around even after you disabled your mods.
 

L2K_Perma

Active Member
Staff member
Moderator
Support Team
Wiki Contributor
Messages
286
Only thing I can suggest then is to go back through your saves and try to see if there is one that has not been affected.
 
Top