the Sim Settlements forums!

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Following Tutorial for Add on mod making and this happens..

Metzler

New Member
Messages
13
Hey There,
Anyone that can help is amazing (Thanks in advance)
So I've followed Kinggaths tutorial for making addons - it's a fantastic guide. Here's my issue, I've followed it to the T 3 times now and every time in game when testing (with a brand new game and new saves with only Unofficial Fallout 4 patch, Sim Settlements, and my mod) I can place a residential plot, use the console commands to make it mine (so the plaque reads "Home test by Metzler) and I assign a settler and nothing happens it shows scaffolding then just shows building materials. If I use the console commands to skip it to stage 2(I've done this on fresh building plots) it still just shows building materials.

I'm racking my brain as I'm following the instructions perfectly. Any help will be greatly appreciated as I utterly love this mod and have so many ideas of things to add...
 

Kana292

Active Member
Staff member
Verified Builder
Wiki Contributor
Messages
508
First have you saved the mod changes in the Creation Kit?

Also is your #1 Level Stop for the building plan set to the Stage Model for your final Level 1 building? In this case Stage Model 2 is the Level 1 building, so Level Stop 1 is a 2.


 

Metzler

New Member
Messages
13
Hey Kana292,
Thanks for your reply! Yes I've saved with all 3 attempts even just did one where I altered one of Kinggaths building plans and made my model the final stage of his tier 1. It made it to my house then sat at the stage beforehand. So I'm assuming it's an issue with my models now, but don't know how it would be as I followed his plan.

In his plan it says set level to 1, so my levelstops are all just "1" as his tutorial shows. Yours has 2, I'm assuming you have a level 1 that is the "development phase" and level 2 is the actual stop phase?

Thanks again!
 

Kana292

Active Member
Staff member
Verified Builder
Wiki Contributor
Messages
508
Stage Model 0 will always be the building materials.
This building has 1 construction stage, that is Stage Model 1.
The actual/final Level 1 building is Stage Model 2. So the Level Stop #1 will be 2 (Telling the game the Level 1 building is the 2nd Stage Model, and stop there).

If I add a construction stage between Building level 1 and 2, it would be Stage Model 3.
Then the 2nd level building would be Stage Model 4. The Level Stops would then have an added value, #2 and it's value would be 4. Telling the game to stop at the 4th Stage Model for the Level 2 building.

It confused the heck out of me for a while. Hopefully the above makes sense.
 

Kana292

Active Member
Staff member
Verified Builder
Wiki Contributor
Messages
508
For example a 3 level building with 2 construction stages in between each level. First number is Stage Model number.

0 < Building Materials, Level Stop 0, Value 0
1 Construction Stage
2 Construction Stage
3 < Building Level 1, Level Stop 1, Value 3
4 Construction Stage
5 Construction Stage
6 < Building Level 2, Level Stop 2, Value 6
7 Construction Stage
8 Construction Stage
9 < Building Level 3, Level Stop 3, Value 9
 

Metzler

New Member
Messages
13
Thanks again lol.
I understand that completely, it makes sense to me. I've attached screenshots to show my stages that are set, it's super simple as I'm following the tutorial, one stage that's it.

Like I said, super confused as I've followed the tutorial to a T. Watching the youtube video for a second time now ontop of using the pdfs.
 

Attachments

  • setstage.png
    setstage.png
    68.2 KB · Views: 85

Kana292

Active Member
Staff member
Verified Builder
Wiki Contributor
Messages
508
Your Level Stop 0 should be a 0 for the value. Then select Add, and change the value for the new #1 Level Stop to a 1.
 

Metzler

New Member
Messages
13
Just tried that, no change still doesn't go to my design, again if I console command the plot to the stage it also doesn't show my design...
 

uituit

Secretary ;)
Moderator
Verified Builder
Support Team
Wiki Contributor
Messages
2,964
i had the same issue as well a few times
picking up the plot and putting it back down seemed to help me
 

Metzler

New Member
Messages
13
Just tried picking them up and telling it to rebuild the same model elsewhere, the plot on the right was set to stage 0 through console commands the plot on the left was set to stage 1 meaning it should have been a built house right away.

with the picking up and putting down a few times, I no longer even see building materials.
 

Attachments

  • ScreenShot0.jpg
    ScreenShot0.jpg
    886 KB · Views: 85

uituit

Secretary ;)
Moderator
Verified Builder
Support Team
Wiki Contributor
Messages
2,964
try refreshing plot 1st then moving that worked for me
but I'm novice at this 2 ,lol havnt released anything yet
 

Kana292

Active Member
Staff member
Verified Builder
Wiki Contributor
Messages
508
What does your level stop information show after updating it? Also did you save again in the creation kit after changing the building plan level stops, then restart the game?
 

kinggath

Well-Known Member
Staff member
Administrator
Moderator
Verified Builder
Messages
3,962
Usually this means there's either a corruption with, or your model file can't be found at all.
 

MaturinMods

Raider Refugees
Staff member
Verified Builder
Messages
13
On my first couple tries at making something in SS I ran into an issue like yours. I'm not sure what the cause and/or solution was but I found that trying again using a clean save (that has never had your mod installed) fixed the issue for me.

It also helps to make a base save game to use for testing. What I do is use Minuteman Empire , get the loot at concorde, go to the empty settlement I want to use for development and before I do anything I open the console and make a save that includes character_settlement_mod_test_number.

So "save Minutemen_Starlight_RaiderRef_NewPlot_01". Then every time I load know there is no chance that I have polluted SS with lots of behind the scenes changes. If it works fine and I don't want to lose my changes I make a new save "save Minutemen_Starlight_RaiderRef_NewPlot_02".

Adding/removing/renaming building plans can do weird things.
 

Metzler

New Member
Messages
13
Hey guys,
So I wiped my desktop computer of Fallout 4, and creation kit for the purpose of making these. I have a gaming laptop and xbox one I figured I'd keep as my gaming systems.
So brand new fallout 4 save that I started getting it to red rocket, I use god mode to build as I have a level 1 character.
I definitely close and reload the game every time I make changes, and I do save after the changes I make. I use to code 10 years back in high School so I'm not completely lost in this realm lol.

I have noticed I get an error message all the time while doing stuff regarding a grey mesh, it reads: TEXTURES:TEXTURE ERROR : Unable to load file 'Data\DarkGray.dds'

could that be my issue( I wouldn't think a texture would be enough to cause this problem)?

This is my 7th hour straight today working on this lmao, still can't figure it out.

PS: Kinggath thanks for your input I'm watching the youtube video and following it exactly again 4th times the charm right. Love your mod it's changed so much on how I play - can't wait to add to it!!
 

Metzler

New Member
Messages
13
Usually this means there's either a corruption with, or your model file can't be found at all.
If this is the case, what section of the tutorial may I have caused this issue at? Sorry I know such a dumb question but I know I followed your pdf to the letter 3 times, and now I'm following your youtube video exactly what you're doing - lets see if that works.
 

Metzler

New Member
Messages
13
@kinggath just followed your video tutorial exactly, just as I had previously and this time instead of stalling on building materials, it then cycled to another home and started building it - I checked before it cycled the plaque showed my build as the unit.

So A- fantastic problem solving built into the mode!
B - what the heck do I do now. I swear I followed your pdf and video EXACTLY. I'm so lost I started this around 1pm today it's now 10:30 lol. I want to add to this mod so bad :(.
Where could I have gone wrong?
 

Metzler

New Member
Messages
13
@kinggath thanks so much for the offer, you're all going to kill me though.

Since I deleted fallout 4, it removed the two lines of code from the custom.ini file that allow outside mods.. since I added sim settlements through bethesda.net so it was on both my laptop and desktop it didn't remind me. I just decided to put Dustbowl on my list, and it required nexus download and nexus mods reminded me - added that in and went and tested it ..... F..ING worked - so pissed at myself lmao.

Thank you everyone who offered advice and help, I really appreciate it.
 
Top