Question Why doen't local settings use Global settings?

Discussion in 'SS Help (Mod Questions Here)' started by Iztari, Jul 13, 2019.

  1. Iztari

    Iztari Member Verified Builder

    Joined:
    Jul 13, 2019
    Messages:
    52
    Likes Received:
    91

    It has always bugged me that Local plot settings always ignore the default Global settings, when you start to become my age and becoming forgetfull and wonder why you settlement doesn't have any trade routes any more. Or why the heck that robot is just idling with a pack-brahmin for days, until you go into workshop mode and wonder: "Why is it a storemanager now? Didn't I set set Auto-assign work thingy to OFF?"

    So shouldn't the Global Settlements settings, become the Local settings by default when you create a new settlement (or change city plan)?
     
  2. kinggath

    kinggath Well-Known Member Staff Member Administrator Moderator Verified Builder

    Joined:
    May 8, 2017
    Messages:
    3,516
    Likes Received:
    3,013

    The local settings are supposed to only be applies when you start a game if you used the Conqueror prebuild system. If you are seeing otherwise, then there's a bug - in which case, any specifics you can give leading up to this would be helpful to try and track it down.
     
  3. Iztari

    Iztari Member Verified Builder

    Joined:
    Jul 13, 2019
    Messages:
    52
    Likes Received:
    91

    I have no clue what caused the problem, but I had to reinstall my computer from scratch and after that the problem is gone, but thanks anyway :)
     
  4. Iztari

    Iztari Member Verified Builder

    Joined:
    Jul 13, 2019
    Messages:
    52
    Likes Received:
    91

    Well... it seems that it only affects some settlements, so far In my new game it works "normal" except for Finch Farm. Every time it loads a new cityplan, the local settings for the settlement is set independently from the Global settings, to an "easier" settings if you understand what I mean.

    (EDIT: Adding a few screendumps to show what I mean, these are from just after "unlocking" The Slog via "normal" quest, with Conqurer installed).
    Local Settings.png Global Settings (Assignment).png Global Settings (Difficulty).png
     
    Last edited: Jul 20, 2019
  5. kinggath

    kinggath Well-Known Member Staff Member Administrator Moderator Verified Builder

    Joined:
    May 8, 2017
    Messages:
    3,516
    Likes Received:
    3,013

    Ahh yeah, that's normal. There is a setting called Involvement under City Building.

    Involvement changes City Plan run settlements to use Local options so that those City Plan's will operate with the level of Involvement you'd expect. One of the Involvement options is Defaults, which will keep the settlements using the global options.
     
    bullyrook likes this.
  6. Iztari

    Iztari Member Verified Builder

    Joined:
    Jul 13, 2019
    Messages:
    52
    Likes Received:
    91

    UPDATE: It seems that all my current settlements have reverted to "the easier" settings.
     
  7. Iztari

    Iztari Member Verified Builder

    Joined:
    Jul 13, 2019
    Messages:
    52
    Likes Received:
    91

    Ahh... me soo stupid sometimes :crazy
    I have never fiddled with that setting before, and I am dyslexic so reading isn't alway my strong point...
     

Share This Page