Unable to assign settlers to anything

Discussion in 'Workshop Framework Bug Reports Archive' started by spike10164, Oct 26, 2018.

  1. spike10164

    spike10164 New Member

    Joined:
    Oct 26, 2018
    Messages:
    0
    Likes Received:
    2

  2. woodfuzzy

    woodfuzzy Probably a Synth or... Verified Builder

    Joined:
    May 18, 2017
    Messages:
    1,408
    Likes Received:
    1,022

    Basically.. you're overloading your system.
    The scripts *should* clear out on their own. Try going to an interior cell like Home Plate, open the Radio tab and let the game run for a good 1/2 hour or so. Save, exit & reload.
    Save again and check the save to see if they are clearing out.
     
    RayBo likes this.
  3. spike10164

    spike10164 New Member

    Joined:
    Oct 26, 2018
    Messages:
    0
    Likes Received:
    2

    I let the game run while I was in Home Plate for a half hour, and the active scripts actually went up a few. Is there anything else I can do? I've also waited in other settlements before and nothing changed.
     
  4. kinggath

    kinggath Well-Known Member Staff Member Administrator Moderator Verified Builder

    Joined:
    May 8, 2017
    Messages:
    3,620
    Likes Received:
    3,231

    PackAttack and War of the Commonwealth are two of the worst offenders for overdoing it on scripting. They tend to cause massive backups.

    Though based on your active scripts it does appear that your workshop scripts are stuck.

    Try running this console command:

    cqf workshopparent UFO4P_ReleaseLock (that's You Ef Oh Pee, as in Unofficial Fall Out 4 Patch - don't worry if you don't have the patch, WSFW implements some functions from it for compatibility reasons)

    After running that command, try waiting in Homeplate again for a bit and check again.
     
    Loredena likes this.
  5. The Typical Idiot Fan

    The Typical Idiot Fan Active Member Community Rockstar

    Joined:
    Jul 6, 2017
    Messages:
    392
    Likes Received:
    159

    God bless Greslin for his mod, but PackAttack is usually the biggest offender of script backup in my logs. Usually the thing that causes me to crash, too.
     
  6. spike10164

    spike10164 New Member

    Joined:
    Oct 26, 2018
    Messages:
    0
    Likes Received:
    2

    I use UFO4P and I've uninstalled Pack Attack the other day since I saw it create a lot of script backup. I will use the command and report back soon.
     
  7. spike10164

    spike10164 New Member

    Joined:
    Oct 26, 2018
    Messages:
    0
    Likes Received:
    2

    Wow, that worked like a charm! For future reference, I also deleted some leftover "Packattack" scripts in Data/Scripts/, and then did "cqf workshopparent UFO4P_ReleaseLock" a couple times. I went to Starlight Drive inn and sent someone as a supply line to Egret Tours and they went right away, so thank you very much Kinggath!
     
    Loredena and SavageRock like this.

Share This Page