the Sim Settlements forums!

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Researching Still CTD with 3.2.1

kinggath

Well-Known Member
Staff member
Administrator
Moderator
Verified Builder
Messages
3,897
Oh yeah, that definitely sounds like it could be the problem! Do you have a save from before you cleared RR you could upload to dropbox.com? Would be interesting to see if the entire place had duplicated 8 times. If so, that could be the explanation for why some folks have trouble and others don't - if there is a bug that allows a settlement to recreate itself indefinitely - then of course some people would be crashing!
 

Cranky Cat

Active Member
Patreon Supporter
Community Rockstar
Messages
291
If I could export with Transfer Settlements without it crashing then we could check :) I'm not sure if it's just clutter or pieces of the plots or the entire set of objects though. Can you do much with the save with just Fallout and Sim Settlements mods installed? If my backups hadn't been borked I could get a save from before it was level 3 :-(

I'll upload a copy after work along with a text file showing the load order.
 

woodfuzzy

Probably a Synth or...
Verified Builder
Messages
1,403
Finally loaded the live version... Got the CrashWatch 3.0 popup. lol
 

Cranky Cat

Active Member
Patreon Supporter
Community Rockstar
Messages
291
I uploaded my save and sent a message with the link and info. I managed to export the Red Rocket settlement but it doesn't show the duplicated objects since they are generated on the plot.

Also, if someone applies performance settings it queues up plot updates. What happens if I change the settings again before the first finishes? Does it clear out the rebuild queue first or does it just add the plots again so some will build multiple times? I may have done that as well :-|
 

kinggath

Well-Known Member
Staff member
Administrator
Moderator
Verified Builder
Messages
3,897
The plots just trigger a refresh after you change settings, so it won't force duplicates.

I'm out of town until next weekend, but I will use your save for investigating changes for the next patch - thanks!
 

Cranky Cat

Active Member
Patreon Supporter
Community Rockstar
Messages
291
btw, I built a desk right in the road from concord at the edge of the settlement and was able to refresh the city successfully. It didn't help though :oops: Thanks for all of your help and have a safe trip!
 

Cranky Cat

Active Member
Patreon Supporter
Community Rockstar
Messages
291
Actually, I *think* the first apply performance settings completes before starting the second one and completes both of them. I did the wait in the interior thing and the builds didn't actually complete until the second time the message about having applied the settings displayed. If that's true then perhaps clear any previous incomplete operations before queuing a new one? I'd want to test on a smaller save though :)

I suspect that if you change your mind after applying settings it'll be building in the background twice as long.
 

kinggath

Well-Known Member
Staff member
Administrator
Moderator
Verified Builder
Messages
3,897
Canceling existing running functions midway through is pretty difficult and requires a lot of pre-planning and inefficient code. We have a very limited amount of things we can do with the scripting engine, it isn't at all a full featured programming language.

Usually I try and just prevent it from running again if a run is already going, though maybe I didn't do that for performance settings changes...
 

Cranky Cat

Active Member
Patreon Supporter
Community Rockstar
Messages
291
Alas, I still get CTDs even when moving away south from the empty Red Rocket after all the rebuilds finished. I still think the cell unload/load scripting is getting a CTD for me but it's hard to tell. I'll inevitably keep looking for that elusive silver bullet to avoid it or at least something to explain it while you are away. :)
 

kinggath

Well-Known Member
Staff member
Administrator
Moderator
Verified Builder
Messages
3,897
Are you able to leave the cell with the coc command?
 

Cranky Cat

Active Member
Patreon Supporter
Community Rockstar
Messages
291
I'll try the coc and see. The crash doesn't always happen though. If I reload and try again it can work.

Also, funny question possibly related:

What if I do this:

1. Turn on all performance options including clutter and wait for the confirmation that settings have been applied.
2. Build a plot with lots of clutter.
3. Turn off all performance options and wait for the rebuilds to finish.

Will the clutter be deleted on the rebuild even though the clutter settings now have it disabled?
 

Cranky Cat

Active Member
Patreon Supporter
Community Rockstar
Messages
291
Well, I leveled Sanctuary and didn't have bits and pieces left over so that seems to be plot-specific. Also, I still got a CTD walking through the empty Red Rocket settlement without much of anything nearby. Maybe it's the number of settlers in the area or there's a non-SS issue. There are few lingering active scripts and no obvious issues otherwise. I'll look at my load order, maybe LOOT moved something unexpectedly last week. What a bummer.
 

kinggath

Well-Known Member
Staff member
Administrator
Moderator
Verified Builder
Messages
3,897
Try running the scrapall command in RR to see if that has any impact. Some people have had that actually remove the scrap crash.
 

MartialLaw

New Member
Messages
5
Hi everyone.
I just had the same problem at Snctuary immediately after it upgraded to lvl 2 - evry time I approached it I got a CTD.
I tried setting graphics and mod performance to absolute minimum, approaching the settlement from different directions, disabling, uninstalling/reinstalling the mod and disabling the AI - all to no avail.

When I rolled back to an older save and tried upgrading the town manually it CTD'd halfway through the upgrade. I tried running the "refresh city" command and watching it work and found out it leaves quite a few objects behind after tearing the settlement down - see attached screens. While rebuilding the settlement it CTD'd again halfway through the process, just like it did during the upgrade.

Could those unscrapped objects be the cause of the problem?

Upd: the "refresh local plots" command runs fine, no stutter or CTDs so far.
 

Attachments

  • 20180426201105_1.jpg
    20180426201105_1.jpg
    231.3 KB · Views: 32
  • 20180426201117_1.jpg
    20180426201117_1.jpg
    272.2 KB · Views: 33
Last edited:

kinggath

Well-Known Member
Staff member
Administrator
Moderator
Verified Builder
Messages
3,897
Those floating items are the plots - they will always be left behind during the refresh. You can use the Town Meeting Gavel or the holotape's self destruct tools to tear down absolutely everything. If you do, you'll want to give it 10-15 minutes before you try and rebuild the city - that way the game will have time to clean up everything in the background.
 
Top