the Sim Settlements forums!

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Public Beta 2.2.1

Elektra

Member
Messages
66
I have buffout 4 installed. I think it was your hud override mod from the SS2 download page. But yes I believe it was power. I was reading through your form post here and seen your post about auto fixing the grid and causing issues and to turn off so I did and my crashes from power stop just still had issues with like hud bars and resources not being calculated or jumping around
I then downloaded your workshop Script override and it some what Normalized it. If you understand what I mean. Like it would say on the bars half my population had “homes” but on vanilla hud said everyone had beds. But if I were to fast travel away then come back it would try to start fixing the hud. and my hud would move around saying more people had beds or food. Or if I used the toggle on the city manager tape to see what my town was doing it would show on hud that they were producing +130 build Materials etc. but only after I came back. And I mostly found this issues in City plans. Like my manual sanctuary hills build was flawless other then power grid crashes. Until I turned off auto fix.
 
Last edited:

kinggath

Well-Known Member
Staff member
Administrator
Moderator
Verified Builder
Messages
4,869
Build 3 is up, you can download it here.

This build should do the following:

  • Eliminate the population number fluctuating wildly, which should in turn fix HQ assignment doing what it did to me on the stream Wednesday
  • Stabilize Power Transfer (you'll need to visit HQ and each of your settlements with Power Transfer once) - no more having the number change every time a settlement unloads
  • Automatically fix junk storage category numbers across the entire network every 24 hours (which should eliminate them getting noticeably out of sync in the first place)
  • Vault 75 precombine was rebuilt to try and resolve a lot of performance issues... hopefully didn't break Runners and Gunners in the process.
 

Elektra

Member
Messages
66
Build 3 is up, you can download it here.

This build should do the following:

  • Eliminate the population number fluctuating wildly, which should in turn fix HQ assignment doing what it did to me on the stream Wednesday
  • Stabilize Power Transfer (you'll need to visit HQ and each of your settlements with Power Transfer once) - no more having the number change every time a settlement unloads
  • Automatically fix junk storage category numbers across the entire network every 24 hours (which should eliminate them getting noticeably out of sync in the first place)
  • Vault 75 precombine was rebuilt to try and resolve a lot of performance issues... hopefully didn't break Runners and Gunners in the process.
Starting a new game. Ill let you know how it goes.
 
Last edited:

Antoine Soverie

Well-Known Member
Messages
1,355
Oh, I know. Ballistic weave with no Railroad! HQ superiority!
(I do know that a lot of mods already add that so idk)
Then ballistic weave could be upgraded and as a cherry on top - supreme HQ commander outfit. Something with a choice of faction allegiance, a fusion of some of them or all new HQ thing. Though I'm not sure what that would look like. Probably a shiny American flag with eagles bursting from rocket flames.
Or skulls and beavers. Or snakes and tunnels. Or a big spray painted pink smiley face with guns. Something.
This is more and more wet dream sidetracked wishful thinking that's probably outside the scope of the mod but still. If I don't get fired from my new job and save up for a PC, I'd want to make something like that. And a player home on the office level next to all the cool stuff.
 

Antoine Soverie

Well-Known Member
Messages
1,355
Sorry for getting way off the rails, this is an actual question about the betas. Are old disasters that wouldn't go away despite all measures, going away now? Like for example, 5 fires that never stop (putting them out does nothing either) or a couple deserters that can't be accessed (admin mission also does nothing)?
 

yaugie

Well-Known Member
Messages
1,729
This is supposed to be handled by the game engine automatically. Can you click on one and run the console command: sv

This should show if its being persisted by any aliases, in which case that's something I can fix.
If that's being handled by the engine itself, that'd mean the corpses only get cleaned up after not being in that cell for more than a certain amount of ingame time, right? Probably why they're still there for me, but I ran that command anyway:
bloatflycorpse.jpg
 

yaugie

Well-Known Member
Messages
1,729
Yeah, my Resources HUD numbers are still all kinds of jacked up. Egret Tours Marina here now seems to somehow think it's holding multiple orders of magnitude more resources than it should be able to - but for some reason that ~200k resources aren't contributing to the Grand Total? The amounts elsewhere on the network seem about right - but even the sum of those wouldn't equal what the Total says (should be somewhere around 18k if counting in my head still works right).
egretresources.jpg
 
Last edited:

kinggath

Well-Known Member
Staff member
Administrator
Moderator
Verified Builder
Messages
4,869
Yeah, my Resources HUD numbers are still all kinds of jacked up. Egret Tours Marina here now seems to somehow think it's holding multiple orders of magnitude more resources than it should be able to - but for some reason that ~200k resources aren't contributing to the Grand Total? The amounts elsewhere on the network seem about right - but even the sum of those wouldn't equal what the Total says (should be somewhere around 18k if counting in my head still works right).
View attachment 17844
@cbrgamer2 Any ideas? (I updated the KGLatestChanges branch on the private git so you can see if I mucked something up when integrating your code.)
 

yaugie

Well-Known Member
Messages
1,729
@cbrgamer2 Any ideas? (I updated the KGLatestChanges branch on the private git so you can see if I mucked something up when integrating your code.)
A few extra details on that, if it helps:
That game was running on '31 components' level, but I downgraded it to only '4 categories' level once I had built about a half dozen rooms at HQ. Numbers started appearing messed up at around that time - may be coincidence, but the shot earlier in this thread of it reporting a total of a negative number was at around that point.
Did a Mark 1 Beacon run at some point during 'v2' to see what'd happen - best guess is it deposited all those resources into Egret (where the Comms Plot is) regardless of how much room there actually was. (but that wouldn't explain the ~160k Organic - even at best that shouldve been 1/10th that much)
Several ingame days were spent traveling between settlements to see what happened - no sign of any kind of 'recount' as best I could tell.
On loading in after updating to 'v3' (last save was at Somerville Place), I did a passtime 24 then waited 5 realtime minutes - then Fast Traveled to Egret Tours Marina - then waited another 5 minutes. Numbers still all screwy as most recent image showed.
 
Last edited:

cbrgamer2

Well-Known Member
Messages
494
Any ideas? (I updated the KGLatestChanges branch on the private git so you can see if I mucked something up when integrating your code.)
I think the problem is this :
CheckandRepairVirtualResouceTotal(i)

From my comments above the CheckandRepairVirtualResourceTotal function :
if akThisBreakdown is none, akParentResource must be passed

You will need to add akParentResource=VirtualResource_Scrap as a parameter.

I'm not sure what else is happening with the resource values in yaugie's game, but in dailyupdate the CheckAndRepairVirtualResourceTotal will just be returning without doing anything at the moment.
 

Elektra

Member
Messages
66
Thankyou for all of your hard work and all your guys fixes. Finally Codworth Works xD .. Been running a new save for about 12 hrs+. All my issues are fixed so far for settlements. Just grinding the quest to hq. About to start chp2 content quests I’ll post here if I see anything.
 

Attachments

  • image.jpg
    image.jpg
    1.8 MB · Views: 5

XxA1xX

Well-Known Member
Community Rockstar
Messages
1,528
About the only info I have ( just started a new game on v3 yesterday) the city plans and wsfw layouts are way faster then before. For some reason my power grid in sanctuary just stopped working had to unwire and rewire the whole thing. But I only got to well well well quest and it’s running all good will post up later today if I see anything else.
 

thenewking

New Member
Messages
7
just wanted to add some things i noticed n my last couple playthroughs

in 2.2.0 in HQ was not able to put out fires
updated to 2.2.1 beta first file in this thread and same save fires still wouldnt put out

started new game raced to hq was able to get disasters and they could be completed but remains from bugs remain and are not cleared
i also had issues with resources and power to the HQ but that seems to be fixed in the latest version in build 3 after a long time going to each settlement and having it recalculate the resources

next main issue was the 2 quests commonwealth rising and remote memory - if i didnt do remote memory quest before doing the last upgrade for commonwealth rising then the group meeting at hq would not happen after the antenna was upgraded and the quest would not complete unless using console commands

went to a save before i started the antenna upgrade then completed remote memory quest but this time once i visited a settlement to get jake to radio me the cinematic dialog would freeze me in one spot i couldnt move look or open pipboy - i tried different settlements all same so i googled and found if i was in power armor it may let me move as it cuts the action so i tried it and i worked
this then allowed me to return to hq to complete the quest and no other issues
 
Messages
49
Silly question, I was about to start a new playthrough and was considering using the beta so I downloaded it, how do I install it? Do I need to install the original versions and then copy paste these into the game folder and have them replace the files. Normally I just drag the zipped files into Vortex but these seem to be unpacked but also grouped.
 

Rexorp

Active Member
Messages
131
Silly question, I was about to start a new playthrough and was considering using the beta so I downloaded it, how do I install it? Do I need to install the original versions and then copy paste these into the game folder and have them replace the files. Normally I just drag the zipped files into Vortex but these seem to be unpacked but also grouped.
I just open the zip, grab all files and folders and replace the old. done.
 

greven

New Member
Messages
2
I have a save file with multiple fires raging and 26 NPCs trying to put them out and freezing themsleves to death. Loaded it up with the patch and no luck with a solution. Flames still won't go out and also tried no clip to get under them without effect. I did notice my load time increased by about 3 minutes after the patch. I can upload any info necessary, but it's years since I looked at creation engine code and have no clue what might be causing it using sv.
 

Attachments

  • Screenshot 2022-08-10 092721.png
    Screenshot 2022-08-10 092721.png
    2.8 MB · Views: 1
  • Screenshot 2022-08-10 092613.png
    Screenshot 2022-08-10 092613.png
    2.9 MB · Views: 1
  • Capture.PNG
    Capture.PNG
    3.7 MB · Views: 1
Messages
49
Rexorp I was starting from a fresh install so I didnt have the folders to replace. I usually try to start fresh every couple times especially after as many CTD as I experienced in the last playthrough. I delete all the folders and start over. I did a manual install of F4SE, Buffout 4, Address Library, and xSE PluginPreloader then used Vortex to do the rest including SS2. Now that is done I just drag the contents of the beta folder into my Fallout folder and click replace files if it asks?
 

Elektra

Member
Messages
66
Hey how’s it going, I didn’t know where to report this bug and I know you guys are busy on bug fixes code implementation for HQ and making sure everything runs smoothly but I was doing the quest Gray Matters and I saved Audra and Knox but every time I send them to a settlement then try to leave the Red Door I run into an infinite load screen. Idk if that is mine issue your guys seeing as this is the very 1st time I’ve ever run into this and I’ve played at least 20-50 playthroughs. Can I ask what causes infinite load screens? I even tried saving and reopening the game. I apologize just trying to make sure, and thankyou in advance.
 
Last edited:

XxA1xX

Well-Known Member
Community Rockstar
Messages
1,528
Rexorp I was starting from a fresh install so I didnt have the folders to replace. I usually try to start fresh every couple times especially after as many CTD as I experienced in the last playthrough. I delete all the folders and start over. I did a manual install of F4SE, Buffout 4, Address Library, and xSE PluginPreloader then used Vortex to do the rest including SS2. Now that is done I just drag the contents of the beta folder into my Fallout folder and click replace files if it asks?
Just install the beta file it has ss2 plus wsfw plus chapter 2
 

XxA1xX

Well-Known Member
Community Rockstar
Messages
1,528
Got through hub of the problem quest still no big issues had 1 settler refuse to be assigned to a caravan plot though but another settler assigned fine. The new settler trade routes are a lot cleaner and less spidery looking so that works. Will play a little more tonight and try to get to chapter 2 and report any thing I see.
 
Top