the Sim Settlements forums!

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Public Beta 2.2.1

Elektra

Member
Messages
59
Hey I am having issues with my hud and settlements and scripts running with newest update from nexus. My hud is Like fluctuating all over the place saying no food no jobs or homes etc over and over again or would just get stuck. With no bars full. I downloaded the workshop script over ride last night. It fixed most my issues. Just having power grid issues now. Mostly just from a crash prevent or because workshop had to update those settlements to get the correct code with the new mod/Script I downloaded. Was an easy enough fix with power tools or running around rewiring everything so was good. game was fine. I then started chp2 quests like dark horizons now I’m on the vault 81 radio quest. And I was doing some Unique settlers quests I come into sanctuary to get an update from Cleff I send him to hangman’s then I save I try to go craft something at my work bench, i then crash. I load back from save. Get into game. Crash. I checked fallrim tools and I have 30 active ss2 scripts running with the last patch installed. I need help to stop all these scripts from running at once in my game.
I Have not download the beta because this is a new save from the last beta and I wanted to get to HQ and enjoy the new systems you had so was going to wait before I installed a new beta.
 

cbrgamer2

Well-Known Member
Messages
401
I'm requesting some clarification on what this is actually doing, and how it's triggered to activate. Because after walking between settlements, waiting 5 realtime minutes, and pushing a passtime 24 through to do the Daily Resource Income, my resources on this save are still kind of...
Could you turn on individual settlement info on the HUD and see which settlement(s) do not add up correctly? It will only check what is in each individual settlement as you walk in, not all settlements each time.
@kinggath maybe we could change it so every 24 game hours it does a loop and checks all settlements? It's only checking numbers in the datastore, so it doesn't require the settlements to be loaded. We should also put in a check to stop it from running if the ClearStoredExcessCapacity array is not empty (we don't want it running in that two minutes the player has to fix up their max storage before losing resources).
If you've found a way to pass on a save @yaugie that would still help.
 

yaugie

Well-Known Member
Messages
1,078
Strangest thing, after another few sessions; I did get Vault 88 to show up in the logs as rolling for Generic/Unique Visitors and thusly put some in there... once. In the game session where I walked out of the vault through the cave and into the quarry outside, rather than Fast Traveled out.

Could you turn on individual settlement info on the HUD and see which settlement(s) do not add up correctly? It will only check what is in each individual settlement as you walk in, not all settlements each time.
From a bit of a look, several of them are effed up at this point. Oberland and Hangmans were correct, but Somerville and Egret were holding more than they should even be able to (Egret by a full factor of 10), whereas 88 is reporting its total as being lower than the sum of the categories.
Providing a save isn't a problem; it's just that I was doing a test with my 'actual' load order enabled, and I don't even know what it'll do if someone else tries to load it without at least most of these. Here's a GDrive link anyway:
Now judging by the name I gave to the player character, this save was actually first made during the previous Public Beta and then upgraded to this version. Not sure if that might be part of the issue?
As best I can figure from thinking back through this save's progress, I think the numbers got all borked from the moment I lowered the 'resource complexity' from '31 components' to just 'categories' - building HQ was becoming far too much of a pain with fully 1/4 of my V.Storage (and rising) at that point being Asbestos that nothing was using.
 
Last edited:

cbrgamer2

Well-Known Member
Messages
401
Providing a save isn't a problem
Got the save and was able to open it. I ran a test where I looped through and ran the repair function on each settlement data store and the overall total across the network was still off ... by 1 :grin
I did my best to account for rounding error, but apparently its not perfect. Personally I think I can live with it.
So I think if we change it to run that loop each 24 hours instead of doing it on each individual workshop as you enter it, that will be better.

I think the numbers got all borked from the moment I lowered the 'resource complexity' from '31 components' to just 'categories'
Doing that doesn't actually change any numbers - it just stops you from seeing the component numbers (the category totals it shows you are the same numbers was showing you on the higher complexity). So it shouldn't have messed anything up.

building HQ was becoming far too much of a pain with fully 1/4 of my V.Storage (and rising) at that point being Asbestos that nothing was using
I think KG has plans for ways to make use of the excess resources. In the meantime there's always my throw away resources mod.
 

yaugie

Well-Known Member
Messages
1,078
Doing that doesn't actually change any numbers - it just stops you from seeing the component numbers (the category totals it shows you are the same numbers was showing you on the higher complexity). So it shouldn't have messed anything up.
I thought that was how it worked, but I was just trying to think back to what might have been the cause. It wasn't until I was building HQ that it started to look odd like that, and I've noticed every so often in HQ it seems like you get... I don't know, the "free resources" you're meant to get for the 'mandatory tutorial' sequence forcibly added to your Virtual Storage Network, which throws the numbers off (because it doesn't seem to correctly recalculate the Totals at that point).
 

Elektra

Member
Messages
59

Elektra

Member
Messages
59
image.jpg
Hey hows it going, been playing through the mod today with the beta fixed some of settlement isses but now I have an issue in HQ which i have had this issue before back at the start of HQ release.
Vault 81 just recruiting Manfield:
In HQ mid quest I am short 2 people, shouldnt have to use GodMode to build Living Quarters:
https://drive.google.com/file/d/1UoGiQJtabfMt2vzf1BswUxRP1r1xkOnW/view?usp=sharing
 

Elektra

Member
Messages
59
Hey hows it going, been playing through the mod today with the beta fixed some of settlement isses but now I have an issue in HQ which i have had this issue before back at the start of HQ release.
Vault 81 just recruiting Manfield:
In HQ mid quest I am short 2 people, shouldnt have to use GodMode to build Living Quarters:
https://drive.google.com/file/d/1UoGiQJtabfMt2vzf1BswUxRP1r1xkOnW/view?usp=sharing
 

Attachments

  • image.jpg
    image.jpg
    1.7 MB · Views: 11
  • image.jpg
    image.jpg
    1.8 MB · Views: 11

Antoine Soverie

Well-Known Member
Messages
789
There's a quest cheat for How to HQ in case you don't have 10 people at that stage (shouldn't have to use it though). And assignment code is wonky still I guess? If you add people to departments by 1 or 2 instead of a whole bunch and wait each time for HUD to update that might make it more stable.
 

Elektra

Member
Messages
59
There's a quest cheat for How to HQ in case you don't have 10 people at that stage (shouldn't have to use it though). And assignment code is wonky still I guess? If you add people to departments by 1 or 2 instead of a whole bunch and wait each time for HUD to update that might make it more stable.
Thankyou will give this a try if needed. Going to try to recruit and build some living quarters later today when I get home.
 

Elektra

Member
Messages
59
Getting a weird texture-glitch (z-fighting?) in Mansfield's Bedroom in a specific room on this save. I am running fadingsignal's "Interiors Enhanced" this save but I wouldn't think that is even applying in HQ with it being a custom cell and all... (although it looks like it might be?)
Refreshing the room does get rid of it... until next time I leave and come back to HQ, then it's doing it again. You can see which space it's in in the video. That's where I almost always put his room and I've never seen it do that before...
(Side note: is his room MEANT to not have a door, and no Upgraded version?)
Same here
 

Elektra

Member
Messages
59
Not really a bug but seems all assets have gone missing. Visual bugs you’ve fixed are unfixed lol
 

Attachments

  • image.jpg
    image.jpg
    2.6 MB · Views: 9
  • image.jpg
    image.jpg
    1.8 MB · Views: 9
  • image.jpg
    image.jpg
    2.2 MB · Views: 8
  • image.jpg
    image.jpg
    2.3 MB · Views: 7
  • image.jpg
    image.jpg
    2.2 MB · Views: 7
  • image.jpg
    image.jpg
    1.9 MB · Views: 6
  • image.jpg
    image.jpg
    2.4 MB · Views: 5
  • image.jpg
    image.jpg
    1.9 MB · Views: 5
  • image.jpg
    image.jpg
    1.8 MB · Views: 5
  • image.jpg
    image.jpg
    2.3 MB · Views: 6

Elektra

Member
Messages
59
Lily is still massively bugged for me. It did say she was a labor but I used the town hammer and she appeared in my settlement stayed for a few mins then walked away and came back to HQ and now she just wonders the main hall/quarters
 

Attachments

  • image.jpg
    image.jpg
    1.3 MB · Views: 6

Elektra

Member
Messages
59
Lily is still massively bugged for me. It did say she was a labor but I used the town hammer and she appeared in my settlement stayed for a few mins then walked away and came back to HQ and now she just wonders the main hall/quarters
And MALA has stood in the exact same spot since the concord settlers dropped her off, it’s like her script stopped before it could register being assigned to HQ she just sits there saying all is well like she was in Concord
 

Attachments

  • image.jpg
    image.jpg
    1.5 MB · Views: 1
Last edited:

Elektra

Member
Messages
59
And MALA has stood in the exact same spot since the concord settlers dropped her off, it’s like her script stopped before it could register being assigned to HQ she just sits there saying all is well like she was in Concord
Office level controls spazing out. I don’t know if that’s previs and my fault or the remote control doing this through code but I will say it is so distracting when you pass by it. Haha. just thought I’d report what I can. I seem to have a great deal of issues or small bugs rather that I didn’t have before and this is a new playthrough with less mods then I had last time. I got rid so call mod bug fixes like chatter mods and stuff only trying to run ss2 addons with character changes and not world or settlements changing. I had an issue with Jake earlier where he was stuck on the console in the comm array room wouldn’t interact with me or acknowledge I was there he was dead focused on that console. but I used move to player run over to Lupe It initiated his convo for the remote control quest. I declined getting in as I had already been stuck in it earlier. I quick interacted with him with x and got him to initiate his convo for the commonwealth’s rising quest and got through quest No problem and Then was able to do remote control with no issues. Just a struggle to move forward when he was sat there is all.
 
Last edited:

Elektra

Member
Messages
59
Office level controls spacing out. I don’t know if that’s previs and my fault or the remote control doing this through code but I will say it is so distracting when you pass by it. Haha. just thought I’d report what I can. I seem to have a great deal of issues or small bugs rather that I didn’t have before and this is a new playthrough with less mods then I had last time. I got rid so call mod bug fixes like chatter mods and stuff only trying to run ss2 addons with character changes and not world or settlements changing. I had an issue with Jake earlier where he was stuck on the console in the comm array room wouldn’t interact with me or acknowledge I was there he was dead focused on that console. but I used move to player run over to Lupe It initiated his convo for the remote control quest. I declined getting in as I had already been stuck in it earlier. I quick interacted with him with x and got him to initiate his convo for the commonwealth’s rising quest and got through quest No problem and Then was able to do remote control with no issues. Just a struggle to move forward when he was sat there is all.
Saves if you wanted to have a closer look.
1st time trying Chair:
Just outside HQ(later on in playthrough):
Jake Stuck
Moveto player Command, Run to Lupe:
 
Last edited:
Top