the Sim Settlements forums!

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Question Problem with beds not registering

Psyche

New Member
Messages
22
I've been having a problem where beds or residential plots have not been registering towards housing. I've found it when using both beds and residential plots, or using beds or residential plots in isolation. It's not limited to a single settlement. It shows that I have enough beds according to the in-game overlay, but not according to the HUD Framework. To try to fix this I've run shelter fix, gone through and individually refreshed my residential plots, but nothing seems to fix it. I end up having to build several more beds / plots than necessary.

Mods I'm using related to Sim Settlements:

SS 3in1
HUD Framework
Settlement Management Menu
Workshop Framework
Wasteland Venturers 2
Recruitable Settlers Leadership pack
Captain LaserBeam's Jampads
Plots by Paw Paw
Intimate Spaces
Place Anywhere
All Settlements Extended

Any thoughts you might have would be greatly appreciated!
 

RayBo

Well-Known Member
Moderator
Patreon Supporter
Community Rockstar
Support Team
Vault Librarian
Messages
2,351
I've been having a problem where beds or residential plots have not been registering towards housing. I've found it when using both beds and residential plots, or using beds or residential plots in isolation. It's not limited to a single settlement. It shows that I have enough beds according to the in-game overlay, but not according to the HUD Framework. To try to fix this I've run shelter fix, gone through and individually refreshed my residential plots, but nothing seems to fix it. I end up having to build several more beds / plots than necessary.

Mods I'm using related to Sim Settlements:

SS 3in1
HUD Framework
Settlement Management Menu
Workshop Framework
Wasteland Venturers 2
Recruitable Settlers Leadership pack
Captain LaserBeam's Jampads
Plots by Paw Paw
Intimate Spaces
Place Anywhere
All Settlements Extended

Any thoughts you might have would be greatly appreciated!

Oh, I have noticed this. So you are not alone.
I have noticed with:
Beds and power.
I am running what I now call “Combos” :crazy Unpure settlements :blum Meaning a heavy mix of non-sim settlement assets. Mostly to see if it improves things like FPS within boarders.

For me closing the game and restarting seems to reset the ss-hud / and fix what you are describing.

It’s a new game so I am still trying to get my head around it. For me it is neither a game breaking glitch or something that I just will not notice. So, I am just thinking hummmm, this is odd?

Good thread @Psyche Let’s see what others are observing.

We all should post screenshots of what we are seeing from this point on if we wish to further develop / define the issue.

Now for the funny part. When using Coots new plot, the barricade or something like that. My settlers undress themselves “repeatedly” so I watch take videos and screenshots. Purely for technical evidence of course!

I have concluded this is not a glitch. :pardon I figured they made it just for my entertainment :lol
I am grateful for such as this. :yahoo

I sure hope it is a mod conflict so I can keep it :rofl
 
Last edited:

1ae0bfb8

Well-Known Member
Banned
Messages
1,018
i'm seeing this currently - i also see the number of beds set to a value over 4000. what i do is head directly to the affected settlement and run the shelter fix, and then set that to auto (i had it on manual). i then rebuild local data and, if there's no change, the last thing i do is rebuild all the plots. takes a bit of time - but eventually one of these resolves the issue. i've noticed that any beds i place manually are fine, it appears to be (to my ignorant eyes) beds in plots only.
 

Barbara917

Active Member
Messages
103
I have been struggling with accurate bed counts as well. I originally had the vanilla game bug that is particularly bad in Sanctuary in which the pip-boy inaccurately undercounts the beds causing settlement happiness to plummet. I asked here about any available workarounds knowing that this is a Fallout 4 bug in an unmodded game. I was recommended to install Workshop Framework. I did that but detected no noticeable change in the game behavior. I then started a new game to see if I would get different results. I did. In the opposite direction.

In Sanctuary, I currently have 19 residential plots developed, 2 residential plots for rent and 3 beds placed manually by me. A correct count should be 21 beds. When I left the game the pip-boy and workshop mode were both reporting Sanctuary as having 31 beds. When I returned to the game, my character was located in Starlight Drive-in and the pip-boy was reporting 11 beds in Sanctuary. Returning to Sanctuary both the pip-boy bed count and workshop bed counts were both "corrected" to 41 beds. I have no clue what is going on here....
 

RayBo

Well-Known Member
Moderator
Patreon Supporter
Community Rockstar
Support Team
Vault Librarian
Messages
2,351
I have been struggling with accurate bed counts as well. I originally had the vanilla game bug that is particularly bad in Sanctuary in which the pip-boy inaccurately undercounts the beds causing settlement happiness to plummet. I asked here about any available workarounds knowing that this is a Fallout 4 bug in an unmodded game. I was recommended to install Workshop Framework. I did that but detected no noticeable change in the game behavior. I then started a new game to see if I would get different results. I did. In the opposite direction.

In Sanctuary, I currently have 19 residential plots developed, 2 residential plots for rent and 3 beds placed manually by me. A correct count should be 21 beds. When I left the game the pip-boy and workshop mode were both reporting Sanctuary as having 31 beds. When I returned to the game, my character was located in Starlight Drive-in and the pip-boy was reporting 11 beds in Sanctuary. Returning to Sanctuary both the pip-boy bed count and workshop bed counts were both "corrected" to 41 beds. I have no clue what is going on here....

Are you running any kind of boarder expansion mod?

I run the shelter fix manually several times in succession in such settlements. For me this has worked, others not so much.
 

Barbara917

Active Member
Messages
103
Are you running any kind of boarder expansion mod?

I run the shelter fix manually several times in succession in such settlements. For me this has worked, others not so much.

There is no boarder expansion mods in Sanctuary. The only locations I have expanded the boarders with mods are in Hangman's Alley and Jamaica Plain but each of these locations are yet to be discovered in this game.

Could you tell me what the shelter fix is?
 

RayBo

Well-Known Member
Moderator
Patreon Supporter
Community Rockstar
Support Team
Vault Librarian
Messages
2,351
There is no boarder expansion mods in Sanctuary. The only locations I have expanded the boarders with mods are in Hangman's Alley and Jamaica Plain but each of these locations are yet to be discovered in this game.

Could you tell me what the shelter fix is?

:bye Yes. :rollseye

Open the city manager halotape.

Select “Tools”
E32903C4-6423-4E00-AFB3-FC9F927C6108.png


Select “Shelter Fix”
B8994ABB-BF63-4829-83EA-0F01231E9F87.png

As “corny” as it sounds. I seem to have better results selecting and running multiple times while in the problem settlement. “might be my imagination that running it several times is better” ha, but that’s how I have been doing it.:crazy

This “bed” being off calculations seems to happen for me once every playthrough.

Once it starts happening I just run around to all my settlements run the “shelter fix manually” and it seems to fix it for me. Everytime.

Once I do this I set it back to Auto.

As corny as it sounds it has worked repeatedly for my games. I know from feedback it has not yielded the same results for other players. I am sure they think me a goof. But, hay my game is working so I can live with it. :acute
 
Last edited:

1ae0bfb8

Well-Known Member
Banned
Messages
1,018
this bug is killing me. i'm seeing more and more settlements where the number of beds is > 4000, and repeatedly I will get CTD's if I head anywhere near those settlements to try and resolve it. I'm at my wits end trying to understand how this occurs and how to stop it but seemingly there's nothing i can do until it's too late, and then i have to revert back to a save where the ctd doesn't occur, and that can be 1 level previously, or 10 levels previously.
it's really getting tiresome. if anyone has any idea how the bed situation can cause ctd's i'd love to hear it - for me, in my experience, this is worse than the power grid bug.
 
Top