the Sim Settlements forums!

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Patch 2.0.2 - Get Extended is now live!

Litec1

New Member
Messages
28
EDIT 02/26/22: Hotfix 2.0.0c addresses the crash some people are experiencing when visiting the settlement Old Paul is in. This had been caused by a corruption in the ba2 file, this seems to have primarily affected Xbox players, but may have also been hitting some PC hardware.

EDIT: Hotfix 2.0.0b fixes issues with HQ where projects would claim to be completed and nothing happened!



  • 67 new outfits added via SS2Extended (optional injection patch also available to get those outfits on settlers)!
  • Tutorial message history can now be accessed to re-read that message you just dismissed by mistake!
  • Companions can now be recruited for HQ if they are living at a settlement!
  • Automatic data corruption recovery added - if you had a buggy settlement, it might spring to life when you visit it next!
  • SS2Extended is now included by default on Nexus and is available via Bethesda.net for PC players (as is the optional injection patch)!
  • TONS of bug fixes!
  • And loads more!

In addition there is an update available for Workshop Framework!

Xbox players, the versions to watch for when you can safely update are: 51 of SS2, and version 22 of Chapter 2.

Full patch notes available here: https://wiki.simsettlements2.com/en/getting-started/patch-notes

-kinggath
There might some other corruption because I am getting persistent CTD after this patch that I was not getting before. It seems to be related to upgrades in settlements or getting some of the later plot types unlocked (immediately followed by a hard CTD when using VATS, engaging with an item, entering a settlement).

This only started for me after 2.0.2
 

LordTrog

Active Member
Messages
121
Dude just try using Bethesda.net for Xbox downloads and Nexus/Vortex for your new MSI laptop. Also don't forget to update workshop framework and all that. The crashes lately were from Old Paul's clothing, which is fixed now. On nexus, v2.0.2c.
Dude! Dude. Totally! I have it all running now with some 14 mods and in the midst fixed my graphics card to be more automatic. And today doubled my ram and installed another ssd along with the base m.2.

Thank you!
 

Jodywilkes66

Member
Messages
83
hello again,
I am noticing something odd with the latest C version, I no longer have the resource panel In workshop mode.
When I use the holotape, under The HUD autohide settings, it only lists ”always hidden” As an option.
Can someone tell me how to allow the resource panel to show up again? Or did i miss a note in the changelog?

thank you
 

spacefiddle

Well-Known Member
Messages
560
hello again,
I am noticing something odd with the latest C version, I no longer have the resource panel In workshop mode.
When I use the holotape, under The HUD autohide settings, it only lists ”always hidden” As an option.
Can someone tell me how to allow the resource panel to show up again? Or did i miss a note in the changelog?

thank you
Ah. Not just me then. Or you! Stand by.... I'm getting general weirdness with the Resources panel, its hotkey press is being logged but no attempted action results. Maybe this was intentional.... checking notes again:
Nope, either undocumented or unintentional, I don't remember seeing anything about adjustments to the (non-HQ) HUD in the notes and I'm not seeing anything about it on a third read. Looks like the Resources panel may currently be broken, for at least some of us.

I'm going to try reinstalling WSFW and HUDFramework while i'm at it; probably wouldn't hurt for you to try as well (they're tiny, compared to SS2 itself).
 

Litec1

New Member
Messages
28
There might some other corruption because I am getting persistent CTD after this patch that I was not getting before. It seems to be related to upgrades in settlements or getting some of the later plot types unlocked (immediately followed by a hard CTD when using VATS, engaging with an item, entering a settlement).

This only started for me after 2.0.2
since the game is now unplayable*, am I better off just going back a version until things settle out?

(* - for me)
 

spacefiddle

Well-Known Member
Messages
560
hello again,
I am noticing something odd with the latest C version, I no longer have the resource panel In workshop mode.
When I use the holotape, under The HUD autohide settings, it only lists ”always hidden” As an option.
Can someone tell me how to allow the resource panel to show up again? Or did i miss a note in the changelog?

thank you
ok, we might have 2 diff issues - but try this:
first make sure you have the latest WorkshopFramework, and that HUDFramework is installed and enabled.
You say holotape settings - i would recommend getting MCM, the Mod Configuration Manager, and installing that.
Then find your SS2 2.0.2c download - the .7z archive itself - and set it somewhere safe.
Then check your mod manager: do you see other SS2 versions available? Like from a drop-down on the version number in Vortex?
If so, uninstall ALL OF THEM, then reinstall 2.0.2c from that archive you downloaded/set aside.
If you're not sure how to do the above, then i know it's a huge download, but kill all versions of SS2 - remove/delete archive, not "disable" - then install SS2 2.0.2c fresh from a new "install with mod manager" from the nexus page. DO NOT start your game once you begin this process.
Make sure when you install SS2 that if it asks about "multiple plugins," you enable all of them! That is the SS2.esm as well as the SS2Extended.esp.
Lastly make sure the latest Chapter 2 (i think it's on letter "A") is installed and enabled.

Once all this is done, make a backup copy of whatever savegame you're about to load. Once you load in, hit ESC, click the top new option "Mod Configuration," go to Sim Settlements 2 -> HUD, and see if the autohide options are all fully there.
 

spacefiddle

Well-Known Member
Messages
560
since the game is now unplayable*, am I better off just going back a version until things settle out?

(* - for me)
Well, if you have something that's conflicting and causing a crash, it'll never resolve itself on its own - stuff like this means that an existing issue or flaw in your game has been exposed by the new version, but it was always there, and something would have caused it eventually. Better to tackle it head-on and try to resolve it.

Get Buffout 4 , play game until crash, use crash log autoscanner to identify likely suspects. Follow all install steps and instructions. None of them are skippable. Once you do that, you will have greatly narrowed down where to look for the culprit. (And you'll feel a lot less helpless about the whole thing too)
 

spacefiddle

Well-Known Member
Messages
560
....and as a general step for all of us, myself included just now, having issues: if using F4se, it needs a whole lotta loose scripts to function. Go to your f4se download, get that Data folder, drag it to your Fallout 4 folder, agree that it should merge all the things. Any missing or clobbered scripts will be restored.

(a mod manager can't tell one file with the exact same name and path from another.... especially compared to a loose file thrown into Data that has no mod association. If a mod incorrectly includes scripts it shouldn't oughtta, and clobbers the f4se versions.... then you uninstall that mod... your mod manager will helpfully make sure that the script which it sees as part of that mod goes away with the other mod's files. I believe that may be a more common path to f4se corruption than i'd previously realized.)
 

Litec1

New Member
Messages
28
Well, if you have something that's conflicting and causing a crash, it'll never resolve itself on its own - stuff like this means that an existing issue or flaw in your game has been exposed by the new version, but it was always there, and something would have caused it eventually. Better to tackle it head-on and try to resolve it.

Get Buffout 4 , play game until crash, use crash log autoscanner to identify likely suspects. Follow all install steps and instructions. None of them are skippable. Once you do that, you will have greatly narrowed down where to look for the culprit. (And you'll feel a lot less helpless about the whole thing too)
This is the most helpful advice I have received on the forum. Yes, it was complicated to install, but I got it all running.

I've attached the autoscan results below. It seems to possibly be pointing to AWKCR or FallUI. I will try removing those (which I know brings its own risks).
 

Attachments

  • crash-2022-03-02-17-10-47-AUTOSCAN.txt
    4.4 KB · Views: 13

Litec1

New Member
Messages
28
And after replacing the "offending" mods, still getting the crash. New crashlog autoscan offers no suggestions. :cray

So, back to asking if I should just roll back to 2.0.1 for now? @spacefiddle @kinggath
 
Last edited:

Ion_Blue

New Member
Messages
10
I had the old paul ctd issue and the latest patch solved it but now i have the ..no resource panel and no status meters either.. if it helps this all started after i unlocked all the new plots, after finishing new plots on the block. Thankyou for a great mod btw.

It seems to have solved its self after playing with the options. But it does not show the resources that my plots are gathering only what i donated.
 
Last edited:

SlowGunSam

New Member
Messages
6
Same problem here. I reinstalled the vanilla game, re-downloaded all of the mods (HUD, WSFW, F4 unofficial patch, SS2, SS2c2, SS2 extended, Everybody's best friend and Subversion). Can't get the resources bar to appear through the holotape menu. Any help appreciated.
 

Kilo1-1

Active Member
Messages
104
This is the most helpful advice I have received on the forum. Yes, it was complicated to install, but I got it all running.

I've attached the autoscan results below. It seems to possibly be pointing to AWKCR or FallUI. I will try removing those (which I know brings its own risks).
If you can post your original crashlog before you ran it through the scanner, I'll take a look at it. There's a lot of one off nuances from bigger mods like SS2 that it can't pick up on.
 

Cavete

Member
Messages
33
Found another stray door while running the current version. Haven't spotted any others yet, but I only have a dozen or so Concord settlers so far.
 

Attachments

  • concord_door1ext_030622.png
    concord_door1ext_030622.png
    3 MB · Views: 18
  • concord_door1int_030622.png
    concord_door1int_030622.png
    2.9 MB · Views: 18

Litec1

New Member
Messages
28
If you can post your original crashlog before you ran it through the scanner, I'll take a look at it. There's a lot of one off nuances from bigger mods like SS2 that it can't pick up on.
Thanks! Here is the crashlog
 

Attachments

  • crash-2022-03-02-17-36-24.7z
    4.4 KB · Views: 5

Amardon1961

Member
Patreon Supporter
Messages
88
hello,
with the latest C version, I no longer have the resource panel. When I use the holotape, under The HUD autohide settings, it only lists ”always hidden”.
Can someone tell me how to allow the resource panel to show up again?

thank you
+1 I haven't been to GNN for awhile, then I come back to this. Everything seems to work, but the panel. I don't think I did anything except update to 2.0.2c.
 

Kilo1-1

Active Member
Messages
104
Thanks! Here is the crashlog
I must admit this one is strange. There are no references to any esp/esm that are giving issues. Your mod list is also small and straightforward. All this log has is something related to Papyrus that pops up. My hunch on your crash is a script is trying to run or reference something that doesn't exist anymore. I can't find it right now but you may be able to fix this by running your save file through that save file tool that removes obsolete or bad data in your file. Did you remove any mods recently or update anything else?
 

Litec1

New Member
Messages
28
I must admit this one is strange. There are no references to any esp/esm that are giving issues. Your mod list is also small and straightforward. All this log has is something related to Papyrus that pops up. My hunch on your crash is a script is trying to run or reference something that doesn't exist anymore. I can't find it right now but you may be able to fix this by running your save file through that save file tool that removes obsolete or bad data in your file. Did you remove any mods recently or update anything else?
Thank you for looking it over.

after the crashes started, I installed Buffout4 and the inital crash file pointed to FallUI and AWKCR, so I removed those. I knew it was a risk, but it was already broken AF. I don't recall removing or updating anything else.

Do know what the name of the save file tool is?

I'm still left wondering if rolling back SS2 (and associated mods) to 2.0.1 would work.
 
Top