the Sim Settlements forums!

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Solved Game crashes when I approach a Conqueror pre-built settlement

Sneed Gaming

New Member
Messages
5
Hi all,

This is my first post on this forum and I hope I'm doing it right, as I've long been a fan of Youtubers using Sim Settlements and only recently decided to try the mod out myself. I've started a heavily modded playthrough of Fallout 4 and am really enjoying it, having started a city plan in Sanctuary and converted the Red Rocket into a base for my Liberator faction, the Minutemen. Now about 4 hours into my playthrough, I've approached my first pre-built settlement, Starlight Drive-In, which is run by the Libertalian Brothers faction. However, once I approach the front gate of the settlement, I run into two problems.

First of all, I could see that the raider guards seemed to be attacking the civilians/hostages. Second, about 15 seconds later, my game crashes to desktop. I wasn't expecting this, since even though I'm running 200+ mods, some of which use scripts, I'm running it on a decent PC that I just built. My guess is that I'm running too many scripts at once, even though I'm using the Baka Script Limit Extender set to 3x memory. One of my guesses is that it could be Pack Attack causing lag by trying to apply to all the NPCs in a Level 3 city. Has anyone had problems like this and/or knows of any fixes?

My specs are: Nvidia GTX 2070, AMD Ryzen 3700x, 16gb RAM.

My load order: pastebin com/71LusVaj
(add a . between pastebin and com since I can't post links yet)
 

VersusXV

Well-Known Member
Staff member
Moderator
Patreon Supporter
Verified Builder
Vault Librarian
Messages
640
An additional thing that could potentially help is the new "Buffout 4" mod which they are intending to make into Fallout 4 Engine Fixes basically like the SSE Engine fixes. A few fixes are already included such as for UI stuff via Scaleform Allocator as well as the Cell Reset Bug Fix & Cell Init Fix which were listed as fixed in the Changelog. So there is a chance it might help out with this. It reportedly has already helped other users that are using UI mods like item sorters & others using HUDFramework, so may also help Conqueror.

It also has a Crash Log feature that they've stated in the mod description that they intend to use to try to identify & fix engine issues. The resulting logs won't be really readable for regular users but the general idea seems to be to allow them to analyze it from programmer's perspective by asking users to post crash logs. So I would suggest that it might also be helpful/useful to replicate the crash after installing Buffout 4 and then making a comments post with a PasteBin link containing the full log contents, with the comment containing only what you were specifically doing at time of crash ie "Crash when approaching Starlight Drive In <log>". Maybe there is a chance that they can identify any possible engine issue occurring here and potentially solve it?

Link: https://www.nexusmods.com/fallout4/mods/47359/?

Now about 4 hours into my playthrough, I've approached my first pre-built settlement, Starlight Drive-In, which is run by the Libertalian Brothers faction. However, once I approach the front gate of the settlement, I run into two problems.
By chance do you know which City Plan was in use for it? Have any mods been uninstalled & the save continued despite it, without rolling back to before it was installed or beginning a new game?

One thing that is potentially concerning and confusing is that it looks as though both the city plan contest pack AIO & several of the standalone esl are both in use at the same time. As far as I know that isn't expected, so it is possible that it could be the cause. I can't say for sure but if everything else does get ruled out then it may be worth a try to see if issue still happens when the ESLs are removed and just using the plans via the all in one SimSettlements_CityPlanPack_ContestEntries.esp


First of all, I could see that the raider guards seemed to be attacking the civilians/hostages. Second, about 15 seconds later, my game crashes to desktop. I wasn't expecting this, since even though I'm running 200+ mods, some of which use scripts, I'm running it on a decent PC that I just built. My guess is that I'm running too many scripts at once, even though I'm using the Baka Script Limit Extender set to 3x memory. One of my guesses is that it could be Pack Attack causing lag by trying to apply to all the NPCs in a Level 3 city. Has anyone had problems like this and/or knows of any fixes?

My specs are: Nvidia GTX 2070, AMD Ryzen 3700x, 16gb RAM.
I've been able to do similar, generally with few issues and only have a little bit better specs albeit with a far worse CPU than the Ryzen 3700x. I run 400+ plugins including Pack Attack, Crime & Punishment, several of the quest mods like Thuggysmurf ones & The Bleachers & TMAH. I do about half & half in terms of prebuilding or not, though I do often use RotC only or RotC with a small number of additions. I found personally I liked prebuilding around 1/3 or 1/2 of the options and varying it each time for some variety. Some crashes will happen but it's generally not been a 100% every time thing.

Latest versions of Pack Attack seems much more optimized than before & far more reliable overall, but I've not tried upping the spawning settings on it as I've stuck to recommended defaults for now. As long as you're on a fairly recent version like at least 1.9.0(& not the "No F4SE Version") I think it should be fine. If you're still using a fairly old version like from before the start of the year, you might find a nice improvement by updating to the latest.

Overall I would say hardware is unlikely to be why unless using heavy ENB & many higher res textures(I see a few but if repack was done then I can't see those from the load order) and given that Baka Scrap Heap is in use I would say script load might not be the sole cause since it's been very effective for me. To check for that I would suggest to use FallRim Tools ReSaver to check if the saves before crashing have an unusually high number of Active Scripts or Suspended Stacks.

Link https://www.nexusmods.com/fallout4/mods/22633
 

Lazar Gecic

Member
Messages
60
When it comes to Pack Attack, head on the Greslin Discord chanel. There under Sim Settlments forum you will find:
1. A little guide how to play SS/SSC with PANPC
2. Patch for SS/SSC which adds the NoEnable keyword to every Non-Player Character which in efective stop PANPC to take any king of controle over NPC-s added by SS/SSC.
 

Sneed Gaming

New Member
Messages
5
First, thanks for the detailed response, Versus. I do have Buffout 4 installed and I will see if I can generate a crash report and post it to their nexus page.

Checking my active plugins list, I have the full Season 1 city plan pack active and one of the plugins (Outpost Zimonja) from the Season 2 plan pack active as well, while the rest of those are deactivated. I'm not sure why they're showing up as active on the load order report since they're unchecked in MO2. It could be that these look like the redundant plugins you mentioned. I am using Kleptoheart's plan for Starlight Drive-in, but I should mention that with further testing I've found that I crash after a few seconds in any pre-built settlement, or at least also Oberland Station and on a previous game, Tenpines.

I have uninstalled multiple mods such as Armorsmith Extended and Super Mutant Overhaul since getting these errors, because they're large and because I'm pretty sure they made raiders in my game show up naked. I don't believe they are the cause of my crashes since they were removed after I found Starlight and Oberland. I had Scrap Everything on my last trial playthrough, but when I got crashes approaching Tenpines, I deleted that mod and started a new game.

I too have around 1/2 the settlements pre-built, or a little less. I've tried to space them evenly around the map and have avoided pre-building in the triangle of death.
 

Lazar Gecic

Member
Messages
60
I too have around 1/2 the settlements pre-built, or a little less. I've tried to space them evenly around the map and have avoided pre-building in the triangle of death.
On what level are they prebuild(higher level more script data) and do you have autobuild ON(this fuctions alone is the heavies part because it has a lot of things doing in the backround).
 

Lazar Gecic

Member
Messages
60
They are prebuilt at level 3, and I'm pretty sure I turned autobuild off.
That's 13 prebuild settlments on level 3. That by itself is heavy. In my game I use level 3 cities as hubs and never have more the 3-4 of them, while others are level 2 or 1. Heck when I prebuild 11 of them on level 3 I can't doo the first attack trou quiestline with Jammer. My game allways crash.
 

Sneed Gaming

New Member
Messages
5
Hmm, the people at Buffout 4 tell me its a graphics driver issue, so I looked into which mods would be stressing my graphics card the most. I have disabled my Touch of Green flora mod, and for some reason, I can finally enter settlements without a crash. Perhaps it was just too much when combined with all the buildings being generated. I'm going to tentatively say this one is solved! Now onto the next issues, namely naked raiders and the plot-generated turrets shooting at their own factions controlling the pre-built settlements.
 
Top