the Sim Settlements forums!

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Question Conveyor belt wiring causes reproduceable crash for power tools

Cranky Cat

Active Member
Patreon Supporter
Community Rockstar
Hi all, I decided to make another go with Fallout 4 since I didn't ever finish before. I'm just testing still and wanted to try to make some test designs and, naturally, made the game crash. Fortunately there are all sorts of logging tools now so I was able to find the issue in the logs.
Starting from a fresh settlement which I never built anything in I created the combination on the left. If I go to the workbench and choose "Power Tools" and either "Destroy All Wiring" or "Rebuild Power Grid and Wiring" then the game crashes shortly after entering the workshop. Fortunately, there was an easy fix to not directly wire two conveyor belts with connectors together.

It doesn't crash if I only create the two conveyor belts and wire them together with nothing else. Anyway, I don't know if this is related to any other issues which may be occurring or is just a rare combination that I found but I hope this helps!

Ugh, the more wires I have the more likely a random wire will cause the game to crash when either "destroy wires" or "Rebuild Power Grid and Wiring" are used. I tried eliminating conduits and just using wires and now I get these. I can look in the logs and see something like this and then delete the wire manually but it just ends up having another error later until there's not much left. My first case had a specific wire but now I have no idea what causes the game to constantly crash when powertools deletes wires.
[11/19/2022 - 04:41:04PM] Attempting to scrap wire: [ObjectReference < (FF00D763)>]

Also, no crashlog is ever created.

Edit: I exported my settlement and imported it to my pre-build save and it was fine so it wasn't a specific combination but something I must have done while working on my building in-game that caused wiring issues somehow. I'm using just vanilla power connectors though since I want to export eventually so no idea what I could have done. Ah well, the original reproduceable issue still stands though and perhaps finding the issue which causes the crash in that situation will point to a way to avoid crashing if someone else can reproduce is.

I disabled both auto-destroy and auto-check power options in WSFW and the auto-repair option from Transfer Settlements to try to add visibility for any issues. Fortunately, I'm still testing and haven't started a "real" game yet. I just occasionally stop and destroy/rebuild the powergrid to see if I've broken it yet so I don't go too far :|
Last edited:
I had something similar. When I ran the "auto wire" function from the workbench, it would run a wire from a power pole to the workbench. It did that in all settlements in that save. There was no "smoking gun" to be found. I started a new game with the same load order and could not reproduce the issue. My only guess is there is a very rare chance for something engine related to glitch and cause strange power grid issues.
My only guess is there is a very rare chance for something engine related to glitch and cause strange power grid issues.
In the pic on the left there is another check going on that is not present in the second pic. Lets just switch those two conveyers for two turrets. In pic one if the turret that the power goes to first were to get damaged then the second turret would shut down. Anything powered also acts like a switch, vanilla. I have run into the same issue with advanced beacons where the tower seems to pass through power even when not operating. Often it was my power out pole, I would get a delayed freeze in the settlement when wired that way. As soon as I went back to wiring those normal and not passing power through them that problem went away.
I tried the same same exact test as the first time and it didn't crash this time. The order of the build and connection may matter so I though of how I was actually doing my wiring and did the following:

1. Build 2 conveyor belts which have connectors, wire together.
2. Add connector and connect to one of the conveyor belts.
3. Add a switch and wire to connector.
4. Add the small generator and connect to switch.
5. Go to powertools from the workbench and choose rebuild powergrid and wiring.

Hopefully the example I gave is reproduceable by the devs and can be used to find and resolve an issue with the wire deletion code crashing the game when it's executed from build mode. Conveyor belts specifically act like conduits and can snap to other conveyor belts which have no power connector on them.

Two turrets crashed the game for me in the same configuration as the conveyor belts - sometimes. I build them the same way as the conveyor belts and the rebuild powergrid and wiring didn't crash. Then I turned off the switch and ran the rebuild again and then it crashed. However, I didn't have to do this with the conveyor belts.
Eh, I think maybe it was all a red herring. The rebuild/rewire crashes some of the time no matter what I do. I just reload and try again and it'll eventually work even if I don't change anything at all.