Workshop Resource Manager Issues

Discussion in 'Workshop Framework Bug Reports Archive' started by MrJacean, Nov 11, 2018.

  1. MrJacean

    MrJacean Member

    Joined:
    Sep 29, 2018
    Messages:
    0
    Likes Received:
    0

    Updated most recent SS 3in1 and WSFW/WS+ and WSFM seems to be causing near immediate CTD in game.

    Getting a lot of workshopscript.vendorIncome issues followed by a very long string of Resource manager errors like the following

    Starting timer to retry daily update. Awaiting properties to be configured from WSFWResourceManager
     
  2. kinggath

    kinggath Well-Known Member Staff Member Administrator Moderator Verified Builder

    Joined:
    May 8, 2017
    Messages:
    3,620
    Likes Received:
    3,231

    Existing save or a new one? I've been playing with the latest versions all day, so hoping for some more info to replicate this.
     
  3. MrJacean

    MrJacean Member

    Joined:
    Sep 29, 2018
    Messages:
    0
    Likes Received:
    0

    Existing save.

    One thing I just noticed was that the message I received was that SS updated to 3.046 not 50. Did you update the internal number to with the removal of the complex plans? If so It might be a bethesda net mismatch again and I'll just have to delete and reinstall from Nexus. (One note, Nexus Vortex for whatever reason didn't show an available update from 3.040 even though obviously that was out of date)

    Tried new save, didn't have the crash but not sure if that would be relevant as new save wouldn't be loading Sim Settlements yet and I disabled WS FW and WS+ to review but it was still crashing without.

    Existing save with SS, WS FW and WS+ disabled, no crash. I'm thinking that even though this is saying WS FW, I'm seeing that I'm getting WS FW AV issues with just sim settlements so I'm thinking that's just variable name changes to the core of SS.

    Going to delete and verify I'm actually running 50 as it seemed like a lot of people were having issues with 46.
     
  4. MrJacean

    MrJacean Member

    Joined:
    Sep 29, 2018
    Messages:
    0
    Likes Received:
    0

    So verified and deleted, reinstalled everything to latest version (Btw seems to be a numbering mismatch between versions relating to what Nexus says is newest vs bethnet newest) but it still says 3.0406 no 50 on SS update message prompt.

    Failure seems to be with the Starting WSFW_DailyUpdate_AdjustResourceValues routine. Does this series of evaluations have problem with non-vanilla settlements? As it properly skips the empty ones, reviews some of the standard ones, but then quickly lags/dies from there. Wondering if it might be from placing a City planner desk in an area that SS doesn't think should be a city to make use of the automatic deployment of weapons and armors without having a city leader or city plan enabled.
     
  5. kinggath

    kinggath Well-Known Member Staff Member Administrator Moderator Verified Builder

    Joined:
    May 8, 2017
    Messages:
    3,620
    Likes Received:
    3,231

    So long as the non-vanilla settlement was designed correctly, it will not have any issues.

    The City Planner's desks have no impact on anything like that.
     
  6. MrJacean

    MrJacean Member

    Joined:
    Sep 29, 2018
    Messages:
    0
    Likes Received:
    0

    Well by all accounts the alternative settlements appear to be designed correctly without issues, but either way this doesn't appear to be workshop framework related, it's relative to the latest sim settlements as with newest WSFM and WS+ installed with Sim Settlements disabled, no CTD. So something in the script changes as it's trying to find references to things it can't find. SKK Script Latency is also pulling the same scripts as the cause of lag and Crash.
     
  7. kinggath

    kinggath Well-Known Member Staff Member Administrator Moderator Verified Builder

    Joined:
    May 8, 2017
    Messages:
    3,620
    Likes Received:
    3,231

    Which scripts is it reporting?
     

Share This Page