the Sim Settlements forums!

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

V1.2 and up will require all DLC

Kana292

Active Member
Staff member
Verified Builder
Wiki Contributor
Messages
508
Sorry for anyone not having all the DLC, but all future versions of Hunter Gather will require them. I will leave Version 1.1 (Non-DLC) on Nexus and Bethesda for anyone not having the DLC.
 

uituit

Secretary ;)
Staff member
Administrator
Moderator
Verified Builder
Support Team
Wiki Contributor
Messages
2,823
Top