unable to load save game

Discussion in 'Bug Reports' started by mlwest1970, Aug 19, 2017.

  1. mlwest1970

    mlwest1970 Member

    Joined:
    May 17, 2017
    Messages:
    62
    Likes Received:
    22

    Having a new issue here. I started a new game from a vault save and did the whole sim settlements setup just so I could have a test save to play with the add on packs. Made my save. This morning I go in and enable your add on pack along with wasteland ventures, industrial city, jtbryants utilities, ruined homes and gardens, classic shacks, braes defenses, hunter-gather, and sim towers. Built a ton of plots in sanctuary and had to quit, so I made a save. I came back to it this evening and couldn't load the save. I disabled mods and when I disabled animal farm I was able to load the save. Tried it on some other saves that I had with animal farm installed and got the same results until I disabled it. This is on xb1 and i can send you the LO I use if you would like.
     
  2. kinggath

    kinggath Well-Known Member Staff Member Administrator Moderator Verified Builder

    Joined:
    May 8, 2017
    Messages:
    3,659
    Likes Received:
    3,345

    I'm on a kick helping out with add-on bug reports tonight - so I'll give this one a shot ;)

    Could you test moving animal farm up a couple spaces in your load order to see if you have different results?
     
  3. mlwest1970

    mlwest1970 Member

    Joined:
    May 17, 2017
    Messages:
    62
    Likes Received:
    22

    sure. Right now I have it set up as follows:
    Sim Settlements
    Cheat Terminal
    HUD Framework
    Cobb water options
    Give me back my bottle
    No legendary spawns
    Slow healing / Rad Removal
    Settlement Management Menu
    Sim - Industrial Revolution
    Wasteland Ventures
    Animal Farm
    All other mods...
    I'll move it above WV and see what happens. Otherwise I don't think you want it above Industrial Revolution.

    Edit: Moved it just below Industrial Rev and CTD. Moved it just above IR and CTD. Moved it directly under sim settlements and still won't load.
     
    Last edited: Aug 20, 2017
  4. Altairp

    Altairp Mayor of the Farm Staff Member Verified Builder

    Joined:
    May 12, 2017
    Messages:
    119
    Likes Received:
    78

    Can you access the game, if you disable it?

    If so, could you move away from any settlement you have with my plots, save, check the mod again and see if the game starts?
     
  5. mlwest1970

    mlwest1970 Member

    Joined:
    May 17, 2017
    Messages:
    62
    Likes Received:
    22

    sorry for the late reply. I am able to access the game if I disable it. I did so, moved away from sanctuary to the gate for vault 111. Saved the game, checked the mod and I am able to access the game. I went back to sanctuary hills. Your plot had been one of the two molerat plots. It had reset itself to the tato mud farm, but there was nothing there, just a settler in mid air farming :). I selected the molerat enclosure from the ASAM. I waited for that to build, then made a save and I then quit the game. I quite fallout and then reloaded it. I am able to access this save
    I still cannot access any of the saves from last evening that I made, which had only plots, but nothing had been constructed. Those saves were also made in Sanctuary Hills.

    edit:
    once I load one save successfully I can load all saves that I was previously unable to load. If I quit fallout, then I am no longer able to load any of the saves that I had an issue with until I load the save that I created above.
     
    Last edited: Aug 20, 2017
  6. Altairp

    Altairp Mayor of the Farm Staff Member Verified Builder

    Joined:
    May 12, 2017
    Messages:
    119
    Likes Received:
    78

    That's really weird. So the bugged Sanctuary didn't have any actual building constructed? Just the agricultural plot areas?

    Also: is this the first time you're trying the add-on after updating to the latest version? Had any similar issues before?
     
  7. mlwest1970

    mlwest1970 Member

    Joined:
    May 17, 2017
    Messages:
    62
    Likes Received:
    22

    It actually had a home and the molerat milk pen. Rest of the plots were just down for place holders when I got settlers. I'm still working with it though. I am trying to figure out what plots are down that could make this happen. I have another that I believe had four industrial plots for rent and four homes for rent (nothing built yet) and the same thing is happening. I'll keep you posted on my end as well.
     
  8. mlwest1970

    mlwest1970 Member

    Joined:
    May 17, 2017
    Messages:
    62
    Likes Received:
    22

    Also forgot to answer your other question, this did start occurring after the update to the add on.
     
  9. Altairp

    Altairp Mayor of the Farm Staff Member Verified Builder

    Joined:
    May 12, 2017
    Messages:
    119
    Likes Received:
    78

    Be sure to tell me if it happens again.

    As an aside, can you see the Cat Farm and Joe's Mess Hall in the building list?
     
  10. mlwest1970

    mlwest1970 Member

    Joined:
    May 17, 2017
    Messages:
    62
    Likes Received:
    22

    sorry it's been so long. RL got in the way. Ok, I'm still having the problem. I can load the mod for the first time on a save that it has never been loaded into and its fine. Once I make a save, I can quit and I can't load the new save game. No matter what I do unless i disable it, then save and then reenable it.

    I can see the cat farm and joe's mess hall by the way.
     
  11. tankthing

    tankthing NOT the Settler AI designer Administrator Moderator Verified Builder Wiki Contributor

    Joined:
    Jun 2, 2017
    Messages:
    1,681
    Likes Received:
    690

    What happens if you load a previous save, then hit escape and load the current save? I've had problems before where I needed to load a previous save and then load the current one to get it to work.
     
  12. mlwest1970

    mlwest1970 Member

    Joined:
    May 17, 2017
    Messages:
    62
    Likes Received:
    22

    Yeah that i can do, but that is less than ideal.
     
  13. tankthing

    tankthing NOT the Settler AI designer Administrator Moderator Verified Builder Wiki Contributor

    Joined:
    Jun 2, 2017
    Messages:
    1,681
    Likes Received:
    690

    Absolutely agreed that it isn't ideal, my current save is doing addon prototyping using the Minuteman Empire endgame save with almost no mods loaded except Sim Settlements, place everywhere and scrap everything. The sucky part is that every time I load it, I have to load the original save, then load my exit game save or whatever in order to not CTD instantly when loading from the menu.

    It's maddening but I've gotten used to it.
     
  14. mlwest1970

    mlwest1970 Member

    Joined:
    May 17, 2017
    Messages:
    62
    Likes Received:
    22

    It's rather bizarre actually. It works fine on some saves and then CTDs on others. I've looked for a pattern, but it seems random, which I wonder though. As I do software testing IRL, I know there is some sequence of events causing it, but you can't recreate it reliably with this type of game. And trying to do it on an xb1 further complicates the issue as we have no diagnostic tools.
     
  15. Yagisan

    Yagisan Rebuilding the Commonwealth. Vault Librarian Verified Builder

    Joined:
    Jul 8, 2017
    Messages:
    607
    Likes Received:
    681

    Oh dear. I have hit this bug. In survival mode. Ouch.

    The save will load when I disable this mod. There are no plots to disable, as no sim settlement plots have been built anywhere.
     
  16. Altairp

    Altairp Mayor of the Farm Staff Member Verified Builder

    Joined:
    May 12, 2017
    Messages:
    119
    Likes Received:
    78

    Apologises for the late reply, I've been distracted.

    Did the CTDs begin as soon as you started to play with my add-on?
     
  17. Yagisan

    Yagisan Rebuilding the Commonwealth. Vault Librarian Verified Builder

    Joined:
    Jul 8, 2017
    Messages:
    607
    Likes Received:
    681

    I've previously used your addon in the past with no problems.

    In this case I started a new game on survival mode. I went to sanctuary, built a bed and then rescued Garvey. After dragging them back, I slept in the bed to save. Attempting to load that save resulted in a CTD.

    I've done some further testing. Adding your mod to my existing normal game had no problems loading. Adding it to my new horizon/survival game has no problems loading.

    I'm afraid I didn't keep the crashing save, as I er kinda rage quit at 2am and deleted that character.
     
  18. Lynna

    Lynna Member

    Joined:
    Jun 3, 2017
    Messages:
    22
    Likes Received:
    32

    Hey there, Altairp. I just started a new game the other day to play with Rise of the Commonwealth. I played for a while (went to Concord - did the thing - got the things, came back to Sanctuary), then went to bed. When I went to play the next day I couldn't load any of my saves. So, I started again. Played up until I talked to Codsworth the first time, and went to bed again. Went to play the next day, and couldn't load any of my saves. After methodically shutting down each add on to Sim Settlements, I found that it was yours that was causing problems. After unclicking it, I was able to get into all of my saves.

    So, information:

    I could not load a save, regardless of where it was (Sanctuary or Concord).
    I had not started building, nor had I scrapped anything prior to shutting down (and subsequently not being able to get back into a save).
    I had no plots at all laid in either run through at that point.
    I am using 1.0.6c.
    Everything worked fine for me with your mod up until the installation of Rise of the Commonwealth.
    I installed your mod on 12/15 - and was using it before ROTC install.
    I play on PC

    Thank you very much for your fine work. I just wanted to let you know about the issue.
     
    Last edited: Jan 1, 2018
  19. Altairp

    Altairp Mayor of the Farm Staff Member Verified Builder

    Joined:
    May 12, 2017
    Messages:
    119
    Likes Received:
    78

    This CTD bug is so frustrating. I'll see if I can get back to you to test a solution tomorrow.
     
    Yagisan likes this.
  20. Lynna

    Lynna Member

    Joined:
    Jun 3, 2017
    Messages:
    22
    Likes Received:
    32

    Thank you!
     

Share This Page