Not a bug Strange agricultural plot behaviour

Discussion in 'Bug Reports' started by ApoAlaia, Aug 17, 2017.

  1. ApoAlaia

    ApoAlaia Active Member Support Team

    Joined:
    Jul 20, 2017
    Messages:
    176
    Likes Received:
    63

    I have upgraded to v2.0 and ever since the agricultural plots (that were already established) do not have 'ground.'

    The settlers work on them just fine and the vegetables and stuff are there, just there is no 'bed.'

    I have hit them hard with the immersion breaker breaker but no dice.

    Moreover the changelog says that plots should upgrade to lvl4 however in all the settlements there is a tool and die shop (and those agricultural plots that supported it previously already upgraded to lvl4) yet these do not.
     
  2. ruinedworld

    ruinedworld Rebel Without a Pulse Staff Member Moderator Verified Builder

    Joined:
    May 12, 2017
    Messages:
    270
    Likes Received:
    267

    Howdy.... are you are using Sim Settlements Building Plans Tags and more mod? If so you will need to update to his new version, I think he just updated.... That mod alters the esp file, so if we update and he doesn't, it breaks the addon
     
    ApoAlaia likes this.
  3. ApoAlaia

    ApoAlaia Active Member Support Team

    Joined:
    Jul 20, 2017
    Messages:
    176
    Likes Received:
    63

    Aha!

    Well that would explain it.

    Might also explain some other... aberrations I have been experiencing with a different AddOn that was updated recently too.

    Thank you very much for your quick reply!

    Off to update I go!

    EDIT: Update is not up yet so I have uninstalled it for now. Elated that removing it has not corrupted my save (more than it already was :P )
     
    ruinedworld likes this.
  4. ruinedworld

    ruinedworld Rebel Without a Pulse Staff Member Moderator Verified Builder

    Joined:
    May 12, 2017
    Messages:
    270
    Likes Received:
    267

    I believe, if you reinstall the add-on packs esp files that were updated, and then refresh the plots, it should fix everything, but I am not 100% sure of everything he changed, so I would need to test it.
     
  5. ruinedworld

    ruinedworld Rebel Without a Pulse Staff Member Moderator Verified Builder

    Joined:
    May 12, 2017
    Messages:
    270
    Likes Received:
    267

    I gave the mod author a few days warning I was about to update.... I had a feeling a bunch of players might start having issues with how his mod works... :)
     
  6. ApoAlaia

    ApoAlaia Active Member Support Team

    Joined:
    Jul 20, 2017
    Messages:
    176
    Likes Received:
    63

    I did another round of Immersion Breaker Breaker and everything seems to have come to its senses now.

    Apart from the issues with your AddOn plots for no apparent reason the scrapyards that are part of Industrial Revolution (and subsequent tier 2 upgrades of that plot) stopped upgrading using the stockpile method.

    I have not tested if they've gone back to normal now, will do when I start populating a new settlement.

    Either way his mod is pretty nifty but with so many addons that are not 'feature complete' to keep track of, each one with its own schedule, is going to be quite a bit of work for this person to keep up.

    I sincerely hope he does not burn and manages to see this through - I like his mod.

    EDIT: Changed the wording of the last sentence, sounded incredibly selfish and callous. Should not write posts before my first coffee in the morning.

    EDIT2: I guess there is no way to get the nice 3D plot preview without messing with the addons as his mod does?
     
    Last edited: Aug 18, 2017
  7. BebopCola

    BebopCola New Member

    Joined:
    Jan 20, 2018
    Messages:
    5
    Likes Received:
    1

    I've had what I think is a similar issue where some of my agricultural plots from this mod would simply reset, but leave their crops and any extras, such as scarecrows and water pipes, in place. The cinderblock walls and everything else would just disappear. Refreshing the plot would proceed to rebuild it, but the crops left behind remain, and will attract settlers to work them.

    I tried to remove the plot entirely, thinking it might clean up the abandoned elements, but no dice. I've attached a screenshot of the issue.

    I prefer these plots over the regular Sim Settlements plots for the most part, so I haven't tested those as extensively to see if the behavior is more generally linked to all agricultural plots of just these, but I've had three plots experience this so far with little to no way to clear out the abandoned items once it happens.

    Any help would be appreciated.
     

    Attached Files:

  8. ruinedworld

    ruinedworld Rebel Without a Pulse Staff Member Moderator Verified Builder

    Joined:
    May 12, 2017
    Messages:
    270
    Likes Received:
    267

    Hello,

    I am glad you like my plots... :)

    have you tried running the [cleanup up settlement] tool in the city planner tape tools/ catagory... this seems like script lag might have left stuff behind for some reason...
     
  9. BebopCola

    BebopCola New Member

    Joined:
    Jan 20, 2018
    Messages:
    5
    Likes Received:
    1

    I have, but no luck.

    I've been reading a bit on other Sim Settlement issues, and it occurs to me this might have happened with an industrial plot at one point as well, and I'm suspecting it's related to an issue with the 3-in-1 install of the base mod. Apparently folks are reporting issues of plots resetting to level 0, and it sounds similar to what I've been experiencing.
     
  10. ruinedworld

    ruinedworld Rebel Without a Pulse Staff Member Moderator Verified Builder

    Joined:
    May 12, 2017
    Messages:
    270
    Likes Received:
    267

    hmmm... thats odd...
     

Share This Page