the Sim Settlements forums!

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Still Valid To Play?


Active Member
Is Conqueror still valid to play? I appreciate it won't get any updates except for major bug fixes, and the story itself isn't complete and won't be, but I wanted to play it again. Any SS:L mods to avoid installing?
The last I tried, a whole bunch of vanilla content was broken with either Conqueror or one of the supporting SS1 mods and I gave up trying to run it. The biggest recurring problem was NPCs no longer able to path in a lot of quest content (e.g. Edward Deegan would be stuck at the entrance to Cabot House and Jack wouldn't come down the stairs, various quests were not able to progress because NPC dialogue would never fire because they couldn't get to their goal location etc).
What I'm wondering too is the latest version of Workshop FW and Plus . . . will they play nice with Legacy?
i hope it will still get a ss2 release tho haven't heard anything about it in a while
i use to have a few issues performance mostly and ofcours black face
but i tried again few days ago and it was bad to name a few
raiders moving them self's off plots
raiders changing back to warrior
new warriors not registering and standing in there spawn spot blocking any new troops from joining
and some raiders not registering that outpost was there's and refusing to lower there guns or be assigned a job
Absolutely still valid to play, just enjoyed the massive setpiece battle at redacted =D =D =D

Bugs I've found in my heavily modded playthrough are:

1) Graygarden robots wouldn't chill - kept murdering the guards! Only happened in that settlement though, so kept it unloaded.

2) Finickitiness in the walky quests. Several times you're walking with an NPC, and if you get interrupted? NPCs wander Super Mutants chance upon you? PANPC triggers round the bend? True Storms ghoul attack? Automatron encounter? Quest locks, demanding sqs and Setstage to fix.

3) Super Mutants from the Super Mutant faction pack never showed.

4) Children of Atom from the CoA faction pack stormed a settlement, mullered me a dozen times. Had to flee while attack in action. The quest never failed, and I didn't lose the vassal...

5) Built a wall to protect jeering raiders in a Jammer HQ encounter. Didn't want him shooting my precious army up. Bugged Jammer, had to reload to prior that point.

6) Using charisma persuasion on hostile Minutemen locked a "kill all" quest. And they would have made such good raiders

7) Guards forgetting their defence assignments in vassals. Didn't care much about their happiness though (and settlement attacks are taken over by Conqueror's system anyway)

8) Item sort mod incompatibility (there's Conqueror misc items in Workshop Framework). How I wish SS script misc items had a keyword...

9) RotC pre-built Starlight Settlement caused FPS drops & uses weird martial/commerce interior plots (settlement was built before the plot changed type). Could be worked around by blacklisting it/using another Starlight settlement in the startup sequence

10) Had to disable soldier needs due to it's finickitiness (didn't want to babysit vassals, but they didn't produce enough caps). Roleplayed a mix of vassals/outposts anyway

11) Had to force-level some vassal city plans - I selected random, but e.g. The Slog didn't get any defences, which hurt immersion. Wished I could have had random city plans PLUS some defined built up ones

12) Weirdness when building a city plan. Squad had to be ordered to sit still. The flyby triggered a massive PANPC fight with those muppets running all over
- 12 b) Changing race for the flyby fixed a speed bug caused by using RAW and (some other motion mod I forget). Despite my xEdit patch. Must remember that race change trick for the future.

13) Soft incompatibility with HUD mod. Compass needed re-enabling. Certain quests demanded certain NPC deaths, or else it soft locks.

14) A main quest attack on my HQ by NPCs that never moved

15) Some weirdness with enslaved categorised as civilians. Enslaved without collars. Civilians with collars. Numbers not adding up (4 guards on the HUD, but only 3 in the settlement)

16) Not really a bug, but I gave up on recruiting properly and built a metric fucktonne of beds to get the army up. Kinda strange to go back to pre-SS building.

17) Wall busters didn't blow holes in RotC Taffington walls

18) Ack-ack killing Dakka's raiders (the raiders didn't fight back. She literally butchered them).

19) Couldn't lure the Sentry Bot to the molerat den (too far away). Used a nuka grenade - which the quest didn't register. Despite calling for a nuke explosion. Further convinced adventure clue games discriminate against neurodivergents XD

20) 19 is an awkward number to end on :) Oh yeah, slaving raids didn't work as I thought. I thought it'd be loss mitigation - you fail an attack, but you're compensated by enslaving as many as you can. Nope you just lose. Don't raid through Jammer, raid through the War Table.

21) Oh and I had a free Raider Prospect duo that always joined later assaults, wouldn't take no as an answer from the raid party selection

Huh now I've typed it all out, that is a big list... Still the central feature - Assaults - worked wonderfully, characters were well written and voiced, and that setpiece battle. Dang I'm glad I had my China Lake!
Last edited:
Should add that I was playing with the P113 Plasma Caster, which comes with a workshop script that breaks the UF4P & Workshop Framework :party: That might explain some breakages!