the Sim Settlements forums!

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Question (SOLVED) SS2 Nif loading error in Geck

Reprobite

New Member
Messages
3
I've been following the guides in the new 'AddOn Toolkit', and today I wanted to try to build a model, but haven't been able to get very far.
The guide tells me to drag 'SS2_BuildingPlanStarterPI_2x2' into the window, but the Geck gives me an error message and the asset loads in with a missing mesh exclamation mark, and all of the other BuildingStarterPl_ files do it as well. I assume this isn't correct.

I got through the wall retexture guide with no problems, and the Geck has no problem loading any of the assets to actually design a plot.
The log error says "MODELS:Could not queue model SS2\Helpers\AlignmentHelpers\2x2Flat.nif"

It's possible my Geck install is broken as I get a large number of errors upon loading the esm files, but I tried reinstalling it once already to no avail. I have also tried running the Geck from MO2 and from the exe directly in the data folder to see if the former was the issue.
I've additionally tried three separate versions of the mod and have the same problem. Currently using 1.0.1b.

I've been trying on and off for a number of hours to fix this and I'm generally out of ideas. I don't know enough about the Geck, so there's probably something I'm missing.
Can anyone help me? I would appreciate it immensely.
 

Tinuvia

Wasteland Venturers
Staff member
Moderator
Verified Builder
Support Team
Messages
926
Make sure you get the latest beta from here:

It includes the missing meshes. They will also be in the regular patch that gets published later today (if everything follows the plan).

The huge amount of errors when loading the esms is just the Creation Kit being the Creation Kit. Just minimize the error window and drag it to the side. If you get an error pop up when you load up your esp mentioning to look in the *"EditorWarnings.txt" that usually actually has relevant information. Making mods through Mod Organizer works, but sometimes you need to setup workarounds (if you should start writing Papyrus scripts) and keep a look out in the Overwrite folder if you are missing files.
 

Reprobite

New Member
Messages
3
I noticed a number of the 1000+ errors were related to QASmoke which I know is a testing area, so I assumed they can't all have been an error with my files and more a remnant of Bethesda's coding errors. But a number near the top were the Geck trying to load things that were leftovers in the Data folder from mods I didn't uninstall correctly, reference files leading to empty folders or something, so I thought it could be some sort of error with my files interfering and causing it not to load the files.

Thanks again though, I've been pulling my hair out for the last couple of hours because I somehow missed seeing the C update and got B earlier. I'll update the header title to state the problem's been resolved.
 
Top