the Sim Settlements forums!

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Solved [SOLVED] spawning bug, need help

originalsnub

New Member
Messages
2
This may or may not have to do with sim settlements conqueror, though it seems to have arrived concurrently.
Im using a mod called npc spawner- dangerzone, and have been for a while. I use a handful of other mods to spawn npcs on the fly like dangerzone does, and lately they wont spawn or apparently sandbox on anything I build in the workshop, but rather below or over and adjacent on the "vanilla bottom." NPCs still sandbox otherwise, pumping water, working, hammering, pumping water, occupying ground level defense posts, and pumping water, but no stairs, no manning the walls and towers, no interacting with the 10 or so stories I want to build above them at all. The only npc placement I can successfully place on built floors utilizes a "place-from workshop" m.o. and even that prevents them from moving around and gets them "bucked off" afterwards.

So it seems to be a sandboxing/navmesh issue. Ive been perusing around trying to learn more about how navmeshing and sandoxing works and what all ive done to this game.Here's some of what I tried:

Reloading, reinstalling, and restarting. All mods mentioned along with the whole sim/Wframework shebang, as well as new games, off of the idea I broke the initial loading of sim or conqueror. during the beginning load of plots and settlements and stuff. Had it at one point but updated sim everything and lost it.

Let it loooad. Although I do have a theory using dangerzone to spawn before conqueror load completion being the reason and kinda thought "it'd be fine" near the very end on a few, off of the advice that this process needs some patience, Ive been staying still in game, loading cells near concord before proceeding, and generally waiting as much as I can. This process has been difficult with sim updates as additional variables and finally by the fact that new saves to the finish screen is a slow, slow process. Ive only had time to do a handful of tries and had no lasting luck.

Updating. Hoped in vain each update would just incidentally fix the problem. Got rid of some freezing, some ctds came and went on a few loads, no luck. Have not had time for most recent update, here to hoping someone can tell me that will fix it.

Yet more mods. Never my brightest idea, Ive hoped new saves with a sandboxing mod called more npc sandboxing expansion and its requisites, would help. Another mod with invisible mats to manually create navmesh paths went in as well. No luck whatsoever or change.

So Im assuming Ive broken the navmesh system in some way, in a manner worryingly similar feeling to common fo4 settlement bugs. All npcs still fight, follow, and go about all other business in settlements and elsewhere. While Im waiting through my next attempt, Im looking for any advice whatsoever on what seems to be the culprit, or on navmeshing in general and how conqueror affects these systems. Any guidance would be appreciated and let me know what else info you could use. Thanks!

ps. also currently missing option to remover abernathy from original conqueror settlement list at start up. But it didnt work when none of the triangle of death settlements were unbuilt either.
 

RayBo

Well-Known Member
Moderator
Patreon Supporter
Community Rockstar
Support Team
Vault Librarian
Messages
2,350
Wow, :umnik2 that is a big write up. :slow

From what you said nothing indicates a nav-mesh issue? I think you are correct, sometimes with sandbox problems, NPC activity can be a symptom of another problem but until you remove many of the possibilities it is going to be really hard to recommend solutions :unknw
Often, when they seem to bunch it seems to be a script problem.

I don't use dangerzone but it hasn't been updated in near 2 years and the author hasn't been active in a long time. Not something I would hold on too if you think that might be the problem. :nea

I would disable all mods except sim-settlement related and maybe a very few others and restart the game. :this

When you get to a good point outside vault 111 and everything is running well make a controlled save and see how well they "the questionable mods" work. If they don't roll back your save to the controlled save you made earlier. :moil

Never play forward while testing then remove a mod without rolling back to before the point you installed it. :yes3
 
Last edited:

originalsnub

New Member
Messages
2
Its Build High. Chatter on the mod page seems to corroborate-- several posts about it not playing nicely with sim suite and workshop framework for lots of different, little reasons. All settlements extended seems to do the same, hopefully Im on the right track and whats more hopefully theres a mod that will extend the build area without problems.

Thanks for the help there, Raybo.
 

RayBo

Well-Known Member
Moderator
Patreon Supporter
Community Rockstar
Support Team
Vault Librarian
Messages
2,350
Its Build High. Chatter on the mod page seems to corroborate-- several posts about it not playing nicely with sim suite and workshop framework for lots of different, little reasons. All settlements extended seems to do the same, hopefully Im on the right track and whats more hopefully theres a mod that will extend the build area without problems.

Thanks for the help there, Raybo.

Thank you for the kind reply and follow-up :bye

AllSettlementsExtended is fine as long as you never mix a city-plan in at the same location:good
 
Top