Possible Active Script Creep

Discussion in 'Workshop Framework Bug Reports Archive' started by Ravenholme, Oct 2, 2018.

  1. Ravenholme

    Ravenholme New Member

    Joined:
    Oct 2, 2018
    Messages:
    0
    Likes Received:
    4

    Using Workshop framework 1.0.2 loading a save with 2 active scripts notice about a half-hour into game play my save file has 62 active scripts referencing workshopframework::workshopresourcemanager. Playing another 20 min or so the count is now 86.

    I have a little over 8 settlements all built by hand not using city map planner at the moment.
     
  2. woodfuzzy

    woodfuzzy Probably a Synth or... Verified Builder

    Joined:
    May 18, 2017
    Messages:
    1,408
    Likes Received:
    1,022

    Are you also running UFO4P? If so.. the bug originated from it. I'm not sure IF the fix Kinggath did in WSFW effects UFO4P.
    Is your Papyrus logs getting larger?
     
  3. Ravenholme

    Ravenholme New Member

    Joined:
    Oct 2, 2018
    Messages:
    0
    Likes Received:
    4

    I am currently not using UFO4P I stopped using it strictly for this mod. I do not have papyrus logging enabled. I will turn it on and see what I get.
     
  4. Ravenholme

    Ravenholme New Member

    Joined:
    Oct 2, 2018
    Messages:
    0
    Likes Received:
    4

    Log file went to 4mb. I waited 24 hours in game and the log was 6mb. I created a test save with the active scripts deleted, loaded the test save and then quick saved. the quick save file had 39 active scripts for resource manager.
     
  5. Ravenholme

    Ravenholme New Member

    Joined:
    Oct 2, 2018
    Messages:
    0
    Likes Received:
    4

    I uninstalled the mod and loaded save after cleaning out the active scripts. Reinstalled 1.02 and everything seems to be working OK now.
     
  6. Ravenholme

    Ravenholme New Member

    Joined:
    Oct 2, 2018
    Messages:
    0
    Likes Received:
    4

    The mod seemed to be working for a while but now I have many active scripts from workshopframework
    activescripts.png
     
    VersusXV and RayBo like this.
  7. kinggath

    kinggath Well-Known Member Staff Member Administrator Moderator Verified Builder

    Joined:
    May 8, 2017
    Messages:
    3,620
    Likes Received:
    3,231

    @Ravenholme Can you expand one of those so I can see what function it's backing up on? That might not be backup at all, but a snapshot of a large operation.
     
  8. Ravenholme

    Ravenholme New Member

    Joined:
    Oct 2, 2018
    Messages:
    0
    Likes Received:
    4

    activescriptsExpanded.png
     
    VersusXV and RayBo like this.
  9. Ravenholme

    Ravenholme New Member

    Joined:
    Oct 2, 2018
    Messages:
    0
    Likes Received:
    4

    seems like I can uninstall the mod make a save reinstall and it works fine again for a while.
     
  10. kinggath

    kinggath Well-Known Member Staff Member Administrator Moderator Verified Builder

    Joined:
    May 8, 2017
    Messages:
    3,620
    Likes Received:
    3,231

    Clean installing the mod to fix that is probably not a good idea. The framework is pretty low level in your settlement data and you're likely leaving a lot of artifacts in your save from it.

    We should get this figured out.

    Are you using a lot of City plans? Doing a lot of building? If the save gets past 100 of those scripts and you leave your character sit for a while, do they eventually clear up?

    If they aren't clearing up, then either I have an infinite loop in the code, or there's something wrong in your save file.

    If they are clearing up, then likely this function is just too slow and I need to rewrite it in another way.
     
    VersusXV and RayBo like this.
  11. Ravenholme

    Ravenholme New Member

    Joined:
    Oct 2, 2018
    Messages:
    0
    Likes Received:
    4

    I never see my save go above 5 – 10 active scripts. I have a lot of workshop item mods (USO being the main one) but only use Sim Settlements that does any kind of major settlement change. I use a modified AIO SS for the large passive power radius, so I don’t have to wire power to every 10 square feet for a simple light.


    When I experienced this the first time I went far away to an instanced zone and waited for about 10 minutes (not using wait just sat there for 10 real minutes). And the list just gets longer. I tried waiting for 3 days in game with wait feature and the game crashed shortly after the 3rd 24-hour cycle ended (possible fallout 4 just being fallout 4).

    I am currently not using City Plans all settlements have been built by hand.

    On a side note;


    I’m going to assume that this is a result of your mod. My settlers for the first time seem to have a brain. I have yet to see one stand around for long they all appear to be going somewhere and doing somethings. It’s truly unprecedented work.

    Thanks for your dedication.
     
  12. Ravenholme

    Ravenholme New Member

    Joined:
    Oct 2, 2018
    Messages:
    0
    Likes Received:
    4

    I’m going to start a new game as its most likely and issue with my save.
     
  13. kinggath

    kinggath Well-Known Member Staff Member Administrator Moderator Verified Builder

    Joined:
    May 8, 2017
    Messages:
    3,620
    Likes Received:
    3,231

    Keep me posted. If there is an infinite loop, I need to crush it ASAP so we don't end up with swathes of broken saves.

    Given that you're the only report in this vein, I'm hopeful it's a save file issue.
     
    VersusXV and RayBo like this.
  14. Gonzz

    Gonzz New Member

    Joined:
    Jan 7, 2018
    Messages:
    3
    Likes Received:
    1

    Hi Kinggath, I too had this problem. I actually just assumed it was the UF4P infinite loop I was hearing about and reverted to an earlier save, where the scripts hadn't backed up, and updated both WF and UF4P. I've been monitoring my scripts since and so far the problem hasn't returned.This said, I haven't played that many hours.
    Given that it seems to be a separate issue, here's a screen from Falrim tools. I'm not able to get them all in the image, at the time I had over 140 active scripts.
    scripts.jpg
     
  15. Gonzz

    Gonzz New Member

    Joined:
    Jan 7, 2018
    Messages:
    3
    Likes Received:
    1

    I literally spoke too soon, went to resaver to check yesterday's save file and the scripts are back. The one just before is fine. This save was just after fast travelling from Warwick to Murkwater, where I have a city plan at level 0
    scripts2.jpg
     
  16. Gonzz

    Gonzz New Member

    Joined:
    Jan 7, 2018
    Messages:
    3
    Likes Received:
    1

    This is a savefile with a LOT of time put into it, hundreds of mods, some not always uninstalled correctly, and that has had problems before. It's like an old car full of glitches that can fall appart at any moment, so it may very well be a save file issue.
     
  17. kinggath

    kinggath Well-Known Member Staff Member Administrator Moderator Verified Builder

    Joined:
    May 8, 2017
    Messages:
    3,620
    Likes Received:
    3,231

    @Gonzz That save looks like it is early enough into the problem that I can probably learn something useful. Can you post it to dropbox and PM me a link?
     
  18. Gonzz

    Gonzz New Member

    Joined:
    Jan 7, 2018
    Messages:
    3
    Likes Received:
    1

    I've uploaded it to wetransfer and have a link, but can't find how to PM in this forum, can you help pls
     
  19. kinggath

    kinggath Well-Known Member Staff Member Administrator Moderator Verified Builder

    Joined:
    May 8, 2017
    Messages:
    3,620
    Likes Received:
    3,231

    @Gonzz Click my name and choose Start a Conversation.
     
  20. Gonzz

    Gonzz New Member

    Joined:
    Jan 7, 2018
    Messages:
    3
    Likes Received:
    1

    Ok, I've sent you the link, hope it helps track down the issue!
     

Share This Page