the Sim Settlements forums!

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Plots not upgrading if they have changed with city level upgrade

GavMan

Member
City Planner (S3)
Messages
74
Just wondering if anyone else has experienced anything similar...
I have a couple of plots that I changed
Case 1: used the customize plot option to change an industrial plot to commercial - plot not moved in any fashion just the type changed. From city plan level 1 to 2 it should change from Building materials level 1 plot to [WV] Ice cream and Power Armor level 2. The plot changes type but is left at level 0.
Case 2: In city plan change from level 2 to 3. Same plot type, just a change in Building plan - the Watershed Municipal Level 2 to Industrial waterworks level 3. Plot changes but is left unbuilt with details showing its at level 1.

I thing I will just delete the old plot and add a complete new plot slightly offset to get around it for the moment.

 

GavMan

Member
City Planner (S3)
Messages
74
I did a little experiment with a really simple city plan with only 2 plots.
It looks like if you change the Building Plan of a plot it will not update to the level you had set.

I was investigating power grid issues, but threw this in to check at one city level upgrade
This is a level two basic bedroom in the Level 1 city plan
20210401233623_1.jpg

I changed the building plan in my Level 2 city build to a Corner Pallet level two. The result when testing the city plan was a level 0 plot. (yes the rec plot hides it in the back)
20210401234134_1.jpg

For my Level 3 city build it was set to Corner Pallet Level 3, and it did get to that one
20210401235601_1.jpg

Point to note: I haven't tried it with a settler assigned to it.
 

afz

Member
City Planner (S3)
Messages
39
Seems like a bug where after an upgrade, some plots will stay unbuilt. Just curious, but when you interact with the Asam, do you get a "begin construction" option for that plot at L2? I saw that happening to some of my plots during upgrades, and sure enough selecting that option allowed them to build at the correct level. Maybe there's some SS2 setting that would change this behavior.
 
Top