the Sim Settlements forums!

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Question Ongoing issues with Workshop Plus

Mr.Curious

New Member
Messages
4
I was having tremendous difficulty figuring out why so many features in this mod don't work well. I started off this post with some basic questions, but the more I used this mod, the more I felt the need to update my issues here. I will preface this post with saying that I have the following settlement mods installed:

Amazing Follower Tweaks (have used this to reset settlement build limits)
Vertical Wall Mounted Conduits
Place Everywhere
Free Cage Traps & Repairs
Private Area Markers
Auto Doors
Settlement Object Expansion Pack (all DLC)
Soylent Green
Converging Conveyors
Conveyor Belt Barriers
Better Manufacturing
Manufacturing Extended
just Some Terminals
Scrap Everything
Manufacturing Extended Expanded
YWS - Custom Posters
Workshop Framework
Workshop Plus
Posters for you 26.E
Equipment Sorter


List of Issues
ISSUE 1 - Undo not recognized.

Despite trying several different hotkeys for UNDO/REDO the mod often confuses the two, meaning when I press the undo hotkey, there is a message stating "there is nothing to redo" clearly this is a bug. After watching it appear in your videos from years ago it seems that this bug wasn't even addressed.

ISSUE 2 - Undo feature has no steps.
Undo feature seems bugged in another way. It often goes back several steps instead of just one. I assume that each step is recorded once an action is completed by either hitting the Enter key or button on controller (X button on DS4 controller). I also assume that this undo/redo works in a linear method. So an example of workflow demonstrating the issue is:

1 - select settlement object and hit enter (creates object in game)
2 - select object and rotate, then press enter (or X button). Action is complete.
3 - select object and move, then press enter (or X button). Action is complete.
4 - move object again far away then press enter (or X button). Action is complete.

Pressing the undo hotkey after step 4 will often jump the object orientation to where is was in step 2 or even step 1. Is this a bug, or am I missing something in how this undo works? It seems after using this for some time, the undo does not work in steps at all, but often reverts back to the creation of the object.

ISSUE 3 - Already existing objects subject to erasure
Another thing I am noticing right off the bat is that if I select and move a settlement object that I made prior to installing WP, and then use the UNDO function to undo the move, the object completely disappears!

ISSUE 4 - Layer Pane HUD missing
Starting over again from scratch and decided to create layer. Message says Layer is activated, but.... the layers pane is no longer visible.
EDIT1 - Reinstalled mod and layer pane was again visible
EDIT2 - Problem is recurring. Have to completely exit game each time Layer Pane is invisible.
EDIT3 - Layer pane can reappear if we use a layer handle, move the layer, and then cancel.

ISSUE 5 - Add Previous Items to layer
When accessing features in the MCM WP menu, I tried using the Tools--->Add Previous Items to layer, but it seems to randomly select settlement objects at will, sometimes many, other times just one settlement object. It would be nice to be able to select multiple objects and add them to a layer, as this feature also seems unusable.

ISSUE 6 - Can't hide layer
Toggling active layer stopped working after I cloned a bunch of items and grouped them in a layer. Quit game, loaded save, and the bug is still present. It seems the HUD cant process the info when changed. Have to cycle through all the layers to see its current state. Seems very slow and unresponsive most of the time. As mentioned above, other times the HUD layer pane is completely missing.

ISSUE 7 - random assignment of object to layers
While adding layers and hiding other layers objects jump from layer to layer. (Auto Change Layers" set to "OFF")

ISSUE 8 - Broken lights & power connections
Toggling layers with street lights will disable them from casting light. Tested with light sources and power sources on varying layers. EDIT - saving game and reloading works as workaround, but its not a very good way to work. Also, most power connections in an already built settlement will get messed up when using this mod.

ISSUE 9 - Flying stops working
For no reason at all flying stops working during workshop mode. Have to close game and restart.

ISSUE 10 - Fix Layers freezing
This feature doesn't seem to work at all. Sometimes it will go 100% and never complete, other times it will instigate, start at 0%, and never commence. In either scenario, the progress bar stays forever and there is no way to get rid of it unless you revert to an older save.

ISSUE 11 - Remove all Layers doesn't work
This feature simply doesn't do anything. All layers are still present after execution.

Diagnosis
It seems that most of these problems are cascading in nature, that is to say, once the interface gets bugged with one issue the rest will follow. It seems these issues will save themselves with a game save as well, that is to say, if there is a bug present, and we save, loading that save will keep the bug present. It appears the scripts are working really hard and often lag out. There could be a memory allocation problem in the script or something.. .I don't know I haven't looked at the code, but it seems this mod really struggles to operate in real time. If there is a pending operation that hasn't completed (something simple like a layer being hidden), and we try another operation, it often just cascades into total non-functionality. It feels as though I am using a computer from the 90's when using this mod (I have a top end system with ample system memory, RTX 2070 super, all SSD drives and a Ryzen 9 3900X 12-Core Processor @ 3.79 GHz so my machine is fine). I often give the mod plenty of time to process between each function, but even doing that doesn't resolve many of the issues stated above.

I will keep updating this post with more info as I explore the functionality and problems but with the issues stated above the mod is not fun to use. Sometimes it works as intended, most times it doesn't. It is really frustrating after losing hours and hours of work because of these issues.
 

Rellikcro

New Member
Messages
20
If you are not using the LATEST update to WS+ (released yesterday with SS2 Update and Workshop Framework) it fixes an issue of keybinds not saving in MCM, not sure if this is the only issue you are having as mine is working (I fixed the MCM issue myself and reported it to Kinggath).
 

Mr.Curious

New Member
Messages
4
Thanks to those who chimed in. Keybinds seems to be ok at this moment, but the mod is still non-functional in most aspects. I am willing to pause the use of scrap everywhere to see if this is the culprit, but I doubt it will have any effect on most of the issues I brought up. I will report back here at some point with my findings.

Cheers
 

Din'elen DarkStar

Well-Known Member
Community Rockstar
Messages
2,007
You have to ditch scrap everything AND start a new game. Sorry that's how it goes ditching scrap everything and getting best result . It's a save game killer. Ticking time bomb that once there is there and needs to be eraticated.
 

Mr.Curious

New Member
Messages
4
You have to ditch scrap everything AND start a new game. Sorry that's how it goes ditching scrap everything and getting best result . It's a save game killer. Ticking time bomb that once there is there and needs to be eraticated.
Maybe on my next playthrough but right now I have 21 days invested in a level 118 character with really elaborate factories. I might start a new game without the mod installed to test this without Scrap Everything. From what I read it was a must have for settlement builders, but from what I am reading here it is a nightmare pluggin? Can anyone elaborate on why Scrap Everything is so volatile, and how it affects this mod?

Thanks!
 

Din'elen DarkStar

Well-Known Member
Community Rockstar
Messages
2,007
Simple ANY mod that breaks precombines will destroy the game. Bethesda hid errors and what not behind those shouldn't scrap objects. So with scrap everything you let pandora open the box.
 

HyperLordBender

Member
Moderator
Messages
83
Id like to note that mods can cause issues even if they have nothing to do with the issue. This is often due to mods doing things and not telling you, or mods that have scripts.

So are you using faster workshop? That is not compatible. It causes the fly and fast movement to break alot.
Next thing would be to post your loadorder.txt as well as list any F4SE mods. This will allow us to actually see what possible mods could be interfering, or if your load order is broken.
 

Din'elen DarkStar

Well-Known Member
Community Rockstar
Messages
2,007
I am an advocate for putting Scrap Everything on the top of the DO NOT USE list. And the if you do then any bug report is invalid. Just my 2 cents. I am so burnt out on repeating this problem. About 80%+ of reports can probably be traced back to that one mod.
 

HyperLordBender

Member
Moderator
Messages
83
I am an advocate for putting Scrap Everything on the top of the DO NOT USE list. And the if you do then any bug report is invalid. Just my 2 cents. I am so burnt out on repeating this problem. About 80%+ of reports can probably be traced back to that one mod.
Yeah. Id also say any report without a loadorder.txt is invalid. However for whatever reason I cant change the prefix on any post thats already got one...
 
Last edited:

Mr.Curious

New Member
Messages
4
Again, thanks to those who chimed in. I just did some reading about 'precombines' ( I am a new player who only installed this a couple of months ago, but with modding experience from other games so I didn't know what this was). I assumed using Scrap Everything was a good way to help with FPS as there would be less polys to draw on screen, but I am reading now that this is not in fact the case. I wish I had known this prior to creating my elaborate settlements and installing Scrap Everything, as I am pretty sure I can't go back.

As for providing the said 'loadorder.txt' file, I am happy to provide that and review it with you (not sure where that file is located though). To be honest, I haven't tweaked much of the load order stuff, as I don't know how! Yes, terrible, but things have worked so far (when some of the mods I installed said 'install this or that first' I did that, but haven't gone back and rearranged any load orders as I don't know how. I am using Vortex to install and manage my mods.

Thanks again !
 
Top