Bug Nothing To Redo

Discussion in 'Workshop Plus (BUG Reporting Area)' started by McKaby, Dec 30, 2018.

  1. McKaby

    McKaby Member

    Joined:
    May 27, 2017
    Messages:
    59
    Likes Received:
    14

    As much as I want to say the title is a bit of a joke, I am getting that when I try to undo something when I delete a tree, fence, rock, house at Sanctuary.

    I only noticed this now and think it might be tied to the new Scrap Everything update that has hit as that's the only possible change that I can think of that would cause this.

    So, this isn't just a bug report, but also a notification for others that this could be happening.
     
    RayBo likes this.
  2. McKaby

    McKaby Member

    Joined:
    May 27, 2017
    Messages:
    59
    Likes Received:
    14

    Addendum: The latest version of Workshop Framework/Plus still doesn't work, I am still having this issue with Scrap Everything installed.
     
  3. McKaby

    McKaby Member

    Joined:
    May 27, 2017
    Messages:
    59
    Likes Received:
    14

    Addendum: I've been playing lately with the latest Scrap Everything and have been able to undo actions, although some end up a little ... off.

    The existing bug is picking up an item and then cancelling the pick up, the item disappears when I press undo.

    I've found this in Mechanist's Lair while trying to clear up some minor issues I think has arisen from having both SE and SS installed as I'm getting double walkways.
     
  4. Sir Gentleman

    Sir Gentleman New Member

    Joined:
    Jun 2, 2017
    Messages:
    5
    Likes Received:
    2

    Hi McKaby,
    1. The Nothing to Redo message is a bug in WS+, however nothing that impacts the functionality. The script simply references the wrong message (i.e. only the wrong text is displayed.
    2. Undo sometimes works, sometimes doesn't. I usually start a new savegame and Undo is the first thing i try. If it doesn't works i just start over until i hit a state where it works and then it works for the entire play through.
    3. That sometimes items disappear or you can undo once and not again and some other quirks are problems with your load order. Especially if you use multiple mods that edit the same area. For example if you use Clean and Simple Settlement Startup and Build High you must ensure that Build High loads after CAS and just before Scrap Everything and that Scrap Everything is the last mod in your load order. If you swap them around then weird things happen. You can undo once but not again. Best thing to see this is to check the form-ids afterwards (i.e. open the console and clicking on the offending item). You will see that the ID suddenly starts with e.g. ff. ff is usually used by the engine for dynamic objects placed by scripts when i understand it right. For these items there is however no scrap recipe so you can't scrap them. Again, juggling your load order around will fix these issues.
    4. Neither SE or SS add anything to the Mechanist Lair. So having double walkways indicates to me that you have another mod changing the Lair, for example a build area expansion by chance and possibly even yet another mod? Here again, load order will most likely solve the issue. But noted that, there are also mods out there, which are, how to put it nicely, not functioning. Trying another mod might also solve the issue. Said that, if you follow some instructions of some mods, they recommend to globally disable PreVis and Pre-Combines via certain INI Hacks. If you did that, you can get some really strange effects and bugs in your game, plus the massive performance issues in some areas for certain.
    Best if you revert the changes and swap to mods that disable PreVis and PreCombines on a per cell level, such as Build High for example. On that Note, if you scrap any precombined mesh in any area with scrap Everything, Pre-Vis and Pre-Combines will be disabled automatically by the engine for that cell. This may cause the issue that you suddenly stare into the void and the world seems to disappear before your eyes. A problem you won't be having with BuildHigh as it also changes the cells around the affected area with regards to the PreVis. Generally said the game has PreVis and PreCombines there for a reason and Bethesda did not do this system without some thought, disabling them will definitely have an impact. But if there is a right and wrong method to disable them, then using Build High is certainly better than disabling them globally. Not that the modders of the old mods were wrong, there just wasn't anything else anybody knew about how to solve the problem and the errors started way later in the game so nobody knew the why they happened.
    With regards to multiple mods chaging the same area, lets assume you have two mods. Mod 1 disables a tree and moves it way below the map so it will never pop up again. It also places a different, new tree there. Now mod2 re-enables that tree again and restores its original position and state. You will suddenly have two trees there. By loading mod2 before mod1 you however will have solved the issue.
     
    McKaby likes this.
  5. Sir Gentleman

    Sir Gentleman New Member

    Joined:
    Jun 2, 2017
    Messages:
    5
    Likes Received:
    2

    Update:
    The Nothing to Redo/Undo issue i seem to have figured out. When i start Workshop Mode for the first time, scrap something and attempt to Undo the last action, the message "Nothing to Redo" is popping up. During the same session, nothing convinces WS+ to show anything but this message. Entering and reentering Workshop mode doesn't fix the issue, even after longer waiting periods. Using Faster Workshop doesn't fix the issue either. However Saving, leaving the game, enabling a patch to enable unlimited building (Builder Patch from Build High, loaded as last ESP, as an exception even after Scrap Everything. Not required, but i leave this patch enabled even after it did it's job. You can, again as an absolute exception only, save the game after the patch is applied, exit and disable this ESP. As it is the last ESP loaded it will not cause a shift in your load order and should not leave any traces in your save other than the increased build limit, which is basically what you want) and restarting the game, does fix the issue. After this everything works reliably and every time. I tested it with 5 or 6 new Savegames. However if i strayed of this procedure the results were sometimes different and the Undo didn't work sometimes. So, if you have the same issue, try my procedure. I did not try this without enabling the Builder Patch, maybe i will test if a simple save and restart of the game does help as well later on, but for now this issue is solved for myself.and i know how to work around it.
     
    McKaby likes this.
  6. McKaby

    McKaby Member

    Joined:
    May 27, 2017
    Messages:
    59
    Likes Received:
    14

    Hi, as you can tell this is an old bug however.

    I'm at work right now so I'm unable to boot up Fallout 4 to get some more data, but to deal with your first post:

    • The "Unable to undo" is when I scrap something and press the undo button to fix the issue (mostly had this issue when doing my custom build of Sanctuary, however I've just started using RoTC build and leaving it at that)
    • The "double floors" issue in Mech Lair only appears after I've used the RoTC build there, it has the custom floors by that mod and haven't deleted the original floors, I've learnt to let the build happen and then manually delete a few select floors.
    • Scrap Everything is always the bottom of my load order, just above that is my BoS Weapon Replacer and an AIO for West-Tek Optics in a bunch of mods.
    • I don't know if a mod has buried the pre-vis option in it, but I don't turn pre-vis off, the only ones I can think of that could touch such a setting outside of SE is a mod no longer on Nexus called "Immersive Corpses" which has 2 mods, the non-pre-vis editing and the pre-vis editing, I went with the one that doesn't touch pre-vis due to the lag and CTD issues I had in Boston (finally removed Raider Overhaul WiP which was a large cause of this)
    Once I'm home I will have a mess around, though I might turn the undo option back on with this current game and have a go, though I'm also close to starting a new and clean install with a new mod to replace AWKCR/AE.
     

Share This Page