No settlers showing up

Discussion in 'Workshop Framework Bug Reports Archive' started by Jenrose, Jan 13, 2019.

  1. Jenrose

    Jenrose New Member

    Joined:
    Dec 1, 2018
    Messages:
    1
    Likes Received:
    0

    So, after bogging down in a second runthrough with sim settlements installed, I disabled it and started a new run.

    My mod list is not that huge: hud framework, workshop framework, FO4 seasons - spring, Samutz's vault wall snap lights, HZS Easy Homebuilder and working double beds, settlement menu manager, Snappy Housekit+ the dlc version, Vault plus, workshop plus, fog remover2, settlement height 9000, Clean and simple startup, and Settler sandbox overhaul (that one is pretty new because it plays better with Clean and Simple than the one I used to have)

    ANYWAY.

    The problem is that at level 12, with 3 settlements (Abernathy, Red Rocket and Sanctuary), three settlement beacons working.... no new settlers are showing up. Red Rocket is empty. I turned off autorecruit, took the beacon back into inventory, turned it back on and put out a new beacon, and still no settlers. Last playthrough, they just showed up as soon as I put a beacon down, as expected. This playthrough? Nada. I haven't yet done Corvega, but I seem to remember having several settlers at Red Rocket last time before I even bothered with Lexington.


    (BTW, sim settlements was fun, it just broke the game once I hit a certain number of fully built settlements and there was no way to build everything out fully without hitting build limits, and if you do that in too many settlements, well... so I'm doing bunkhouses and tato farms this runthrough because they won't bloat on me. Even boosting my RAM and getting an SSD didn't help.)
     
  2. Rylasasin

    Rylasasin Active Member

    Joined:
    Oct 1, 2017
    Messages:
    105
    Likes Received:
    125

    Try this test:

    Save your game, back up your save, turn off survival (if it's on), open console and type "COC QASMOKE". Then once there, type "SET TIMESCALE TO 99999". Wait for about 5 seconds, then type "SET TIMESCALE TO 20". Then tell us if any new settlers showed up.

    If they do, you're just not waiting long enough.
     
  3. Jenrose

    Jenrose New Member

    Joined:
    Dec 1, 2018
    Messages:
    1
    Likes Received:
    0

    Well, I exited, logged back in, went to Corvega and by the time I got back everything was working normally, so IDEK. I know I've hit corvega later and had settlers show up but shrug, bethesda, whatever.
     
  4. Ristow

    Ristow New Member

    Joined:
    Aug 30, 2017
    Messages:
    4
    Likes Received:
    0

    or... you can download the alien clone gun, its not a "almight solution" or a fix but it helps , you can even clone yourself
     
  5. Lone_Wolf

    Lone_Wolf New Member

    Joined:
    Dec 11, 2018
    Messages:
    25
    Likes Received:
    22

    Okay, so in the Vanilla Game when you first turn on the settlement recruitment Beacon within a few minutes you usually get 1-2 settlers IF the settlement is empty. Then after that they trickle into the settlement over time, based on a number of factors.

    So for his example Red Rocket being empty he should have had 1-2 settlers show up within a few minutes of initially turning on the beacon, (I have actually had them show up within in a few seconds). I don't think it should have taken many in game days to get an initial settler to show up at an empty "new" settlement. If your goal is to mirror vanilla game play.

    In any case I am going to start a new play through to test if this settler recruitment is working similarly to vanilla. I don't think it is but I installed Workshop Frame Work on and existing high level Character for testing so cannot say for sure.
     
    Last edited: Jan 25, 2019
  6. Lone_Wolf

    Lone_Wolf New Member

    Joined:
    Dec 11, 2018
    Messages:
    25
    Likes Received:
    22

    Okay, currently on a totally new play through, using Transfer Settlements as well. In any case the settlers are turning up at the settlement with in 1 min of turning on the beacon, for new settlements. I have been seeing 1-3 settlers each time so far. I am not using any other mods that would effect vanilla workshop behavior.
     

Share This Page