Fixed No Settlements Will Upgrade After Conqueror Install

Discussion in 'Conqueror Mod (System Bugs) (Archive)' started by MacOrion, Mar 19, 2019.

  1. MacOrion

    MacOrion New Member

    Joined:
    Mar 19, 2019
    Messages:
    0
    Likes Received:
    0

    I began a new playthrough with Conqueror and selected the option to have settlements pre-populated at Level 2, with the exception of the settlements with quests, which start at the default L0. None of the settlements will upgrade - all progress normally to 100% at either L0 or L2, but they won't actually execute the upgrade. Other symptoms:
    • Happiness is reasonable (around 80) when viewed in workshop mode, but the hud shows around ~20 happiness
    • Happiness reports read zero across the board in the pip boy / city planner's desk reports
    Things tried / other notes:
    • Attempted turning off all requirements for settler needs / etc (no-involvement setting profile) to see if happiness was affecting ability to upgrade. No change.
    • Built beds manually to cover extra settlers who might be in the settlement. No change.
    • I didn't do the Conqueror raider quest after saving Preston and company. I refused his request and killed him when he went hostile.
    • Scrap isn't an issue - I have quite a bit and they're tied together with supply lines or IDEKs logistics stations. I also turned off the requirement for upgrade scrap.
    Any help or suggestions folks have would be greatly appreciated.
     
  2. kinggath

    kinggath Well-Known Member Staff Member Administrator Moderator Verified Builder

    Joined:
    May 8, 2017
    Messages:
    3,540
    Likes Received:
    3,115

    Are you at the build limit?
     
  3. MacOrion

    MacOrion New Member

    Joined:
    Mar 19, 2019
    Messages:
    0
    Likes Received:
    0

    Thanks for the quick response.

    Initially yes, but prior to trying all the stuff above, I used the tool to increase build limit to usage + 25%, so I can still build manually in those affected settlements.
     
  4. kinggath

    kinggath Well-Known Member Staff Member Administrator Moderator Verified Builder

    Joined:
    May 8, 2017
    Messages:
    3,540
    Likes Received:
    3,115

    Are you using a City Leader? There's a known bug atm where the City won't upgrade without a leader, even if you have Leader Requirement disabled.
     
  5. Kharos

    Kharos New Member

    Joined:
    Jan 12, 2018
    Messages:
    10
    Likes Received:
    9

    Oh, so that's why my raider outposts are not upgrading - the plots upgrade but the settlement as a whole does not. Good to know, I missed that bug report here.

    Another question, I took Starlight Drive-In as my headquarters, disabled the plan, used the self-destruct tool, and then rebuilt it from scratch to my liking. The problem is that plots are not upgrading; all plots are stuck at their initial level, and some of them are very old (i.e. I built plots in other settlements after most of the plots in Starlight Drive-In, and these other plots have reached level 3 in the meantime). Are self-built raider outposts even supported?

    [Edit] Also the plots have no raider skins, but I have seen other bug reports about them disappearaing.
     
  6. kinggath

    kinggath Well-Known Member Staff Member Administrator Moderator Verified Builder

    Joined:
    May 8, 2017
    Messages:
    3,540
    Likes Received:
    3,115

    Yes, you can build your own outposts, but you need to handle their needs like normal to get upgrades. So get happiness up to 70/80, have enough defense, food/water, etc.
     

Share This Page