Kingsport Nautical Trading Post

Discussion in 'May 2019 Entries (Archive)' started by altasilvapuer, May 18, 2019.

  1. NDCowdy

    NDCowdy Well-Known Member Patreon Supporter

    Joined:
    Sep 30, 2017
    Messages:
    204
    Likes Received:
    252

    Someone official may correct me, but I don't think you've done anything wrong with the walking back as you describe it. I think most of us remove plots and population as we go in such a way that by lower levels the population and plots may not meet the end requirements (I certainly do).
     
  2. Phil_T_Casual

    Phil_T_Casual Well-Known Member Community Rockstar

    Joined:
    Dec 18, 2018
    Messages:
    527
    Likes Received:
    759

    This is correct.
    @altasilvapuer the population/plots amounts are for your finished L3.
    There are no requirements to meet these amounts at L1 or L2
     
    altasilvapuer and NDCowdy like this.
  3. altasilvapuer

    altasilvapuer Active Member

    Joined:
    Jun 24, 2018
    Messages:
    68
    Likes Received:
    107

    Praise be to Atom! This is wonderful news.

    I'll have to run the holotape again, tonight, and see if it was a glitch. My level 0 is telling me I need four more plots; I don't have my notes with me, but I believe there are 9 plots in my level 0, counting the residentials.

    -asp
     
  4. altasilvapuer

    altasilvapuer Active Member

    Joined:
    Jun 24, 2018
    Messages:
    68
    Likes Received:
    107

    Okay, two (and a half?) weird situations, everyone. Any 11th-hour help would be much appreciated.

    First, this is the first result of running the Contest Holotape in my Level 0:
    20190528224650_1.jpg

    It doesn't seem to be counting the blue man beds. (The sleeping position floor/surface). You can see one on the top bunk in this second image.
    20190528224521_1.jpg

    In addition, the game registers the settlement as having SIX 'beds' in the UI and all my settlers have a place to sleep. There's the bed on the right of this photo, the blue man you can see, a glitched/invisible blue man you can't on the cot on the left (more on that in a minute), an interior residential, and two 2x2 residential plots. This level also has a single 2x2 Martial, a 2x2 Agricultural, a 2x2 Advanced Industrial, a 2x2 Commercial, an Interior Recreational, and an Interior Commercial. There's also technically a guard post/minigun emplacement and a bar vendor blue man. Both are there more for cosmetic reasons than anything else; the bar vendor might actually get removed since I didn't use him at any level. Those are the two work items, though.

    Total: 6 job plots, 3 residential plots, 2 work items, a bed, and two* blue-man sleeping positions. The holotape doesn't seem to be counting the blue men. That, or it's a result of problem #1.5: When I was working on my Level 1, I had a blue man on that cot that I accidentally scrapped and then reflexively hit the undo button. Instead of actually bringing the blue man back, it just added a phantom bed to my settlement count and I haven't been able to figure out any way to clear it. Luckily I was assigning beds with blue men at that point on a bunch of cots, so I just left one empty to counter-act. This does mean there's a phantom blue man mucking with the numbers. Sadly, my nearest save was too far back to go back and fix it.

    So that's problem #1/1.5.

    Then, there's problem #2: The holotape finishes and tells me I need to build 5 more plots. Am I missing something in the guidelines that I'm not seeing? I know for sure Levels 3 & 2 checked out fine, and I'm 98% Level 1 did, as well, but I have to go back and check. Here are the numbers for those levels:
    Level Plot Counts.jpg
    The numbers in parentheses indicate a plot/work item that's not intended to be manned at that level. The asterisks refer to some of those bed counts including blue men on cots.

    I was going to start the recreational plot around Level 2, but the Holotape called me out for not having one at Level 1, so I had to re-plan. This makes me wonder if maybe we do have to have 11 minimum plots at all levels.

    -asp
     
    WetRats likes this.
  5. altasilvapuer

    altasilvapuer Active Member

    Joined:
    Jun 24, 2018
    Messages:
    68
    Likes Received:
    107

    Whelp, I'm hoping my previous post about plot woes in the lower levels doesn't cause any issues. Other than potentially fixing that, if there is a problem, I think I'm pretty much done, and just under the wire, by my clock. First post has been updated with my actual Final 10. I made a few changes up there that I hope sell the settlement a bit better.

    Housekeeping-wise, I think there might be a few things lurking in the middle city layers that didn't get properly scrapped in the regression, so I'll need to clean that up a bit if I make it beyond this level. Since I have to open the store at work tomorrow, though, I'm off to bed, for now.

    To the seas with ye! May the wind fill your sails.

    -asp
     
    WetRats likes this.
  6. Phil_T_Casual

    Phil_T_Casual Well-Known Member Community Rockstar

    Joined:
    Dec 18, 2018
    Messages:
    527
    Likes Received:
    759

    You are using SS 4.0.7 right?
    There was a problem with non-plot beds registering or being counted as work items.
    This is fixed in 4.0.8
     
    WetRats and NDCowdy like this.
  7. Tinuvia

    Tinuvia Wasteland Venturers Staff Member Moderator Support Team Verified Builder

    Joined:
    May 23, 2017
    Messages:
    591
    Likes Received:
    588

    The battle ship is magic! And everything else too :clap
     
    WetRats likes this.
  8. altasilvapuer

    altasilvapuer Active Member

    Joined:
    Jun 24, 2018
    Messages:
    68
    Likes Received:
    107

    Yep, I'm on 4.0.8. It's counting the actual bed, just not the blue-man animation-marker beds. Then again, I'm not entirely clear on how those work, anyway, so it could be user error.

    -asp
     
    WetRats likes this.
  9. Phil_T_Casual

    Phil_T_Casual Well-Known Member Community Rockstar

    Joined:
    Dec 18, 2018
    Messages:
    527
    Likes Received:
    759

    If you post your L3 save I'll take a look and see if they register ok
     
    WetRats likes this.
  10. altasilvapuer

    altasilvapuer Active Member

    Joined:
    Jun 24, 2018
    Messages:
    68
    Likes Received:
    107

    My Level 2 & 3 saves don't have the issue, because they're entirely using Residential Plots - no beds or blue men. I'm attaching my Level 0, which is the one giving me the "Not enough plots" warning, as well seeming to not read the blue men properly. Did I miss something?

    https://www.dropbox.com/s/hxxnvac3kzh8ber/Level 0.7z?dl=0
    I can't seem to attach *.fos files with the forum software, nor is a 7z of it small enough to upload. Here's a dropbox link; if it doesn't work, just let me know.

    -asp
    EDIT: As a sidenote, that save file has a few radio mods attached to it, because I was listening to them while I worked. I think you should be able to fire it up without, though. I also had SKE and SMM active, but otherwise it should be just HUD Framework, SS 3-in-1, Conqueror, and a bunch of add-on packs.
     
    WetRats likes this.
  11. WetRats

    WetRats Well-Known Member Patreon Supporter Community Rockstar Wiki Contributor

    Joined:
    May 30, 2017
    Messages:
    526
    Likes Received:
    918

    Look at those beautiful numbers waiting to be Wikified!
     
    MrCJohn and altasilvapuer like this.

Share This Page