Question Help! All Settler Plot Assignments Dropped

Discussion in 'SS Help (Mod Questions Here)' started by Verican, May 20, 2020 at 2:03 PM.

  1. Verican

    Verican New Member

    Joined:
    Jun 4, 2017
    Messages:
    12
    Likes Received:
    0

    All of my Settler plot assignments in Sanctuary suddenly dropped and they are not fixing themselves.

    I have 22 settlers ATM. Since this issue occurred I have mostly been unable to assign settlers to any plot, it has been successful with only a few.

    Interface is VERY sluggish. I used the call meeting tool and it took several minutes after exiting my Pipboy to call the meeting, but the screen never came back from the fade to black and I had to Alt-F4 to exit the game.

    I have tried the refresh all plots tool, as well as the refresh settlement tool and let the game sit for a while afterward but to no avail.

    SS is set to auto-assign settlers to plots.

    Is there anything else I can try or any info in the game I can share to aid in troubleshooting?

    Edit: Just attempted to change a building plan. It worked, but took about 4 minutes before the plot self destructed to change to the new plan and then the game crashed.

    Thanks for any help! Love SS, been using it since the first days!
     
    Last edited: May 20, 2020 at 2:36 PM
  2. Verican

    Verican New Member

    Joined:
    Jun 4, 2017
    Messages:
    12
    Likes Received:
    0

    So this has slowly begun to right itself but trying to assign settlers to anything is extremely difficult or impossible. Everything is set to be auto-assigned but this is not occurring for residential plots. I have more plots than settlers but they remain un-assigned and trying to manually assign them doesn't work. I created a Minuteman Settler and assigned him to an artillery piece and that worked for a short duration, but then the assignment dropped and I can no longer get him to be assigned to it.
     
  3. spacefiddle

    spacefiddle Active Member

    Joined:
    May 23, 2017
    Messages:
    241
    Likes Received:
    141

    Okay, everything you posted so far indicates you have massive script lag. There's no way call meeting should take 4 minutes, even leaving out the crash. Sluggish interface in general is also not a great sign. Something is running amok; and SimSettlements might not be the cause, but a victim.

    One good tool to use is Fallrim's ReSaver. Download this tool and use the "ReSaver" program to open up a recent save file. Take a look at "Active Scripts" and "Suspended Stacks."

    Do not edit the save file. Do not run the auto-cleaner tool, or any of its other functions. Just look at those sections.

    How many items are under "Active Scripts?"
    How many items, if any, are under the two "Suspended Stacks" headers?

    Edit: how many seconds pass before I realize I forgot the link to the damn tool?
    https://www.nexusmods.com/fallout4/mods/22633
     
    NDCowdy likes this.
  4. Verican

    Verican New Member

    Joined:
    Jun 4, 2017
    Messages:
    12
    Likes Received:
    0

    Hi Spacefiddle, thanks for taking the time to look into this for me!

    I did as instructed and found the following:
    Active Scripts: 9
    Suspended Stacks 1&2: 0

    I opened my game, made a new save, and that is the file I used for ReSaver to get the above info.
     
  5. spacefiddle

    spacefiddle Active Member

    Joined:
    May 23, 2017
    Messages:
    241
    Likes Received:
    141

    9 active and none suspended is perfectly reasonable, in general. Hmm.

    You did mention it seemed like things were calming down - possibly there was some backlog which is now clearing.

    One safe recommendation from the SS team is: leave the Commonwealth worldspace. A convenient place to go is Diamond City.

    Stand around, unpaused, game running normally allowing time to pass, for like a real-world hour.

    Then save again, and check in Fallrim again. This time expand the Running Scripts section and see what they are. Are all of them SimSet? Are there any others from other mods running?

    You may safely ignore the "birdcritterscript," lol.

    (Again, don't make any changes in Fallrim, just expand the section and look at what's there. You can expand running scripts to get details on them.)
     
    NDCowdy likes this.
  6. Verican

    Verican New Member

    Joined:
    Jun 4, 2017
    Messages:
    12
    Likes Received:
    0

    The dropping of assignments has stopped but getting any new assignments made still doesn't seem to work or is being lost in a large amount of lag. I will park myself in diamond city for an hour and then take another look. Thanks for your guidance!

    I also notice aside from this issue then when I go into workshop mode there is a large delay. I have always assumed it is due to the amount of settlement mods I run but do you know if that is something that could be remedied or even connected to the issue I am currently having?
     
  7. 1ae0bfb8

    1ae0bfb8 Well-Known Member Patreon Supporter

    Joined:
    Jun 3, 2017
    Messages:
    808
    Likes Received:
    945

    download and install faster workshop. it will change your game forever.
     
  8. Verican

    Verican New Member

    Joined:
    Jun 4, 2017
    Messages:
    12
    Likes Received:
    0

    Sapcefiddle - Sat in Diamond City and the game froze. I have noticed textures in DC have not been loading, lot of invisible stuff, since I started this game. I have a big DC expansion mod going as well. About to head out to grocery store, will attempt to let game run again.

    1ae0bfb8 - I will give it a shot, thanks!
     
  9. Verican

    Verican New Member

    Joined:
    Jun 4, 2017
    Messages:
    12
    Likes Received:
    0

    Spacefiddle - Unfortunately no luck here. I sat in the College Square subway cell for about an hour. Several plot update notifications came through, but when I returned to Sanctuary I still had 23 settlers - there are 26, and several unassigned residential plots. Trying to assign the new settlers to a residential plot doesn't work. I attempted to move them to Sanctuary but it was grayed out as an option. I tried assigning to another settlement and then back, but it never took. I am uploading an image displaying the ReSaver results from my initial check, in the College Square Cell, and then back at Sanctuary.
     

    Attached Files:

Share This Page