the Sim Settlements forums!

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Info Needed GUIDE: HELP! My Settlement Crashes on Approach/Fast Travel

Not open for further replies.

Harry Young

Bug Organizer
Staff member
Support Team
Very often we get reports on Crashes. Given how many things Sim Settlements touches, that is hardly surprising.

It also means that we have certain experiences in crashes when it comes to settlements, so here is a guide on what to do if you experience a crash:

First Steps:
  • Whenever you think you might have an SS issue make sure you have the most recent version.
  • Also if you installed using Nexus Mod Manager try uninstalling and reinstalling manually.
  • Always make a backup of your save before trying the next few steps
  • We will not debug saves with Mod/Non-Vanilla Settlements (do not uninstall them as that will break your save!)
  • When we ask you to self-destruct always use full charges. Self-destruct takes time to fully execute.
Debug Steps:
  • Does your game crash on fast travel? If so do you hear any noises?
    • Yes, and I hear noises -> Scrap Crash
    • Yes, and I hear nothing/No -> Next Step
  • Does your game crash as you approach the settlement?
    • Yes -> Next Step
    • No -> open a bug, explain what makes you think this is an SS issue.
  • Try approaching the settlement from different angles, see if that helps
    • That helped -> likely Mem overload, open a bug
    • That didn’t help -> Next Step
  • Try to get close to the settlement and call a remote Self Destruct. Did it work and can you approach (try different angles again)?
    • It worked but I still cannot approach -> Next Step
    • It didn’t work -> Scrap Crash
    • That Worked -> Likely mod conflict or mem overload, open a bug
  • If you are in an area with multiple settlements nearby (i.e. Sanctuary, Red Rocket, Abernathy Farm) try self-destructing all of those.
    • That helped -> Next Step
    • That didn’t help/No settlements nearby -> likely Scrap Crash, potentially mod conflict (Weapon or Armor)
  • Try to self-destruct only one settlement at a time if multiple are nearby and try again. Repeat for all settlements.
    • That helped/only one nearby -> Next Step
    • That didn’t help -> Mem overload
  • Try to self-destruct only the settlement that fixed it. After that open a new bug and provide the following information:
    • Inaccessible Settlement
    • nearby Settlement
    • settlement plan and level for both if applicable
    • Which settlements were destroyed to allow access?
    • Save file (*.fos; Note that link permits are only granted if you have received enough likes. If you cannot post links just upload it somewhere (i.e. Dropbox) and mention that a safe file is ready. A Support Team member will ask you via PM)
Explanations of Results:
  • Scrap Crash: This is a Bug with the vanilla game which triggers on spawning and removing generators and always crashes the game. As this is a vanilla bug, there is nothing we can do other than send information on this issue. For this, Kinggath opened a Thread here:
  • Mem Overload: This happens particularly on Console and low-end PC’s There are a few settings you can tweak depending on your device. Note that for PC’s we are looking for Testers so we can optimize our content for low-end systems. Further information on this is here:
  • Mod Conflict: Often a Mod other than SS acts up, resulting in a conflict or a misattributed bug. Particularly, weapon and armor-mods have a tendency to bug out. To test this, simply disable all your mods. and see if your issue is resolved. If it is you can zero in on the buggy mod by disabling half your mods. and repeat with that half in which the bug reoccurs. As you cannot have more than 256 mods loaded, within 8 turns (16 with a double check on the good group) you will find the faulty mod.
Further Reading:
Not open for further replies.