the Sim Settlements forums!

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Fixed CTD at Jalbert's Disposal, narrowed it down to SS 3 in 1

Viltaren

New Member
Messages
0
Hey there

I am having a CTD at Jalbert Brothers Disposal. I went through and disabled all my mods and found that the CTD only stopped when I disabled SimSettlements.ESM, which was the last mod I disabled. The run I disabled that mod for, Sim Settlements was the only mod newly disabled, as it was the last.

The file I downloaded came from Nexus Mods and is the Sim Settlements: 3 in 1 and was downloaded and installed within the past two days.

This is a fresh install of Fallout 4 on a save started with all of my current mods and with every DLC.

Approaching JBD and typing a killall to kill all the present molerats that attack does not stop the crash.

The crash seems to happen upon loading the JBD area. Being near the site also causes CTD.

Conquorer takes me right past this place so its kinda hard to just avoid. Hoping anyone can help because I've officially sunk about four hours into fixing this and I kinda just wanna play Conquorer lol
 

Viltaren

New Member
Messages
0
I have not cleared and activated Jalbert Brother's Disposal. This is my first time approaching the area.
 

VersusXV

Well-Known Member
Staff member
Moderator
Patreon Supporter
Verified Builder
Vault Librarian
Messages
786
So I tested for this specifically, after reading this post and the one about crashing at Oberland Station. I did experience the crash seemingly same as you. On Fast Travel or presumably also if I walked there.

However since I know that upon upgrading Sim Settlements that scripts will be working in the background to get things over to the latest changes I allowed for time for the background scripts to catch up some more. The save I was on was maybe 30 minutes to an hour of gameplay time after I upgraded, so I allowed like another 30 minutes of being in game then tried again. First I walked to Jalbert from Concord, no crash this time, then I loaded my save back before the walk to try fast traveling, again no crash.

This patch was a large amount of bug fixing for Conqueror so I think it may have required more time than usual.

In conclusion, I would suggest giving the game time for scripts to catch up and seeing later on if it might not crash after that.
 

1ae0bfb8

Well-Known Member
Banned
Messages
1,018
i couldn't load the game as i was saved in sanctuary. i loaded an older save at another settlement, finch farm left it for a good while - certainly over an hour real time - i walked from finch farm past county crossing, no issue - over the bridge to bunker hill - no issue, thru boston to diamond city - no issue - from diamond city to oberland - no issue - over the bridge into cambridge - no issue past corvega, drumlin diner - no issue - concorde no issue - walked to red rocket - ctd
reloaded game at drumlin diner - walked back thru concorde - this time headed towards abernathy to turn into sanctuary - got to the river ctd.
seems that whatever is in 4.0.8 doesnt like my red rocket (0 settlers 0 buildings 0 anything) or my sanctuary.
so i'm stuck with 4.0.7 until whatever the bug is that kills me in 4.0.8 is identified.
as ever, i have a save i can provide. just tell me how to provide it.
 

VersusXV

Well-Known Member
Staff member
Moderator
Patreon Supporter
Verified Builder
Vault Librarian
Messages
786
i have a save i can provide. just tell me how to provide it.
I would upload it to dropbox/mediafire or something then post link here.
 

1ae0bfb8

Well-Known Member
Banned
Messages
1,018
just to try and tie up loose ends to the posts i have made, this is what i did this morning;

hi,

so i went to sanctuary, removed the level 3 general store, created a new general store with a different model, saved and exited.
i then reloaded 4.0.8 simsettlements 3-in-1, so i am now running both simsettlements and conqueror at the same code level.
i started the game, spawned into sanctuary - everything is 100% as it should be.

truly great job zeroing in and finding what i can only assume is an extremely oboscure bug in that model, and that in turn, explains why this is difficult to replicate because it totally depended on the presence of this model being in the settlement.

i continued my verification, and travelled to drumlin diner, then walked back to abernathy, then walked to red rocket - game is 100% stable. i went from red rocket down to the museum and then to the car park at the back of concorde where you can get random encounters, walked to the quarry where you drain it and fight mirelurks - walked up to the robot junk yard and back to sanctuary - no issues at all.

seriously good job to everyone who contributed to tracking down this one.
 

VersusXV

Well-Known Member
Staff member
Moderator
Patreon Supporter
Verified Builder
Vault Librarian
Messages
786
just to try and tie up loose ends to the posts i have made, this is what i did this morning;

hi,

so i went to sanctuary, removed the level 3 general store, created a new general store with a different model, saved and exited.
i then reloaded 4.0.8 simsettlements 3-in-1, so i am now running both simsettlements and conqueror at the same code level.
i started the game, spawned into sanctuary - everything is 100% as it should be.

truly great job zeroing in and finding what i can only assume is an extremely oboscure bug in that model, and that in turn, explains why this is difficult to replicate because it totally depended on the presence of this model being in the settlement.

i continued my verification, and travelled to drumlin diner, then walked back to abernathy, then walked to red rocket - game is 100% stable. i went from red rocket down to the museum and then to the car park at the back of concorde where you can get random encounters, walked to the quarry where you drain it and fight mirelurks - walked up to the robot junk yard and back to sanctuary - no issues at all.

seriously good job to everyone who contributed to tracking down this one.
That's great news! I'd wondered about this thread if the culprit was the Caps General Interior Commercial plot
 

kinggath

Well-Known Member
Staff member
Administrator
Moderator
Verified Builder
Messages
4,076
Assuming this was circumstantial due to a nearby settlement having the corrupt building plan, which was fixed in 4.0.9.
 
Top