the Sim Settlements forums!

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Connecting Municipal Power Lots

SuperGumby

New Member
Messages
7
Specific example

RoTC, Abernathy farm - The municipal power lot (level 1) is not adding to the overall power. Yes a settler is assigned to it. Yes I got the message about requiring a municipal power switch and there is one on the lot - the lot comes with the switch. Note that I cannot find the actual switch under the 'Power' menu in Workshop mode as the message states. I am not at the stage where I can actually build municipal lots myself so I am presuming the switch is gated by that fact.

Refreshing the lot does not work. Grabbing the switch and moving does not work. I have also entered sneak and stared at the ground for an hour to let the scripts run.
Other municipal power lots do add their power such as in Sanctuary (not the RoTC build).

Latest build of SS2 and Workshop etc. New game.

I am at a loss as to why it is not working.
 

Din'elen DarkStar

Well-Known Member
City Planner (S3)
Banned
Messages
2,618
I have never see a lot come with the switch. if you are getting that message you have to actually craft a municipal power pole. Its in the SS2 Power menu. However a City plan should come with the pole already as part of the plan. Did you change anything?
 

ilmlp9147

Active Member
Messages
297
the lot comes with the switch
I believe the 'switch' graphic on the plot doesn't actually count as a switch. It's just there for looks. There are two options for SS2 power switches, a small one that looks like a breaker box, and one that looks exactly like the power pole from the plot.
 

SuperGumby

New Member
Messages
7
So I am a brain dead monkey when it comes to the switch. I was looking under the general Power menu, not the SS2 Power menu. However, still can't figure out why the power wasn't connecting - I did not change anything re power poles. I think I had something corrupt in that save, Connie Abernathy was acting strange as well. Started new game, used the Swanson build for Abernathy farm and all is good.
 

Carinth

New Member
City Planner (S3)
Messages
27
I had my power break on my one settlement I've been working on.
It was fine till I tested it with settlers then it would break.
I re-ran all my lines, replaced poles, switched to a different outdoor power plot type and nothing helped.
It was fine till I added a population then half of the grid would fail no matter what I tried.

I finally figured out a solution, did try all the ones mentioned above but none of them worked.

What I had to do was build an indoor municipal power plot and then my towers and switches all worked correctly, finally.
I figured since it had no pole and it's power is transferred directly to the grid, must be why it seems to work.
Hopefully it will help you out too.

Take care
Carinth
 

yaugieLC

Well-Known Member
Community Rockstar
Messages
3,093
It is worth noting that ALL plots in SS2 use the "radiant" power system, the power poles and lamp posts it autogenerates on 'exterior' plots are not strictly necessary and arent actually part of the plot.
 

RayBo

Well-Known Member
Moderator
Patreon Supporter
Community Rockstar
Support Team
Vault Librarian
Messages
2,448
So I am a brain dead monkey when it comes to the switch. I was looking under the general Power menu, not the SS2 Power menu. However, still can't figure out why the power wasn't connecting - I did not change anything re power poles. I think I had something corrupt in that save, Connie Abernathy was acting strange as well. Started new game, used the Swanson build for Abernathy farm and all is good.
Sounds like you pretty much have it, so IDK if this could help?

 

DocBravo

New Member
Messages
19
If you're still having problems there are a couple of wireless power mods that can be connected like normal as well. I've found similar problems that could be related or not with SS.
I'm no modder but it could be a small issue with other mods or not.
 

yaugieLC

Well-Known Member
Community Rockstar
Messages
3,093
If you're still having problems there are a couple of wireless power mods that can be connected like normal as well. I've found similar problems that could be related or not with SS.
I'm no modder but it could be a small issue with other mods or not.
Thats actually why I made the "Municipal Radiant Power" one in my 'signature'; well, that and to see if it helped with the "power grid crash" thing. (so far it seems it helps, but does not completely eliminate)
 
Top