Can't Click or Open

Discussion in 'Forum (Problems/Suggestions) (Archive)' started by RayBo, Jan 19, 2019.

Tags:
  1. RayBo

    RayBo Well-Known Member Patreon Supporter Community Rockstar Support Team Vault Librarian

    Joined:
    Jun 6, 2017
    Messages:
    1,589
    Likes Received:
    2,513

    Hey, I don't seem to be able to click or open links here?

    Is anyone having the same problem I am?

    upload_2019-1-19_9-19-26.png
     
  2. NDCowdy

    NDCowdy Well-Known Member Patreon Supporter

    Joined:
    Sep 30, 2017
    Messages:
    324
    Likes Received:
    437

    Yes, same here. Only the share links at the very bottom can be clicked for me.
     
    VersusXV and RayBo like this.
  3. RayBo

    RayBo Well-Known Member Patreon Supporter Community Rockstar Support Team Vault Librarian

    Joined:
    Jun 6, 2017
    Messages:
    1,589
    Likes Received:
    2,513

    Thank you very much for the confirmation Good-Sir.

    I will let'em know on the discord.
     
    NDCowdy and VersusXV like this.
  4. VersusXV

    VersusXV Well-Known Member Staff Member Patreon Supporter Vault Librarian Verified Builder

    Joined:
    Jun 22, 2017
    Messages:
    563
    Likes Received:
    644

    Same here but only on the frontpage of the forums
     
    RayBo likes this.
  5. RayBo

    RayBo Well-Known Member Patreon Supporter Community Rockstar Support Team Vault Librarian

    Joined:
    Jun 6, 2017
    Messages:
    1,589
    Likes Received:
    2,513

    ha, thanks VFX :clap

    It's all good. :friends

    GA_D did a lot of work here. :shedevil
    least we can do to help him out is test it an flush it out a bit :declare

    As is, he has already pointed out. :!dog: he owns my " :!dog:gone soul!" :slow
     
    VersusXV likes this.
  6. VersusXV

    VersusXV Well-Known Member Staff Member Patreon Supporter Vault Librarian Verified Builder

    Joined:
    Jun 22, 2017
    Messages:
    563
    Likes Received:
    644

    It's fantastic, I love the forums here. All we need are some more people! I did try posting link to forums/BTK when people seemed interested. Hopefully they'll show up
     
    RayBo likes this.
  7. RayBo

    RayBo Well-Known Member Patreon Supporter Community Rockstar Support Team Vault Librarian

    Joined:
    Jun 6, 2017
    Messages:
    1,589
    Likes Received:
    2,513

    If your reading this with the same problem try switch your browser. When I tested in my system with Microsoft Edge it then works fine :rofl hahaha, Microsoft working :dance2

    :acute
     
    VersusXV likes this.
  8. VersusXV

    VersusXV Well-Known Member Staff Member Patreon Supporter Vault Librarian Verified Builder

    Joined:
    Jun 22, 2017
    Messages:
    563
    Likes Received:
    644

    Firefox appears to work, seems like it's related to Chrome somehow. Disabling Adblockers didn't solve so I'd say it's not them. Issue still remained while logged out.

    I tried playing around with Block Element to see if it might be an oddball thing "covering up" the links. Sites sometimes use transparent elements to block right-click interaction or offer alternative options(One example is Youtube, where you can't use "Save Video As...") or more commonly, to cause a redirect or a pop up to appear even when not clicking an ad(essentially an invisible pop up taking up the full area).

    Though TBH I didn't expect to solve it with Block Element, since neither of those are true on here.
     
    RayBo likes this.
  9. Yagisan

    Yagisan Rebuilding the Commonwealth. Vault Librarian Verified Builder

    Joined:
    Jul 8, 2017
    Messages:
    580
    Likes Received:
    637

    Yep - in my testing it's only Chrome that is broken. Edge works as stated above.
     
    RayBo likes this.
  10. GA_Darkerside

    GA_Darkerside The Forum Maid Staff Member Administrator Moderator Support Team Vault Librarian

    Joined:
    May 28, 2018
    Messages:
    1,006
    Likes Received:
    747

    Hello all, sorry for my late reply, I been working on this for so long, I needed a break, lol.

    I run a full test on both Firefox, Edge and Internet Explorer (yep still there), but did not on Chrome as I don't use it due to many issues in the past.

    However it has been reported via Xenforo that issues keep popping up with the links that @RayBo reported and is exclusively towards Chrome. Sorry I have not looked into it as the most popular browers are Firefox and Edge.

    However please note that some forums maybe missing small items, tags, prefixes, if you find any please let me know.

    I have no fix but can say issues with Chrome/XenForo have been present, from 2016.
     
    RayBo and VersusXV like this.
  11. Yagisan

    Yagisan Rebuilding the Commonwealth. Vault Librarian Verified Builder

    Joined:
    Jul 8, 2017
    Messages:
    580
    Likes Received:
    637

    I hope they fix it soon. Microsoft appears to be retiring Edge for a Chrome based browser. While I don't think it's a great idea (competition is good in this case), having two major browsers unable to access the forums correctly looks bad for SimSettlements.
     
    RayBo and VersusXV like this.
  12. GA_Darkerside

    GA_Darkerside The Forum Maid Staff Member Administrator Moderator Support Team Vault Librarian

    Joined:
    May 28, 2018
    Messages:
    1,006
    Likes Received:
    747

    Well i agree but more for Xenforo who provide the forum software and if it came to it, I guess we would have to change the providor.

    Or we get everyone to move to Firefox :)
     
    RayBo and VersusXV like this.
  13. 1ae0bfb8

    1ae0bfb8 Well-Known Member

    Joined:
    Jun 3, 2017
    Messages:
    433
    Likes Received:
    443

    RayBo and VersusXV like this.
  14. GA_Darkerside

    GA_Darkerside The Forum Maid Staff Member Administrator Moderator Support Team Vault Librarian

    Joined:
    May 28, 2018
    Messages:
    1,006
    Likes Received:
    747

    Thank you for the info, I will raise this and see where we can go, like I siad, if Chrome dont sort this issue out, then either we will have to look at it or take other measures.
     
    RayBo likes this.
  15. 1ae0bfb8

    1ae0bfb8 Well-Known Member

    Joined:
    Jun 3, 2017
    Messages:
    433
    Likes Received:
    443

    i noticed that the unanswered posts module does allow links to be clicked in chrome, while the new posts etc., modules do not.

    For example, this works in Chrome (unanswered posts widget)
    <div class="section widget-single">
    <div class="secondaryContent widget sidebar-widget XFResource_UnansweredThreadsWidget_UnansweredThreads" id="widget-12">
    <h3>Unanswered</h3>
    <div class="WidgetFramework_WidgetRenderer_Threads_ListCompact">
    <ol>
    <li class="thread-8395 thread-node-181">
    <div class="title">
    <span class="prefix prefixOrange">Question</span> <a href="index.php?threads/do-citizens-conflict-with-icebreaker-settlements-realistic-conversations.8395/"
    title=""
    class="PreviewTooltip"
    data-previewUrl="index.php?threads/do-citizens-conflict-with-icebreaker-settlements-realistic-conversations.8395/preview">Do Citizens conflict with Icebreaker Settlements &amp; Realistic Conversations?</a>
    </div>
    This doesn't work in Chrome (New posts widget).
    <div class="section widget-single">
    <div class="secondaryContent widget sidebar-widget WidgetFramework_WidgetRenderer_Threads" id="widget-4">
    <h3><a href="index.php?find-new/posts">New Posts</a></h3>
    <!-- 8da48cd86e7901f4bc7139e7e2571f2a --><div class="WidgetFramework_WidgetRenderer_Threads_Sidebar avatarList">
    <ul>
    <li class="thread-8443 thread-node-180">
    <a href="index.php?members/wetrats.220/" class="avatar Av220s" data-avatarhtml="true"><img src="data/avatars/s/0/220.jpg?1518218618" width="48" height="48" alt="WetRats" /></a>
    <a href="index.php?threads/bunker-hill-as-it-should-have-been.8443/unread">
    Bunker Hill As It Should Have Been!
    </a>
    I wonder if there is something not quite correct in the links that end with /preview which is what we see in the new posts module, but is set correctly in the posts ending with /unread, which is what we see in the unread module?
     
    RayBo likes this.
  16. GA_Darkerside

    GA_Darkerside The Forum Maid Staff Member Administrator Moderator Support Team Vault Librarian

    Joined:
    May 28, 2018
    Messages:
    1,006
    Likes Received:
    747

    It maybe, but presently I cannot look into this and Kinggath is taking a rest. Hopefully we will sort it, but this is not something I have touched.
     
    RayBo likes this.
  17. ArtisanVirgil

    ArtisanVirgil Member Patreon Supporter

    Joined:
    Dec 16, 2018
    Messages:
    26
    Likes Received:
    47

    I'm sure this isn't helpful, as yall will have a much deeper technical understanding, and front end is not my forte at all, but thought it couldn't hurt to mention something.

    Using chrome, if I use something to block the mainContainer, I can click on those side links. That the mainContainer is covering the side bar.
     
    RayBo and Yagisan like this.
  18. Yagisan

    Yagisan Rebuilding the Commonwealth. Vault Librarian Verified Builder

    Joined:
    Jul 8, 2017
    Messages:
    580
    Likes Received:
    637

    Actually - very helpful.
    Removing width=100% from the .mainContainer class makes them clickable again.
    A more elegant solution would probably use z-index.
    Say 1 for .mainContainer, and 2 for .sidebar. Would be worth testing it out.
     
    RayBo likes this.
  19. GA_Darkerside

    GA_Darkerside The Forum Maid Staff Member Administrator Moderator Support Team Vault Librarian

    Joined:
    May 28, 2018
    Messages:
    1,006
    Likes Received:
    747

    @Yagisan have you edited this in the Style Properties?

    I do not have Chrome, so i have been unable to test this
     
    RayBo likes this.
  20. Yagisan

    Yagisan Rebuilding the Commonwealth. Vault Librarian Verified Builder

    Joined:
    Jul 8, 2017
    Messages:
    580
    Likes Received:
    637

    I did when testing - but it seems to be working for me today. Sidebar working for any other Chrome users?
     
    RayBo likes this.

Share This Page