the Sim Settlements forums!

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Broken Power Grid Investigation - Just me or city plan mechanic bug?

GavMan

Member
City Planner (S3)
Messages
74
I wanted to see if anyone else has found or identified issues with broken power grids in city plans.
Possibly related to removing plots in city plans.
Applicable to errors that seem to only occur as city plan upgrades through levels.
(ie: that you don't get if you use layouts)

To check your power grids use R2K's Gameplay mod - 0005. Power Grid Tools 1.4
  • once Power Grid Tools 1.4 is enabled, type in the console "cpg" to check the power grid
  • cpg reports errors but doesn't identify the actual issue
  • cpg reports how many power grids there are and the total number of "nodes" (power related objects)
  • cpg 1 will fix the error - but I find usually at the expense of breaking every power line wire in the settlement (might be on the particular power gird, but I have only 1 in my settlement).
  • pg (showpowergrid) followed by a number will list all the items on that particular power grid
  • If you find an error after cpg, run pg {number} to see a list of the nodes in that particular power grid.
  • Scroll back up the list, the error/s are shown as [INVALID NODE] ff001010 - (the last part is ID of the broken node)
  • If in a city plan test record the ID, then load a save for the lower city plan level
  • (you can check again for errors)
  • you need to find what that error ID is on this lower level
  • pg {#} will give the name of the item - if you only have a few it might be easy to recognise - go and select and find the match
  • I use PRID {ID} and look at the information I get from Kassent's Better Console - F4SE
  • Or, toggle collisions tcl, then use player.moveto {ID} screen will go blank to load location and you appear beside the object. tcl is so you won't fall back to the ground once you are placed there.
  • In console click the items to find the problem object.
  • Now you know - you will need to go back to your city plan level build and sort the object out.
  • Some ways to fix, try repositioning, scrapping/removing, alternative objects....
  • Then export, re- package, re-test, re-check

Background for me
As I work through a few changes to further improve my Croup Build, I was getting a broken power grid.
I am not getting a broken power grid when I import a layout of the city level - indicating it is possibly related to how the city plan is implemented.
Looking at the ID of the Invalid node (using R2K's Gameplay mod ) and comparing it to the previous level it pointed to an interior Martial plot.
This particular martial plot is removed as the city transitions from level 1 to level 2.
I then went to my Level 1 city plan save, (not my build - but an in game city plan), I then scrapped the martial plot just before I upgraded to level 2.
When it was done, I ran the power grid check, and it reported the power grid had no errors - Yay!

It doesn't happen in every situation though, I have other plots that are removed, and don't get power grid errors.
In level 2 the martial plot space has a new residential plot put into it. It is different by 180 degrees in rotation and offset slightly, (by about 10 steps).

In earlier builds I had identified errors with non-plot objects.
These were lights that I had used Place Everywhere's nudge feature to move about.
Running cpg in the city plan level build didn't pick up any errors, it was only when I was testing the city plan that the errors occurred.
After finding the ID and I went back to the build save and got rid of the objects, then upon city plan testing I no longer got those related errors.

Yes - it can be a long process - to check my city plan (getting full plot updates to check all aspects) it takes around an hour and a half to upgrade foundation through to level 3.
 

GavMan

Member
City Planner (S3)
Messages
74
From my next cycle of testing:
I had removed the residential plot in similar location to the martial plot. Still the same result, a power grid error from Level 1 to Level 2 where the internal martial plot was removed.
I also have another error linked back to an internal Municipal plot that was removed in Level 2, with a Power Grid error in level 3
An external industrial plot that is removed in level 1 seems to be fine.

If I remove the internal plot before upgrading I didn't get the power grid error.
A hint that it may only happen with removing internal plots?
 

GavMan

Member
City Planner (S3)
Messages
74
I created a simple Two plot city plan to test the power grid issue.
(I was getting tired of the hour and a half to get there with testing my full Croup Build)

Something funky is going on behind the scenes in the city plan upgrade if you play around with plot positions or get rid of (internal) plots

From my test of the simple city plan
Sm Power Pylon​
FF0016F7​
Generator​
FF0015DE​
Desk​
Generator 2​
FF001FBB​
Generator 2 was added by me after the level 2 build to see if I could get power to the unpowered Recreational plot

Level​
Left Plot​
Left Plot ID​
Right Plot​
Right Plot ID​
Others​
L0​
L1 – Gravel Processing​
FF0016A3​
L1 – Basic
Bedroom​
FF001697​
L1​
FF0016A3​
L2 – Basic
Bedroom​
FF001697​
L2​
L2 – Rec
Room​
FF001E3F​
L2 – Corner
Pallet​
FF001697​
FF0016A3
(deleted industrial from L0)​
L3​
L3 – Caps
General​
FF00200A​
L3 – Corner
Pallet​
FF001697​
FF0016A3
(deleted industrial from L0)​

  • I completely removed and did not replace the left plot in level 1
  • The Rec Room did not show on the power grid - 1st I tried adding a second generator and wired it to the original - no change, then I picked up the pylon and TAB dropped it and it came online.
  • Caps General did not show in the power grid - this time I stored and replaced the wire between the original generator and the pylon and it came online.
  • At level 3 running cpg resulted in an error - the invalid node was the Rec room's FF001E3F
  • Using cpg 1 to fix the errors removed both the Rec Room and the deleted industrial plots references from the power grid.
  • After using cpg 1 the Power grid had 0 nodes showing - nothing powered - until I rewired the generator to the pylon

20210401232802_1.jpg

20210401233315_1.jpg
20210401233623_1.jpg
20210401234134_1.jpg
20210401234616_1.jpg
20210401235308_1.jpg
20210401235601_1.jpg
20210401235712_1.jpg
 

afz

Member
City Planner (S3)
Messages
39
I've noticed power grid issues when testing city plan upgrades for my March contest entry. Some of the issues stem from objects clipping through a wire, or wires being too long. Before building for SS2 I was used to resorting to trickery when wiring, to get around the usual distance and position limitations. These days, if a wire won't cleanly plug from A to B without fiddling with it, I just reposition everything until it does.

That said, I still get grid errors during upgrades, which I suppose are related to the interior plots. I had not used Kassent's Better Console - F4SE yet, so thanks for the suggestion :buba
 

GavMan

Member
City Planner (S3)
Messages
74
I'm in the process of changing the Croup build so as to keep plots and hopefully stop the power grid errors.
It's not my ideal "vision" for the settlement growing, but at least it will work for the majority of players without the need for the extra work to fix it.
(Maybe one day soon I might finish and then get to start on the April build).
 

GavMan

Member
City Planner (S3)
Messages
74
OK, finding new ways of how to break your power grid.

Refreshing plots - I have experienced this on Wasteland Manor (it was level 3 and looking at the IDs linked back to the three lights upstairs).
The Second plot was Level 2 laser cannon, the external light on the left side.
I think it may need to move away and come back before it manifests the error - it it may just be time.

Self inflicted really, I think its related to doing a second refresh on a plot that's already refreshing - yeah I shouldn't be doing that, but frustration levels rise and the plot must be punished!

My Wasteland Manor is randomly putting an invisible barrier out the front of itself at plot level, would be fine if the ground was flat out front, however mine has a step up to it. Refreshing makes it go away, (or come back in a slightly different location - so refresh again).

The Laser cannon had a red HOLO code number on the 4th line, I don't know what it is so thought refresh (maybe twice).


Anyone know of a list/guide somewhere of what the HOLO numbers mean?
 
Top