the Sim Settlements forums!

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

Question WSFW HUD issue hiding Holotime widget


New Member
I'm not going to pretend I begin to understand how the HUD layers and prioritisation work in F04 \ DEF_UI \ HudFrameWork \ VIS-G \ WSFW but I am having issues and I'm hoping someone can help or at least commiserate.

I've been using DEF_UI with a custom layout of my own for a long time, with HUDFramework and VIS-G Item Sorting (which I mention as it include a compatibility version for DEF_UI and HUDFr). I also use Holotime to display the time to the left of the radar which I keep at the bottom of the screen next to the compass.

I've just noticed that since installing WSFW, when I open the workshop and close it again HoloTime disappears - well, not quite - it's still there, but for some reason I can only see part of it if I move so that a compass icon is overlapping with where Holotime is.

I've done some testing and if I move the Holotime widget up the screen it seems to be fine - there just seems to be a bar across the bottom where it's being superceded - I'm not sure if that's an area WSFW is setup to use for something (I've not played with any of the advanced features that much yet).

Holotime also seesm to reappear if I draw a weapon, but then dissapears again if my crosshair is over a container or an NPC - of course these are also actions that change the HUD display.

Whenever I load a save the clock is there, but it reliably has the issue when I go into and out of workshop mode.

The issue did not occur before I installed WSFW, and if I remove it and go back to an earlier save the issue is no longer happening.

I'm guessing the issue is something to do with WSFW's version of HUDFramework implementing a HUD element which is setting a priority below the base UI (hence the compass and ammo counts etc showing) but above Holotime and blocking it from rendering, but I am just clutching at straws there.

I did have HUDFramework below WorkshopFramework in my load order and I tried moving it above, but that didn't help.

Is there anything you can suggest, or is there any more information I can provide? I've attached screenshots showing where I have Holotime and one showing where it is partially showing due to the overlapping compass icon, happy to provide anything else that might help.


  • ScreenShot805.png
    2.8 MB · Views: 24
  • ScreenShot806.png
    2.8 MB · Views: 24
I just installed 2.0.15a and I have a simular issue. Entering WSM all widget, including SS2 dissapear and do not re-appear EVER. Holotime mod is still running but the widget is gone and I cannot get it back unless i reload the save file. Also SS2 overlay is gone and will not come back until I reload. I ran a 'naked' version with only these mods:
Hudframework 1.0f
Holotime 1.1b
MCM 1.39

The problem persists. Plugin loadorder: Hudframework, Holotime, WSFW.
Ill try changing load orders but I doubt it will help.

Reverting to an older version of WSFW where this issue didnt occure hasnt helped. So it seems something has broken in my game (see next post for what 'broke'). Turning off SWFW though seems to remove the issue though.
Last edited:

I don't know if this is the same issue as the original post but I have found a bug with WSFW. The issue I discribed above (widgets not comming back online after exiting WSM) is the result of something in WSFW AND Turning of you crosshairs in the (vanilla) settings menu of the game. I turned them off for my next playthrough for a more immersive experience.... guess ill have to leave them on till this is fixed.
IIRC, the crosshairs are required by HUD Framework. Turning them off breaks HUD Framework. As far as I know, there is no way around this as the crosshairs are used in the "hack" to add the HUD elements.
IIRC, the crosshairs are required by HUD Framework. Turning them off breaks HUD Framework. As far as I know, there is no way around this as the crosshairs are used in the "hack" to add the HUD elements.
And yet HUDFramework plus Holotime work fine without crosshairs! Adding WSFW to the mix causes issues.
Its WSFW that needs the crosshairs not HUDFramework. Also note that the widget work fine BEFORE entering worshop mode on ever save game load. Leaving workshop mode requires the crosshairs to bring back any widget. Which, again, return just fine using HUDFramework and no crosshairs.
Only with WSFW and no crosshairs do widgets not return.
I know this thread is pretty old, but the way SS2/WSFW etc. work in conjunction with Holo Time is, the clock widget becomes attached to the compass and for some reason, when those are turned off WS mode, something borks and the clock goes poof. It's maddening. I just switched to Vault Time, which, as old as it is, actually works with all the mods. I just wish it looked like Holo Time.