the Sim Settlements forums!

Register a free account today to become a member! Once signed in, you'll be able to participate on this site by adding your own topics and posts, as well as connect with other members through your own private inbox!

SS2 Playthrough Test(2022-09-15)...

Mystical Panda

Active Member
Messages
224
This is my current playthrough testing for SS2. It is a fairly modded game, so I'll try to keep that in mind while posting potential issues as they develop. Generally I don't really have problems with the mods I use though some are listed on 'can cause crashes' Buffout 4 list, though there is the occasional plugin record conflict(which I'll tackle as time permits). Later, I'll come back this the initial post here and put more information on the mods I'm using and why.

For openers, I'm attaching the current load order along with most mods I'm currently using(since the Mod Manager I'm working on is under development and some of the folders and files listed in the [Available] and [Downloads] sections won't be 100% complete or in the correct order- but close. And some, even though flagged as 'active' aren't really 'installed'- so please take that part with a 'grain of salt' until I have more time to address it. So, the install order is basically what I added as I directly modded the game.

The second is a list of F4SE plugins that's currently being used. If you notice two of the Baka plugins are ".disabled", so they're not loaded by F4SE. This was mostly due to the fact I use Buffout 4's calls to the OS for dynamic memory allocation rather than Baka's fixed amount.

With this playthrough I decided to just add settlers to a single settlement and no more(at least not for awhile) in an attempt to see how, and/or when, settlement resource values would become an issue. Though, I've acquired around 8-10 or so, there's only one that's populated with settlers.
 

Attachments

  • loadorder.txt
    68.8 KB · Views: 7
  • pluginlist.html.txt
    4.2 KB · Views: 3
Last edited:

Mystical Panda

Active Member
Messages
224
Let's talk pre-SS2 quests for a moment(but to give everyone a heads up- so far, even though the game is fairly modded, SS2 is going strong). The one thing I noticed, which has something to do with a mod is the floor mounted 5.56 turrets will animate like they're firing, but no projectiles are coming out, so they don't really do any damage. I believe those turrets are set as NPC's so it more than likely has something to do with that... just not sure what to check on just yet.

Now let's talk about just BEFORE this test so you can see where the modded game(this playthrough test) is coming from.

Before this test, I was getting quite a few crashes, from what seemed like a 'loose file stream' as picked up by Buffout 4, which according to what I've read means a mesh crash of some kind. So, the first attached file will be of those tests. You'll see where, towards the end of that test crashes were increasing in frequency and got completely out of hand. At this point, I had no idea what the problem could be. Notice though towards the end of the buffout crash list there's a completely different crash- seems to be gpu driver related? That one came after a windows update, and required a driver update for my gpu(which after installing it, problem seemed to go away). I'll show you again here shortly the only crash I've had so far with the current playthrough(test)- which disappeared AFTER I updated the gpu's driver.

One thing I noticed, hud wise, was terrible lag when using any hud menu. It didn't happen everytime, and the only way to fix it was the good ol' 'save and reload' cycle. After checking the install files for the hud I found some were from the previous version of the ultrawide mod(just a few), so I re-installed it, then re-installed FallUI on top of that. I marked the items in the attached image for the only .swf file that's not from the ultrawide mod. Without that, FallUI wouldn't work properly. That was one change.

Another change was to remove from the load order a few mods, one of which was the merged patch from xEdit until I can directly build it myself. With WryeBash if you have, let's say 300 plugins(some 'light' of course) it'll just put as masters in the merged patch those plugins which it used. This was unlike xEdit for me, which tried to put all 300 as masters BEFORE it built the plugin- which of didn't work since you can only have 255. An automatic merge patch isn't supported, so it came out.

The next thing I removed was the crafting highlight fix. This one is probably ok, but I took it out since I noticed lag while building settlements(objects being highlighted) and wanted to remove a potential possibility. It's been uninstalled, though I might put it back in later to see if the same problem crops up.

Other than those changes that's pretty much it. There were a few new mods added, but nothing major and no problems from them that I've noticed so far.
 

Attachments

  • sessionlog.html.txt
    14.6 KB · Views: 1
  • buffouthistory.html.txt
    32.7 KB · Views: 0
  • menufiles.jpg
    menufiles.jpg
    629.1 KB · Views: 3
Last edited:

Mystical Panda

Active Member
Messages
224
Here's is the session log and ONLY crash from this current playthrough. If you noticed that the crashes at the end of the log from the previous post are similar to this one, and it's driver related- I marked the items. AFTER updating to the newest driver there were no crashes like this PAST that point as you can see. In the session log you can easily see the accumulative time before a crash is over a day and growing. You can also see the game play(or session time) for each gaming session. Now on to the good stuff!

With SS2, everything is going really well, with only a few minor hiccups. Here's what I've found so far:

1) When building the initial plots I just keep assigning the same settlers over and over to different plot types until the "Laying the Foundations" could complete. This isn't really a hiccup, but for some reason I was expecting settlers to show up and fill each plot type role automatically. A tad bit confused when it happened... but dropped some logic on the table for what the quest was asking for and the quest continued. More than likely the required settlers would've shown up in time... not sure.

2) The quest "Well, Well, Well" is still white(at least with my color scheme- showing it's active) although it's in the completed section of the quest log, and long COMPLETED. This could be a mod or engine issue, but so far it's the only one showing up like that and could also be how I did the quest(order of completion, things like that).

3) When tuning the radio, XDI kicked me out of the menu, but not the chair when attackers came in while using it. Which, exiting a conversation menu is normal behavior for the engine. The problem happened, after the attackers were dead and I sat back in the chair, I couldn't engage the radio again. I'm wondering if this has something to do with the animations(micro cut scenes) and how they're integrated into the scripting. What I had to do here was reload a previous save, deal with the attackers, then complete the radio tuning phase. One suggestion is, and I'm assuming here, tuning is random- have it so after 5-8 tries(max, if randomly it doesn't get a 'hit') it gets tuned.

4) The next(current) problem again has to do with animations(cut scenes). When I help Jake check on the 3 locations near Olivia for his 'contact', I believe BNS(Boston Natural Surroundings) might be the culprit(either that or extending the borders? I've seen where that can be a problem in other posts)... as all I saw were trees and I couldn't move or interact with any npcs. Jake responded about the settlement being razed, then another npc walked up. For this, I'll need to use the 'cheat' to complete that portion of the quest(at least for now) as I'm not sure of a workaround, and don't want to remove any mods to keep the game saves stable(at least as much as they can be).

So with cut scenes, it looks like scripting is calling a function to 'wait for something' which doesn't happen, so the script can't continue normally if there's a problem, or something breaks the animation, but doesn't really 'kick it out' of it's current state.

Another quick note, I do see bed problems crop up when there's a change or settlers are sent to Sanctuary(only settlement that's active with settlers), but nothing way out of range. So that might be normal, and in some instances it is- as I had to actually go back and build more beds. Plots seem to auto-update ok, and settlement involvement is set to 'none'.

Other than that, great job so far on SS2 team!
 

Attachments

  • sessionlog.html.txt
    2 KB · Views: 0
  • buffout4.jpg
    buffout4.jpg
    444.1 KB · Views: 3
Last edited:

Mystical Panda

Active Member
Messages
224
Note to self... NEVER go inside New Fallion's again. An SM in a nightie? ... pictures? ... :shok1:shok1:shok1 ... onwards...

I've just come across two things quest related:

1) When going back down to the Plutonium well to re-activate(fix) the generator while Jake is starting to tell you about his history, I noticed that opening the Maintenance door doesn't have any sound.

2) When hitting up the robot to fix the generator he will, but it didn't trigger until you were near him and the generator. Not sure if that's intended but expected if I sent him to do it, I wouldn't have to supervise.

3) After coming back to Jake and helping his robot defend itself against a half dozen or so cockroaches and one rad spider- the rad spider kept respawning after death and there was no taking this thing down. As Jake would say... "That thing has more lives than a Siamese cat!". In this instance, once I used the holo-tape to complete that part of the main quest, the spider simply vanished.
 

Mystical Panda

Active Member
Messages
224
Level 22, and still following the SS2 quest line. Here's another instance I noticed, remember to keep in mind this could be SS2 or mod related(I'm keeping an open mind)...

1) Concord is actively being populated by npcs and they seem to be giving quests, including taking residence in the abandoned Concord church. One npc asked me to find his two comrades. One was tossed over a cliff and the other was in a cage. Strangely, the cage door was already open when I arrived. I could continue the quest by manually closing then re-opening the cage door(re-locking, then un-locking didn't come into play).

Another settlement comes into play...

At this point, Jake asked me to find a group of npcs which wanted their own place to settle(the ghoul, a 'half wit', Paul was there, and Lashes). I didn't have the option to build it myself, or send them temporarily to another settlement so I gave them Output Zimonja(so I now have at least two settlements active with settlers).

This, I'm sure is normal, but I had to visit them before they'd start building their settlement using their chosen plan, as this appears to be a tutorial quest about the possibility of using City Plans. Interestingly, after they had everything built, food, water, and related stats were 0. Yet, after a time of running around, exploring and doing quests, then rechecking the workshops in the pipboy, it seemed to balance out, and no problems with Sanctuary being reported. At this point, I haven't directly sent anyone else there except the original group of npcs which might cause a problem. Shouldn't, but I'll test that in a bit to see if SS2 rebalances the load based on number of settlers. If it's tied to a city plan, then it might cause a problem if more is there than the city stage expects.

So far so good...

I didn't notice anything else strange or out of place quest wise. So we're good there. Though one quick note... it doesn't appear that auto renaming of settlers is working. Not sure exactly why as of yet, but it's on the list to figure out(not SS2 related).
 

msalaba

Well-Known Member
Staff member
Community Rockstar
HQ Support
Messages
3,915
The one thing I noticed, which has something to do with a mod is the floor mounted 5.56 turrets will animate like they're firing, but no projectiles are coming out, so they don't really do any damage. I believe those turrets are set as NPC's so it more than likely has something to do with that... just not sure what to check on just yet.
When I was learning how to make custom turrets I had this problem. The issue was the Projectile used by the Weapon didn't have a nif file defined. Without that, the game had no way of knowing when the projectile hit something.
That one came after a windows update, and required a driver update for my gpu(which after installing it, problem seemed to go away).
Once upon a time Windows Update decided to update my nVidea driver even though I had driver updates turned off in the settings. I would CTD any time Concord tried to load plus many weird random CTDs. Once I was done cursing Windows, I downloaded and installed the latest official driver and problem solved.
3) When tuning the radio, XDI kicked me out of the menu, but not the chair when attackers came in while using it. Which, exiting a conversation menu is normal behavior for the engine. The problem happened, after the attackers were dead and I sat back in the chair, I couldn't engage the radio again. I'm wondering if this has something to do with the animations(micro cut scenes) and how they're integrated into the scripting. What I had to do here was reload a previous save, deal with the attackers, then complete the radio tuning phase.
tl;dr - this is a known SS2 issue.
XDI has nothing to do with it, its vanilla behavior. Since v1.0.0, if you exit the radio before completing the scene, when you re-enter, nothing happens. I have looked at that a few times but I do not know enough about the systems involved to figure out the issue. Some have said if you enter and exit the museum the radio will work again. That has never worked for me nor re-loading the game.

A lot of the issues you have listed are highly likely to be mod conflicts. Any mod that touches the workshop system has a good chance to cause issues with WSFW and by extension, SS2. A few might be related to the animation mods you are using. Many quest scripts register for animation events. If a mod changes the name sent, the script will remain idling and the quest will appear unresponsive. As I don't know the first thing about the mechanics of animations, there's a good chance I'm wrong.
 
Last edited:

msalaba

Well-Known Member
Staff member
Community Rockstar
HQ Support
Messages
3,915
it doesn't appear that auto renaming of settlers is working. Not sure exactly why as of yet, but it's on the list to figure out(not SS2 related).
I can help with this one, seeing as that's my mod. ;)

First Question:
Is the settler not being renamed named "Settler?"

If you have mods that change default actor names, you will need to configure Rename Anything Enhanced. You simply add mod added names to the whitelist so they will be allowed to be renamed. Any actor whose name is not on the whitelist will be ignored.

Here is an article I wrote explaining how to do this:
 

cbrgamer2

Well-Known Member
Messages
452
After coming back to Jake and helping his robot defend itself against a half dozen or so cockroaches and one rad spider- the rad spider kept respawning after death and there was no taking this thing down. As Jake would say... "That thing has more lives than a Siamese cat!". In this instance, once I used the holo-tape to complete that part of the main quest, the spider simply vanished.
I had this too. From memory rad spiders an inclusion with Unique NPCs - creatures and monsters.
I had to reload until only roaches appeared. I don't know if this is something that will be addressed in SS2, as it only appears when another mod alters the list of creatures that could spawn there.
 

Mystical Panda

Active Member
Messages
224
I had this too. From memory rad spiders an inclusion with Unique NPCs - creatures and monsters.
I had to reload until only roaches appeared. I don't know if this is something that will be addressed in SS2, as it only appears when another mod alters the list of creatures that could spawn there.
I don't really know enough about scripts and the available functions, but the best way(at least to me) would be to check if the robot is 'in combat', rather than by a specific creature or ref id as it was just weird all the rad roaches I could kill, but the spider would die, then re-appear back right next to the robot. It's like the script was saying... is the robot in combat, no? spawn creature(was always the same)... and if it's killed, don't know what it was(if it's hardcoded, or a ref of a ref problem) but robot isn't in combat so quest can't continue... spawn creature...(repeats). At least that the best I can figure.

I've got quite a list of things to do here, but one task on my 'to do' list is a help framework so things like this can be more easily troubleshot. Do you know right off which script controls this quest? It might be something that readily stands out.
 

Mystical Panda

Active Member
Messages
224
I can help with this one, seeing as that's my mod. ;)

First Question:
Is the settler not being renamed named "Settler?"

If you have mods that change default actor names, you will need to configure Rename Anything Enhanced. You simply add mod added names to the whitelist so they will be allowed to be renamed. Any actor whose name is not on the whitelist will be ignored.

Here is an article I wrote explaining how to do this:
I have both "Rename Anything" and "Rename Enhanced" and from literally all previous playthrough tests it worked just fine, just for some reason, this time it's not; the settlers and raiders still have their original name(there shouldn't be any mod that touches that), and there's nothing else I have that renames them. I noticed that right when settlers started coming to Sanctuary. One thing I did was update SUP to the latest version- since these are dlls I try and keep them up to date even during an ongoing game. I checked the MCM options and both are set to "ON". I just did a quick run to other cells with raiders and their names remain unchanged. I'm guessing it checks all names in a given cell(on load?) and if it's in the text for the npcs name is in the white list it renames it and would work even if the npc is dead. Does that sound correct?

Here's an image of what I have directly installed into the game, with the only difference being the 'ExamineMenu' installed by FallUI(the marked items). At least from what I can tell. I also ran a quick 'conflict search' and only came up with scripts that seemed to be specific to the mod itself.

I'm going to update "Rename Anything Enhanced" to 1.06 now and use the holo-tape in Sanctuary and see if that works.
 

Attachments

  • renameanything.jpg
    renameanything.jpg
    490.6 KB · Views: 4

Mystical Panda

Active Member
Messages
224
@msalaba With Rename Anything, here' s what I've tried...

The holo-tape and MCM option to rename things around me(in the cell) which neither worked. I have updated SUP F4SE and Rename Anything(should be latest versions), which could be when the problem started as it worked perfectly a few playthrough tests back. With these options is there a message that pops up showing when it's complete? or an ongoing status message about how far along it is in the renaming process?

It's there an console command like "getav" to show how many white list items are actually loaded? or a debug option I can set which will dump in the papyrus the steps the script is taking or if a rename fails, why?
 

msalaba

Well-Known Member
Staff member
Community Rockstar
HQ Support
Messages
3,915
I don't really know enough about scripts and the available functions, but the best way(at least to me) would be to check if the robot is 'in combat', rather than by a specific creature or ref id as it was just weird all the rad roaches I could kill, but the spider would die, then re-appear back right next to the robot. It's like the script was saying... is the robot in combat, no? spawn creature(was always the same)... and if it's killed, don't know what it was(if it's hardcoded, or a ref of a ref problem) but robot isn't in combat so quest can't continue... spawn creature...(repeats). At least that the best I can figure.
This isn't a script issue. A mod edited the leveled actor list adding this spider to it. If this added spider is flagged 'essential' you won't be able to kill it in game.
The SS2 quest script is listening for an actor is dead event > increment counter. When counter = target value > advance quest.
 

msalaba

Well-Known Member
Staff member
Community Rockstar
HQ Support
Messages
3,915
After typing out the wall of text below, I remembered a bug that was reported... (reason for the latest update)
I had the spreadsheet sheet names setup as string vars. The game has a string lookup table instead of storing strings individually. If another mod stores a string in the table first and the case is lost, the function to import the spreadsheet data will fail.

Anyway, I willing to bet if you update to the latest version and run the rebuild data tool in the holotape, you will be good to go. Also, make sure to turn on the option to allow actors to be rechecked. (also in the holotape) Most likely all the actors you have seen have been checked against an empty string array and had the DoNotRename keyword added.
I'm guessing it checks all names in a given cell(on load?) and if it's in the text for the npcs name is in the white list it renames it and would work even if the npc is dead.
There are 3 events that will trigger a rename attempt:
  1. actor loaded (story manager event)
  2. player entered combat
  3. actor added to workshop
The first 2 start a quest that grabs all actors in the loaded area that have not been checked before (do not have my custom keyword) then check their current name against the white list. If a match is found, rename actor and add keyword. 3 only checks the individual actor.
Here's an image of what I have directly installed into the game, with the only difference being the 'ExamineMenu' installed by FallUI(the marked items). At least from what I can tell. I also ran a quick 'conflict search' and only came up with scripts that seemed to be specific to the mod itself.
My mod doesn't do anything with the examinemenu.swf. That is an issue between Rename Anything and FallUI as they both edit the same file.
My mod is completely stand alone. It only adds new records. It makes use of Papyrus functions added by SUP_F4SE, Rename Anything and TIM. (Text Imput Menu) The only mod conflict would be a mod that edits Rename Anything Enhanced. (to my knowledge, none exist)
With these options is there a message that pops up showing when it's complete? or an ongoing status message about how far along it is in the renaming process?
No. I tried getting MCM to say "exit menu" when a button is pressed, but I could never get it to work properly. IIRC, you can't popup a message when the main menu is open. The renaming process itself is pretty quick. Unless the Papyrus VM is heavily loaded, it should only take 1 to 2 seconds max to complete.
It's there an console command like "getav" to show how many white list items are actually loaded? or a debug option I can set which will dump in the papyrus the steps the script is taking or if a rename fails, why?
You could try some console commands to check quest states.
help ms_ar 4 qust should list the quests.
I can't remember if my controller is *_main or *_mainquest but do sqv {MainQuestID} This will list the quest vars. At the top of the list, it should show the quest state. It should be "" if not, the quest failed to init. At the bottom it lists the current stage and quest status. Make sure its "running." (it should be as its flagged run on game start)
Do sqv ms_ar_renamemanager and make sure its running. If you scroll up there should be some string properties. Make sure these are not none. This is the data imported from the spreadsheet. When the system is toggled on, this data should be checked and rebuilt if needed.
 

Mystical Panda

Active Member
Messages
224
This isn't a script issue. A mod edited the leveled actor list adding this spider to it. If this added spider is flagged 'essential' you won't be able to kill it in game.
The SS2 quest script is listening for an actor is dead event > increment counter. When counter = target value > advance quest.
I'll doublecheck that this upcoming week, and this is definitely something that would need to be fixed.
 

Mystical Panda

Active Member
Messages
224
@msalaba Ok, I've checked to see if the strings are being loaded, and they appear to be. The script shows 'running'. I've also tried turning off, then back on renaming, rescanning the surrounding area for npcs to rename- nothing seems to work. I've attached an html table list from the installation manifest to show what has been installed. I know this didn't happen awhile back and there's been quite a few SUP updates. Unfortunately, I'm not sure when it stopped working as I didn't start a new test after each update- development time took that slice. One thing I'm going to try is the actual rename anything, and see if that works, as I'm thinking the 'layer' from ground to roof is SUP/Rename Anything/Rename Anything Extended and going towards SUP might help me see when or if renaming at any level will work. It could've been something I've done here, so I can't rule that out entirely until I can find a potential cause.

The attached manifest shows the order in which mods were installed.
 

Attachments

  • currentmanifest.html.txt
    151 KB · Views: 3

Mystical Panda

Active Member
Messages
224
Here's a quick update on renaming npcs- using Rename Anything by going into the console clicking on an npc and entering "setname Jackson", "setter" became "Jackson". So everything seems to work at at that software 'layer', which makes me wonder if it's "SUP" -> "Rename Anything Enhanced" related since "SUP" been updated quite a few times.
 
Last edited:

Mystical Panda

Active Member
Messages
224
Since this is like a 'documentation' log of an SS2 test, along with other mods(to help determine if they play nice together)- I have a question regarding build and resource limits. Lets say both the build and resource limits are capped and I, using Workshop Framework, up the build limit(doubling it), but the resource is still capped... will a settlement still build/upgrade if it's awaiting resources that can't be stored due a resource cap?
 

msalaba

Well-Known Member
Staff member
Community Rockstar
HQ Support
Messages
3,915
Here's a quick update on renaming npcs- using Rename Anything by going into the console clicking on an npc and entering "setname Jackson", "setter" became "Jackson". So everything seems to work at at that software 'layer', which makes me wonder if it's "SUP" -> "Rename Anything Enhanced" related since "SUP" been updated quite a few times.
Rename Anything Enhanced only utilizes SUP_F4SE, Rename Anything and TIM for the added Papyrus functions. If any of these dll and pex files are missing, you would get an error message on game load.
SUP_F4SE:
  • import / export xlsx data
Rename Anything
  • Get / Set name functions
TIM (Text Imput Menu)
  • Get user string input
I'm still using SUP_F4SE v5.00 as I don't require any of the newer added functions. I did contact the author about the sheet name bug I found. I don't see any changes to the functions I use being listed in the change log.

Did you turn on the Recheck Actors option in the holotape? I add a keyword to checked actors so they are never checked again unless this override option is turned on.
RAE Setting.jpg
 

msalaba

Well-Known Member
Staff member
Community Rockstar
HQ Support
Messages
3,915
Since this is like a 'documentation' log of an SS2 test, along with other mods(to help determine if they play nice together)- I have a question regarding build and resource limits. Lets say both the build and resource limits are capped and I, using Workshop Framework, up the build limit(doubling it), but the resource is still capped... will a settlement still build/upgrade if it's awaiting resources that can't be stored due a resource cap?
From what I understand, nether a plot nor city plan will upgrade if that settlement's build limit is maxed. However, there are settings to override this behavior.

When you say resource cap, are you talking about the SS2 virtual resources or workbench junk? For virtual resources, nether a plot nor city plan will upgrade if there are not enough resources within the linked caravan network. However, there are settings to override this behavior. I'm not sure if / when SS2 looks in the settlement workshop for junk. I can't say for certain as the workshop code is a little too complex for me to comprehend.
 

Mystical Panda

Active Member
Messages
224
Rename Anything Enhanced only utilizes SUP_F4SE, Rename Anything and TIM for the added Papyrus functions. If any of these dll and pex files are missing, you would get an error message on game load.
SUP_F4SE:
  • import / export xlsx data
Rename Anything
  • Get / Set name functions
TIM (Text Imput Menu)
  • Get user string input
I'm still using SUP_F4SE v5.00 as I don't require any of the newer added functions. I did contact the author about the sheet name bug I found. I don't see any changes to the functions I use being listed in the change log.

Did you turn on the Recheck Actors option in the holotape? I add a keyword to checked actors so they are never checked again unless this override option is turned on.
View attachment 18279
I tried that, but still nothing. I might have missed this the first time around- is this the problem? Where the vanilla names for the npcs aren't in their respective whitelists? It looks like the gunners/BOS have npc names to search for when renaming but nothing else does?
 

Attachments

  • renameanything.jpg
    renameanything.jpg
    143.7 KB · Views: 3
Last edited:
Top